summaryrefslogtreecommitdiffstats
path: root/meta-webserver/recipes-php/phpmyadmin/phpmyadmin_4.5.0.2.bb
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2015-10-15 10:21:05 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2015-10-23 12:53:23 +0200
commit4e8d16ea6e4144d710799abf81de840ff922c932 (patch)
treef61db124b0fc72ab9bfacf298e8647f88cd86c65 /meta-webserver/recipes-php/phpmyadmin/phpmyadmin_4.5.0.2.bb
parent2d1de436b198c4958e75c22942ba43cc06767fb2 (diff)
downloadmeta-openembedded-4e8d16ea6e4144d710799abf81de840ff922c932.tar.gz
phpmyadmin: 4.4.9 -> 4.5.0.2
Upgrade phpmyadmin from 4.4.9 to 4.5.0.2 and SRC_URI is updated. Accoring to release note, there is NO API changes for 4.5.0.x serial. So upgrade to 4.5.0.2 rather than 4.4.15 which will only support for security fixes only. And license file has some text update. See: https://github.com/phpmyadmin/phpmyadmin/commit/9d080a482fae73bde5049620088d4687da245163 Change files owner to fix [host-user-contaminated] warnings. Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-webserver/recipes-php/phpmyadmin/phpmyadmin_4.5.0.2.bb')
-rw-r--r--meta-webserver/recipes-php/phpmyadmin/phpmyadmin_4.5.0.2.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-webserver/recipes-php/phpmyadmin/phpmyadmin_4.5.0.2.bb b/meta-webserver/recipes-php/phpmyadmin/phpmyadmin_4.5.0.2.bb
new file mode 100644
index 000000000..e28b66a23
--- /dev/null
+++ b/meta-webserver/recipes-php/phpmyadmin/phpmyadmin_4.5.0.2.bb
@@ -0,0 +1,35 @@
1SUMMARY = "Web-based MySQL administration interface"
2HOMEPAGE = "http://www.phpmyadmin.net"
3# Main code is GPLv2, libraries/tcpdf is under LGPLv3, js/jquery is under MIT
4LICENSE = "GPLv2 & LGPLv3 & MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
6 file://libraries/tcpdf/LICENSE.TXT;md5=5c87b66a5358ebcc495b03e0afcd342c"
7
8SRC_URI = "https://files.phpmyadmin.net/phpMyAdmin/4.5.0.2/phpMyAdmin-4.5.0.2-all-languages.tar.xz \
9 file://apache.conf"
10
11SRC_URI[md5sum] = "2d08d2fcc8f70f88a11a14723e3ca275"
12SRC_URI[sha256sum] = "d2e90ea486d90b4ebe5eb02d7ad349ad2916c12a8981f98553395ef78d22a8ec"
13
14S = "${WORKDIR}/phpMyAdmin-${PV}-all-languages"
15
16inherit allarch
17
18do_install() {
19 install -d ${D}${datadir}/${BPN}
20 cp -a * ${D}${datadir}/${BPN}
21 chown -R root:root ${D}${datadir}/${BPN}
22 # Don't install patches to target
23 rm -rf ${D}${datadir}/${BPN}/patches
24
25 install -d ${D}${sysconfdir}/apache2/conf.d
26 install -m 0644 ${WORKDIR}/apache.conf ${D}${sysconfdir}/apache2/conf.d/phpmyadmin.conf
27
28 # Remove a few scripts that explicitly require bash (!)
29 rm -f ${D}${datadir}/phpmyadmin/libraries/transformations/*.sh
30}
31
32FILES_${PN} = "${datadir}/${BPN} \
33 ${sysconfdir}/apache2/conf.d"
34
35RDEPENDS_${PN} += "bash"