summaryrefslogtreecommitdiffstats
path: root/meta-webserver/recipes-php/phpmyadmin/phpmyadmin_4.5.0.2.bb
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2016-07-20 04:45:46 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2016-07-29 11:00:57 +0200
commit1a6e6a9d9670431e3c5e8485df78afc9530e8769 (patch)
treeeddf8a6ee710b30f9465b0c464746797b96db5fc /meta-webserver/recipes-php/phpmyadmin/phpmyadmin_4.5.0.2.bb
parentaa01ab95a374fd00a8cbde841ce0efffdada63c4 (diff)
downloadmeta-openembedded-1a6e6a9d9670431e3c5e8485df78afc9530e8769.tar.gz
phpmyadmin: upgrade to 4.6.3
* Compatible with PHP 5.5 to 7.0 and MySQL 5.5 and newer. * Release notes: http://www.phpmyadmin.net/files/4.6.3/ * Drop two CVE patches which have been fixed: CVE-2015-7873 and CVE-2015-8669 * Use PV in SRC_URI instead of hardcoded version number. Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-webserver/recipes-php/phpmyadmin/phpmyadmin_4.5.0.2.bb')
-rw-r--r--meta-webserver/recipes-php/phpmyadmin/phpmyadmin_4.5.0.2.bb38
1 files changed, 0 insertions, 38 deletions
diff --git a/meta-webserver/recipes-php/phpmyadmin/phpmyadmin_4.5.0.2.bb b/meta-webserver/recipes-php/phpmyadmin/phpmyadmin_4.5.0.2.bb
deleted file mode 100644
index ac321857b..000000000
--- a/meta-webserver/recipes-php/phpmyadmin/phpmyadmin_4.5.0.2.bb
+++ /dev/null
@@ -1,38 +0,0 @@
1SUMMARY = "Web-based MySQL administration interface"
2HOMEPAGE = "http://www.phpmyadmin.net"
3# Main code is GPLv2, libraries/tcpdf is under LGPLv3, js/jquery is under MIT
4LICENSE = "GPLv2 & LGPLv3 & MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
6 file://libraries/tcpdf/LICENSE.TXT;md5=5c87b66a5358ebcc495b03e0afcd342c"
7
8SRC_URI = "https://files.phpmyadmin.net/phpMyAdmin/4.5.0.2/phpMyAdmin-4.5.0.2-all-languages.tar.xz \
9 file://Port-content-spoofing-fix-CVE-2015-7873.patch \
10 file://apache.conf \
11 file://phpmyadmin-CVE-2015-8669.patch \
12"
13
14SRC_URI[md5sum] = "2d08d2fcc8f70f88a11a14723e3ca275"
15SRC_URI[sha256sum] = "d2e90ea486d90b4ebe5eb02d7ad349ad2916c12a8981f98553395ef78d22a8ec"
16
17S = "${WORKDIR}/phpMyAdmin-${PV}-all-languages"
18
19inherit allarch
20
21do_install() {
22 install -d ${D}${datadir}/${BPN}
23 cp -R --no-dereference --preserve=mode,links -v * ${D}${datadir}/${BPN}
24 chown -R root:root ${D}${datadir}/${BPN}
25 # Don't install patches to target
26 rm -rf ${D}${datadir}/${BPN}/patches
27
28 install -d ${D}${sysconfdir}/apache2/conf.d
29 install -m 0644 ${WORKDIR}/apache.conf ${D}${sysconfdir}/apache2/conf.d/phpmyadmin.conf
30
31 # Remove a few scripts that explicitly require bash (!)
32 rm -f ${D}${datadir}/phpmyadmin/libraries/transformations/*.sh
33}
34
35FILES_${PN} = "${datadir}/${BPN} \
36 ${sysconfdir}/apache2/conf.d"
37
38RDEPENDS_${PN} += "bash"