summaryrefslogtreecommitdiffstats
path: root/meta-webserver/recipes-httpd
diff options
context:
space:
mode:
authorTrevor Gamblin <trevor.gamblin@windriver.com>2020-04-17 07:21:55 -0700
committerKhem Raj <raj.khem@gmail.com>2020-04-17 19:05:58 -0700
commitb1aa5f785094d25765657f1df7db0748680ae7fb (patch)
treeb9a6e2e750779b841e25014453e7f3e918567659 /meta-webserver/recipes-httpd
parente9252506c3a7f05a99c2dc2fc4e0760bca9d4131 (diff)
downloadmeta-openembedded-b1aa5f785094d25765657f1df7db0748680ae7fb.tar.gz
apache2: add patch ensuring destdir is empty string
apache2 added cross-compilation support after 2.4.41, but this conflicts with our own cross-compilation setup and causes related recipes like apache-websocket to fail to find config files (due to incorrect file paths) during build: | cannot open /ala-lpggp31/tgamblin/yocto/poky.git/build/tmp/work/core2-64-poky-linux/apache-websocket/0.1.1+gitAUTOINC+6968083264-r0/recipe-sysroot/ala-lpggp31/tgamblin/yocto/poky.git/build/tmp/work/core2-64-poky-linux/apache-websocket/0.1.1+gitAUTOINC+6968083264-r0/recipe-sysroot//usr/share/apache2/build/config_vars.mk: No such file or directory at /ala-lpggp31/tgamblin/yocto/poky.git/build/tmp/work/core2-64-poky-linux/apache-websocket/0.1.1+gitAUTOINC+6968083264-r0/recipe-sysroot/usr/bin/crossscripts/apxs line 213. Add this patch to ensure that the $destdir variable used in apache2's cross-compilation scheme is always the empty string so that apache-websocket can find the right files. Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-webserver/recipes-httpd')
-rw-r--r--meta-webserver/recipes-httpd/apache2/apache2/0001-support-apxs.in-force-destdir-to-be-empty-string.patch49
-rw-r--r--meta-webserver/recipes-httpd/apache2/apache2_2.4.43.bb1
2 files changed, 50 insertions, 0 deletions
diff --git a/meta-webserver/recipes-httpd/apache2/apache2/0001-support-apxs.in-force-destdir-to-be-empty-string.patch b/meta-webserver/recipes-httpd/apache2/apache2/0001-support-apxs.in-force-destdir-to-be-empty-string.patch
new file mode 100644
index 000000000..bdedd146c
--- /dev/null
+++ b/meta-webserver/recipes-httpd/apache2/apache2/0001-support-apxs.in-force-destdir-to-be-empty-string.patch
@@ -0,0 +1,49 @@
1From 705c0a7e9d9c1e64ee09fc0b54f6b5a4e27de1ca Mon Sep 17 00:00:00 2001
2From: Trevor Gamblin <trevor.gamblin@windriver.com>
3Date: Fri, 17 Apr 2020 06:31:35 -0700
4Subject: [PATCH] support/apxs.in: force destdir to be empty string
5
6If destdir is assigned to anything other than the empty string, the
7search path for apache2 config files is appended to itself, and
8related packages like apache-websocket will be unable to locate them:
9
10| cannot open
11/ala-lpggp31/tgamblin/yocto/poky.git/build/tmp/work/core2-64-poky-linux/apache-websocket/0.1.1+gitAUTOINC+6968083264-r0/recipe-sysroot/ala-lpggp31/tgamblin/yocto/poky.git/build/tmp/work/core2-64-poky-linux/apache-websocket/0.1.1+gitAUTOINC+6968083264-r0/recipe-sysroot//usr/share/apache2/build/config_vars.mk:
12No such file or directory at
13/ala-lpggp31/tgamblin/yocto/poky.git/build/tmp/work/core2-64-poky-linux/apache-websocket/0.1.1+gitAUTOINC+6968083264-r0/recipe-sysroot/usr/bin/crossscripts/apxs
14line 213.
15
16Ensure that it is always the empty string so that apache-websocket
17is able to find the required config files.
18
19Upstream-Status: Inappropriate (embedded-specific)
20
21Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
22---
23 support/apxs.in | 10 ++++++----
24 1 file changed, 6 insertions(+), 4 deletions(-)
25
26diff --git a/support/apxs.in b/support/apxs.in
27index 65e1288527..9d96e33728 100644
28--- a/support/apxs.in
29+++ b/support/apxs.in
30@@ -28,10 +28,12 @@ package apxs;
31 # is the empty string.
32
33 my $destdir = "";
34-my $ddi = rindex($0, "@exp_bindir@");
35-if ($ddi >= 0) {
36- $destdir = substr($0, 0, $ddi);
37-}
38+# Comment out assignment of destdir so that it doesn't affect bitbake
39+# cross-compilation setup
40+#my $ddi = rindex($0, "@exp_bindir@");
41+#if ($ddi >= 0) {
42+# $destdir = substr($0, 0, $ddi);
43+#}
44
45 my %config_vars = ();
46
47--
482.17.1
49
diff --git a/meta-webserver/recipes-httpd/apache2/apache2_2.4.43.bb b/meta-webserver/recipes-httpd/apache2/apache2_2.4.43.bb
index 2fff153fc..520011152 100644
--- a/meta-webserver/recipes-httpd/apache2/apache2_2.4.43.bb
+++ b/meta-webserver/recipes-httpd/apache2/apache2_2.4.43.bb
@@ -14,6 +14,7 @@ SRC_URI = "${APACHE_MIRROR}/httpd/httpd-${PV}.tar.bz2 \
14 file://0006-apache2-fix-the-race-issue-of-parallel-installation.patch \ 14 file://0006-apache2-fix-the-race-issue-of-parallel-installation.patch \
15 file://0007-apache2-allow-to-disable-selinux-support.patch \ 15 file://0007-apache2-allow-to-disable-selinux-support.patch \
16 file://apache-configure_perlbin.patch \ 16 file://apache-configure_perlbin.patch \
17 file://0001-support-apxs.in-force-destdir-to-be-empty-string.patch \
17 " 18 "
18 19
19SRC_URI_append_class-target = " \ 20SRC_URI_append_class-target = " \