summaryrefslogtreecommitdiffstats
path: root/meta-webserver/recipes-httpd/apache2/apache2-native_2.4.23.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2016-07-13 08:46:59 -0400
committerArmin Kuster <akuster808@gmail.com>2016-08-16 10:29:41 -0700
commit77fa6a7ca6687c9b4014ff7c4d9fd0147bdace4e (patch)
tree4a252d692392311f573517378e71ee044fa17a3c /meta-webserver/recipes-httpd/apache2/apache2-native_2.4.23.bb
parent5490337a5e8e85541bbc14845fe0bc358583abee (diff)
downloadmeta-openembedded-77fa6a7ca6687c9b4014ff7c4d9fd0147bdace4e.tar.gz
apache2: update to version 2.4.23
This update is mostly bug fixes. Includes: CVE-2016-4979 and CVE-2016-5387 and is why I merged from master. Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> (cherry picked from commit 7707dd5bc82583e4cc41ae3080b40d0d6ede8a45) Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-webserver/recipes-httpd/apache2/apache2-native_2.4.23.bb')
-rw-r--r--meta-webserver/recipes-httpd/apache2/apache2-native_2.4.23.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/meta-webserver/recipes-httpd/apache2/apache2-native_2.4.23.bb b/meta-webserver/recipes-httpd/apache2/apache2-native_2.4.23.bb
new file mode 100644
index 000000000..b227f191d
--- /dev/null
+++ b/meta-webserver/recipes-httpd/apache2/apache2-native_2.4.23.bb
@@ -0,0 +1,45 @@
1DESCRIPTION = "The Apache HTTP Server is a powerful, efficient, and \
2extensible web server."
3SUMMARY = "Apache HTTP Server"
4HOMEPAGE = "http://httpd.apache.org/"
5DEPENDS = "expat-native pcre-native apr-native apr-util-native"
6SECTION = "net"
7LICENSE = "Apache-2.0"
8
9inherit autotools pkgconfig native
10
11SRC_URI = "http://www.apache.org/dist/httpd/httpd-${PV}.tar.bz2 \
12 file://0001-configure-use-pkg-config-for-PCRE-detection.patch \
13 "
14
15S = "${WORKDIR}/httpd-${PV}"
16
17LIC_FILES_CHKSUM = "file://LICENSE;md5=dbff5a2b542fa58854455bf1a0b94b83"
18SRC_URI[md5sum] = "04f19c60e810c028f5240a062668a688"
19SRC_URI[sha256sum] = "0c1694b2aad7765896faf92843452ee2555b9591ae10d4f19b245f2adfe85e58"
20
21EXTRA_OECONF = "--with-apr=${STAGING_BINDIR_CROSS}/apr-1-config \
22 --with-apr-util=${STAGING_BINDIR_CROSS}/apu-1-config \
23 --prefix=${prefix} --datadir=${datadir}/apache2 \
24 "
25
26do_install () {
27 install -d ${D}${bindir} ${D}${libdir}
28 cp server/gen_test_char ${D}${bindir}
29 install -m 755 support/apxs ${D}${bindir}/
30 install -m 755 httpd ${D}${bindir}/
31 install -d ${D}${datadir}/apache2/build
32 cp ${S}/build/*.mk ${D}${datadir}/apache2/build
33 cp build/*.mk ${D}${datadir}/apache2/build
34 cp ${S}/build/instdso.sh ${D}${datadir}/apache2/build
35
36 install -d ${D}${includedir}/apache2
37 cp ${S}/include/* ${D}${includedir}/apache2
38 cp include/* ${D}${includedir}/apache2
39 cp ${S}/os/unix/os.h ${D}${includedir}/apache2
40 cp ${S}/os/unix/unixd.h ${D}${includedir}/apache2
41
42 cp support/envvars-std ${D}${bindir}/envvars
43 chmod 755 ${D}${bindir}/envvars
44}
45