summaryrefslogtreecommitdiffstats
path: root/meta-systemd/recipes-core
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2012-07-21 08:05:07 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-07-23 12:47:04 +0200
commit3c488a49b512afd25c4b696e7b688af516dc6513 (patch)
tree5541bce24670723da310222fe2a0ae8a891d1c00 /meta-systemd/recipes-core
parenta2f5ec73d665006251c2d9756500df018ff3b403 (diff)
downloadmeta-openembedded-3c488a49b512afd25c4b696e7b688af516dc6513.tar.gz
systemd: cleanup /var/run on boot and create /var/run/utmp
* Angstrom uses /var/run cleanup because: Some apps (e.g. avahi-daemon) to clean up their old-style pid files and fail to start every other boot. Se we let systemd clean it on boot. Which seems general enough, so lets move var-run.conf from base-files.bbappend to systemd recipe. * /var/run/utmp was created by volatiles before, but without sysvinit installed systemd-update-utmp-runlevel.service fails to start without this file Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-systemd/recipes-core')
-rw-r--r--meta-systemd/recipes-core/systemd/systemd/var-run.conf4
-rw-r--r--meta-systemd/recipes-core/systemd/systemd_git.bb5
2 files changed, 8 insertions, 1 deletions
diff --git a/meta-systemd/recipes-core/systemd/systemd/var-run.conf b/meta-systemd/recipes-core/systemd/systemd/var-run.conf
new file mode 100644
index 000000000..c2c18e2b9
--- /dev/null
+++ b/meta-systemd/recipes-core/systemd/systemd/var-run.conf
@@ -0,0 +1,4 @@
1# empty /var/run
2R /var/run/* - - - - -
3# systemd-update-utmp-runlevel.service fails to start without this
4f /var/run/utmp 0644 root root - -
diff --git a/meta-systemd/recipes-core/systemd/systemd_git.bb b/meta-systemd/recipes-core/systemd/systemd_git.bb
index 9cbdd76c1..386843845 100644
--- a/meta-systemd/recipes-core/systemd/systemd_git.bb
+++ b/meta-systemd/recipes-core/systemd/systemd_git.bb
@@ -19,7 +19,7 @@ inherit gitpkgv
19PKGV = "v${GITPKGVTAG}" 19PKGV = "v${GITPKGVTAG}"
20 20
21PV = "git" 21PV = "git"
22PR = "r2" 22PR = "r3"
23 23
24inherit useradd pkgconfig autotools vala perlnative 24inherit useradd pkgconfig autotools vala perlnative
25 25
@@ -29,6 +29,7 @@ SRC_URI = "git://anongit.freedesktop.org/systemd/systemd;protocol=git \
29 file://gtk-doc.make \ 29 file://gtk-doc.make \
30 file://touchscreen.rules \ 30 file://touchscreen.rules \
31 file://modprobe.rules \ 31 file://modprobe.rules \
32 file://var-run.conf \
32 " 33 "
33LDFLAGS_libc-uclibc_append = " -lrt" 34LDFLAGS_libc-uclibc_append = " -lrt"
34 35
@@ -82,6 +83,8 @@ do_install() {
82 touch ${D}${sysconfdir}/machine-id 83 touch ${D}${sysconfdir}/machine-id
83 84
84 install -m 0644 ${WORKDIR}/*.rules ${D}${sysconfdir}/udev/rules.d/ 85 install -m 0644 ${WORKDIR}/*.rules ${D}${sysconfdir}/udev/rules.d/
86
87 install -m 0644 ${WORKDIR}/var-run.conf ${D}${sysconfdir}/tmpfiles.d/
85} 88}
86 89
87python populate_packages_prepend (){ 90python populate_packages_prepend (){