summaryrefslogtreecommitdiffstats
path: root/meta-systemd/oe-core
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-12 13:20:16 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-12 18:50:15 +0200
commitf195081bd0d52f72e0a8b54dc48d47624a1ebbbe (patch)
treea747c71bbcb763987cc8ad1926f47ba861d01a17 /meta-systemd/oe-core
parenta179ca25a4223bab312d2717fce63a7b160dc769 (diff)
downloadmeta-openembedded-f195081bd0d52f72e0a8b54dc48d47624a1ebbbe.tar.gz
meta-systemd: move cronie to oe-core subdirectory
Diffstat (limited to 'meta-systemd/oe-core')
-rw-r--r--meta-systemd/oe-core/recipes-extended/cronie/cronie/crond.service10
-rw-r--r--meta-systemd/oe-core/recipes-extended/cronie/cronie_1.4.9.bbappend17
2 files changed, 27 insertions, 0 deletions
diff --git a/meta-systemd/oe-core/recipes-extended/cronie/cronie/crond.service b/meta-systemd/oe-core/recipes-extended/cronie/cronie/crond.service
new file mode 100644
index 000000000..5ae193bfc
--- /dev/null
+++ b/meta-systemd/oe-core/recipes-extended/cronie/cronie/crond.service
@@ -0,0 +1,10 @@
1[Unit]
2Description=Periodic Command Scheduler
3
4[Service]
5ExecStart=/usr/sbin/crond -n
6ExecReload=/bin/kill -HUP $MAINPID
7Restart=always
8
9[Install]
10WantedBy=multi-user.target
diff --git a/meta-systemd/oe-core/recipes-extended/cronie/cronie_1.4.9.bbappend b/meta-systemd/oe-core/recipes-extended/cronie/cronie_1.4.9.bbappend
new file mode 100644
index 000000000..418836fc2
--- /dev/null
+++ b/meta-systemd/oe-core/recipes-extended/cronie/cronie_1.4.9.bbappend
@@ -0,0 +1,17 @@
1# look for files in the layer first
2FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
3
4PRINC := "${@int(PRINC) + 3}"
5
6inherit systemd
7
8RPROVIDES_${PN} += "${PN}-systemd"
9SYSTEMD_SERVICE_${PN} = "crond.service"
10
11SRC_URI += "file://crond.service"
12
13do_install_append() {
14 install -d ${D}${systemd_unitdir}/system
15 install -m 0644 ${WORKDIR}/crond.service ${D}${systemd_unitdir}/system
16}
17