diff options
author | Paul Eggleton <paul.eggleton@linux.intel.com> | 2014-09-17 15:26:07 +0100 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2014-09-26 05:41:52 +0200 |
commit | dee376383721781118c6115a4593ad969e0830c1 (patch) | |
tree | 371483d8ff97166224cce46729aa772164681218 /meta-systemd/oe-core | |
parent | 1956582b91afda4612f0e4c84ab59826a3e1a2c1 (diff) | |
download | meta-openembedded-dee376383721781118c6115a4593ad969e0830c1.tar.gz |
portmap: systemd support now in OE-Core
Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'meta-systemd/oe-core')
-rw-r--r-- | meta-systemd/oe-core/recipes-connectivity/portmap/portmap/portmap.service | 10 | ||||
-rw-r--r-- | meta-systemd/oe-core/recipes-connectivity/portmap/portmap_6.0.bbappend | 11 |
2 files changed, 0 insertions, 21 deletions
diff --git a/meta-systemd/oe-core/recipes-connectivity/portmap/portmap/portmap.service b/meta-systemd/oe-core/recipes-connectivity/portmap/portmap/portmap.service deleted file mode 100644 index cffb56c1d..000000000 --- a/meta-systemd/oe-core/recipes-connectivity/portmap/portmap/portmap.service +++ /dev/null | |||
@@ -1,10 +0,0 @@ | |||
1 | [Unit] | ||
2 | Description=Portmap | ||
3 | |||
4 | [Service] | ||
5 | Type=oneshot | ||
6 | ExecStart=/sbin/portmap -l | ||
7 | RemainAfterExit=yes | ||
8 | |||
9 | [Install] | ||
10 | WantedBy=multi-user.target | ||
diff --git a/meta-systemd/oe-core/recipes-connectivity/portmap/portmap_6.0.bbappend b/meta-systemd/oe-core/recipes-connectivity/portmap/portmap_6.0.bbappend index f13b51187..6ce6e70d9 100644 --- a/meta-systemd/oe-core/recipes-connectivity/portmap/portmap_6.0.bbappend +++ b/meta-systemd/oe-core/recipes-connectivity/portmap/portmap_6.0.bbappend | |||
@@ -1,16 +1,5 @@ | |||
1 | FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:" | ||
2 | |||
3 | inherit systemd | ||
4 | |||
5 | RPROVIDES_${PN} += "${PN}-systemd" | 1 | RPROVIDES_${PN} += "${PN}-systemd" |
6 | RREPLACES_${PN} += "${PN}-systemd" | 2 | RREPLACES_${PN} += "${PN}-systemd" |
7 | RCONFLICTS_${PN} += "${PN}-systemd" | 3 | RCONFLICTS_${PN} += "${PN}-systemd" |
8 | SYSTEMD_SERVICE_${PN} = "portmap.service" | ||
9 | SYSTEMD_AUTO_ENABLE = "disable" | 4 | SYSTEMD_AUTO_ENABLE = "disable" |
10 | 5 | ||
11 | SRC_URI_append = " file://portmap.service" | ||
12 | |||
13 | do_install_append() { | ||
14 | install -d ${D}${systemd_unitdir}/system | ||
15 | install -m 0644 ${WORKDIR}/portmap.service ${D}${systemd_unitdir}/system | ||
16 | } | ||