summaryrefslogtreecommitdiffstats
path: root/meta-systemd/oe-core
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2012-09-20 09:43:26 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2012-11-13 12:58:07 +0100
commit4a87464fa6cbd4a3c292509fcca40267ddcbbad1 (patch)
tree5c4b640929d09b46672f67960dc7b5e0081311a4 /meta-systemd/oe-core
parent87d5eaf8a336516c22ec4a498ed40b9983306496 (diff)
downloadmeta-openembedded-4a87464fa6cbd4a3c292509fcca40267ddcbbad1.tar.gz
lighttpd: move systemd appends since recipe is in oe-core
Diffstat (limited to 'meta-systemd/oe-core')
-rw-r--r--meta-systemd/oe-core/recipes-extended/lighttpd/lighttpd/lighttpd.service13
-rw-r--r--meta-systemd/oe-core/recipes-extended/lighttpd/lighttpd_1.4.31.bbappend10
2 files changed, 23 insertions, 0 deletions
diff --git a/meta-systemd/oe-core/recipes-extended/lighttpd/lighttpd/lighttpd.service b/meta-systemd/oe-core/recipes-extended/lighttpd/lighttpd/lighttpd.service
new file mode 100644
index 000000000..f4564f3f7
--- /dev/null
+++ b/meta-systemd/oe-core/recipes-extended/lighttpd/lighttpd/lighttpd.service
@@ -0,0 +1,13 @@
1[Unit]
2Description=Lightning Fast Webserver With Light System Requirements
3After=syslog.target
4
5[Service]
6Type=oneshot
7EnvironmentFile=-/etc/sysconfig/lighttpd
8ExecStart=/usr/sbin/lighttpd -D -f /etc/lighttpd.conf
9RemainAfterExit=yes
10
11[Install]
12WantedBy=multi-user.target
13
diff --git a/meta-systemd/oe-core/recipes-extended/lighttpd/lighttpd_1.4.31.bbappend b/meta-systemd/oe-core/recipes-extended/lighttpd/lighttpd_1.4.31.bbappend
new file mode 100644
index 000000000..b016bdc2f
--- /dev/null
+++ b/meta-systemd/oe-core/recipes-extended/lighttpd/lighttpd_1.4.31.bbappend
@@ -0,0 +1,10 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3PRINC := "${@int(PRINC) + 2}"
4
5inherit systemd
6
7SRC_URI += "file://lighttpd.service"
8
9SYSTEMD_PACKAGES = "${PN}"
10SYSTEMD_SERVICE_${PN} = "lighttpd.service"