summaryrefslogtreecommitdiffstats
path: root/meta-systemd/oe-core
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2013-02-13 17:25:35 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-12 18:49:55 +0200
commit313f0ae25925caead4f588695ac9c9bcf00b2755 (patch)
tree1c167bd3cecfa253e438fefd045db110e2fa4cad /meta-systemd/oe-core
parent0afa2a51d2720ed1d6c06aaef17bd90248ef650e (diff)
downloadmeta-openembedded-313f0ae25925caead4f588695ac9c9bcf00b2755.tar.gz
meta-systemd: Append ${PN} to SYSTEMD_SERVICE
When using systemd class from OE-Core we also need to install the units explicitly. systemd packages ending with -systemd are consumed and now provided by package proper. MJ: fix RPROVIDES_PN = PN-systemd in entrance MJ: add RPROVIDES for ntp*-systemd in ntp MJ: the same for wpa-supplicant Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-systemd/oe-core')
-rw-r--r--meta-systemd/oe-core/recipes-connectivity/avahi/avahi_0.6.31.bbappend7
-rw-r--r--meta-systemd/oe-core/recipes-connectivity/bluez/bluez4_4.101.bbappend5
-rw-r--r--meta-systemd/oe-core/recipes-connectivity/connman/connman_1.12.bbappend5
-rw-r--r--meta-systemd/oe-core/recipes-connectivity/dhcp/dhcp_4.2.5.bbappend22
-rw-r--r--meta-systemd/oe-core/recipes-connectivity/ofono/ofono_1.12.bbappend5
-rw-r--r--meta-systemd/oe-core/recipes-connectivity/openssh/openssh_6.1p1.bbappend13
-rw-r--r--meta-systemd/oe-core/recipes-connectivity/portmap/portmap_6.0.bbappend10
-rw-r--r--meta-systemd/oe-core/recipes-connectivity/wpa-supplicant/wpa-supplicant_2.0.bbappend16
-rw-r--r--meta-systemd/oe-core/recipes-core/util-linux/util-linux_2.22.2.bbappend5
-rw-r--r--meta-systemd/oe-core/recipes-extended/lighttpd/lighttpd_1.4.32.bbappend7
10 files changed, 62 insertions, 33 deletions
diff --git a/meta-systemd/oe-core/recipes-connectivity/avahi/avahi_0.6.31.bbappend b/meta-systemd/oe-core/recipes-connectivity/avahi/avahi_0.6.31.bbappend
index d41ca93bf..ec0f08d93 100644
--- a/meta-systemd/oe-core/recipes-connectivity/avahi/avahi_0.6.31.bbappend
+++ b/meta-systemd/oe-core/recipes-connectivity/avahi/avahi_0.6.31.bbappend
@@ -2,8 +2,9 @@ PRINC := "${@int(PRINC) + 1}"
2 2
3inherit systemd 3inherit systemd
4 4
5SYSTEMD_PACKAGES = "${PN}-systemd" 5SYSTEMD_PACKAGES = "${PN}"
6SYSTEMD_SERVICE = "avahi-daemon.service" 6RPROVIDES_${PN} += "${PN}-systemd"
7SYSTEMD_SERVICE_${PN} = "avahi-daemon.service"
7SYSTEMD_AUTO_ENABLE = "enable" 8SYSTEMD_AUTO_ENABLE = "enable"
8 9
9FILES_${PN}-systemd += "${systemd_unitdir}/system/" 10FILES_${PN} += "${systemd_unitdir}/system/"
diff --git a/meta-systemd/oe-core/recipes-connectivity/bluez/bluez4_4.101.bbappend b/meta-systemd/oe-core/recipes-connectivity/bluez/bluez4_4.101.bbappend
index 8945a6da7..004c4945a 100644
--- a/meta-systemd/oe-core/recipes-connectivity/bluez/bluez4_4.101.bbappend
+++ b/meta-systemd/oe-core/recipes-connectivity/bluez/bluez4_4.101.bbappend
@@ -4,6 +4,7 @@ inherit systemd
4 4
5EXTRA_OECONF += "--with-systemdunitdir=${systemd_unitdir}/system/" 5EXTRA_OECONF += "--with-systemdunitdir=${systemd_unitdir}/system/"
6 6
7SYSTEMD_PACKAGES = "${PN}-systemd" 7SYSTEMD_PACKAGES = "${PN}"
8SYSTEMD_SERVICE = "bluetooth.service" 8RPROVIDES_${PN} += "${PN}-systemd"
9SYSTEMD_SERVICE_${PN} = "bluetooth.service"
9SYSTEMD_AUTO_ENABLE = "disable" 10SYSTEMD_AUTO_ENABLE = "disable"
diff --git a/meta-systemd/oe-core/recipes-connectivity/connman/connman_1.12.bbappend b/meta-systemd/oe-core/recipes-connectivity/connman/connman_1.12.bbappend
index b94f84b2f..37c0d2919 100644
--- a/meta-systemd/oe-core/recipes-connectivity/connman/connman_1.12.bbappend
+++ b/meta-systemd/oe-core/recipes-connectivity/connman/connman_1.12.bbappend
@@ -1,4 +1,5 @@
1PRINC := "${@int(PRINC) + 1}" 1PRINC := "${@int(PRINC) + 1}"
2 2
3SYSTEMD_PACKAGES = "${PN}-systemd" 3SYSTEMD_PACKAGES = "${PN}"
4SYSTEMD_SERVICE_${PN}-systemd = "connman.service" 4RPROVIDES_${PN} += "${PN}-systemd"
5SYSTEMD_SERVICE_${PN} = "connman.service"
diff --git a/meta-systemd/oe-core/recipes-connectivity/dhcp/dhcp_4.2.5.bbappend b/meta-systemd/oe-core/recipes-connectivity/dhcp/dhcp_4.2.5.bbappend
index fde242659..aec1dfbe9 100644
--- a/meta-systemd/oe-core/recipes-connectivity/dhcp/dhcp_4.2.5.bbappend
+++ b/meta-systemd/oe-core/recipes-connectivity/dhcp/dhcp_4.2.5.bbappend
@@ -5,12 +5,26 @@ inherit systemd
5 5
6PRINC := "${@int(PRINC) + 1}" 6PRINC := "${@int(PRINC) + 1}"
7 7
8SYSTEMD_PACKAGES = "dhcp-server-systemd dhcp-relay-systemd dhcp-client-systemd" 8SYSTEMD_PACKAGES = "dhcp-server dhcp-relay dhcp-client"
9SYSTEMD_SERVICE_dhcp-server-systemd = "dhcpd.service" 9SYSTEMD_SERVICE_dhcp-server = "dhcpd.service"
10SYSTEMD_SERVICE_dhcp-relay-systemd = "dhcrelay.service" 10SYSTEMD_SERVICE_dhcp-relay = "dhcrelay.service"
11SYSTEMD_SERVICE_dhcp-client-systemd = "dhclient.service" 11SYSTEMD_SERVICE_dhcp-client = "dhclient.service"
12
13FILES_dhcp-server += "${systemd_unitdir}/system/dhcpd.service"
14FILES_dhcp-relay += "${systemd_unitdir}/system/dhrelay.service"
15FILES_dhcp-client += "${systemd_unitdir}/system/dhclient.service"
16RPROVIDES_dhcp-server += "dhcp-server-systemd"
17RPROVIDES_dhcp-relay += "dhcp-relay-systemd"
18RPROVIDES_dhcp-client += "dhcp-client-systemd"
12 19
13SRC_URI += "file://dhcpd.service \ 20SRC_URI += "file://dhcpd.service \
14 file://dhclient.service \ 21 file://dhclient.service \
15 file://dhcrelay.service \ 22 file://dhcrelay.service \
16 " 23 "
24do_install_append() {
25 install -d ${D}${systemd_unitdir}/system
26 install -m 0644 ${WORKDIR}/dhcpd.service ${D}${systemd_unitdir}/system
27 install -m 0644 ${WORKDIR}/dhclient.service ${D}${systemd_unitdir}/system
28 install -m 0644 ${WORKDIR}/dhcrelay.service ${D}${systemd_unitdir}/system
29}
30
diff --git a/meta-systemd/oe-core/recipes-connectivity/ofono/ofono_1.12.bbappend b/meta-systemd/oe-core/recipes-connectivity/ofono/ofono_1.12.bbappend
index a061b52c5..992370801 100644
--- a/meta-systemd/oe-core/recipes-connectivity/ofono/ofono_1.12.bbappend
+++ b/meta-systemd/oe-core/recipes-connectivity/ofono/ofono_1.12.bbappend
@@ -2,6 +2,7 @@ PRINC := "${@int(PRINC) + 1}"
2 2
3inherit systemd 3inherit systemd
4 4
5SYSTEMD_PACKAGES = "${PN}-systemd" 5SYSTEMD_PACKAGES = "${PN}"
6SYSTEMD_SERVICE = "ofono.service" 6RPROVIDES_${PN} += "${PN}-systemd"
7SYSTEMD_SERVICE_${PN} = "ofono.service"
7SYSTEMD_AUTO_ENABLE = "disable" 8SYSTEMD_AUTO_ENABLE = "disable"
diff --git a/meta-systemd/oe-core/recipes-connectivity/openssh/openssh_6.1p1.bbappend b/meta-systemd/oe-core/recipes-connectivity/openssh/openssh_6.1p1.bbappend
index a4590657d..fe5c91906 100644
--- a/meta-systemd/oe-core/recipes-connectivity/openssh/openssh_6.1p1.bbappend
+++ b/meta-systemd/oe-core/recipes-connectivity/openssh/openssh_6.1p1.bbappend
@@ -2,9 +2,18 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3PRINC := "${@int(PRINC) + 1}" 3PRINC := "${@int(PRINC) + 1}"
4 4
5SYSTEMD_PACKAGES = "openssh-sshd-systemd" 5SYSTEMD_PACKAGES = "openssh-sshd"
6SYSTEMD_SERVICE = "sshd.socket" 6SYSTEMD_SERVICE_openssh-sshd = "sshd.socket"
7FILES_openssh-sshd += "${systemd_unitdir}/system/sshd.socket"
8RPROVIDES_openssh-sshd += "openssh-sshd-systemd"
7 9
8inherit systemd 10inherit systemd
9 11
10SRC_URI += "file://sshd.socket file://sshd@.service file://sshdgenkeys.service" 12SRC_URI += "file://sshd.socket file://sshd@.service file://sshdgenkeys.service"
13do_install_append() {
14 install -d ${D}${systemd_unitdir}/system
15 install -m 0644 ${WORKDIR}/sshd.socket ${D}${systemd_unitdir}/system
16 install -m 0644 ${WORKDIR}/sshd@.service ${D}${systemd_unitdir}/system
17 install -m 0644 ${WORKDIR}/sshdgenkeys.service ${D}${systemd_unitdir}/system
18}
19
diff --git a/meta-systemd/oe-core/recipes-connectivity/portmap/portmap_6.0.bbappend b/meta-systemd/oe-core/recipes-connectivity/portmap/portmap_6.0.bbappend
index c0276a391..281c44043 100644
--- a/meta-systemd/oe-core/recipes-connectivity/portmap/portmap_6.0.bbappend
+++ b/meta-systemd/oe-core/recipes-connectivity/portmap/portmap_6.0.bbappend
@@ -4,8 +4,14 @@ PRINC := "${@int(PRINC) + 1}"
4 4
5inherit systemd 5inherit systemd
6 6
7SYSTEMD_PACKAGES = "${PN}-systemd" 7SYSTEMD_PACKAGES = "${PN}"
8SYSTEMD_SERVICE = "portmap.service" 8RPROVIDES_${PN} += "${PN}-systemd"
9SYSTEMD_SERVICE_${PN} = "portmap.service"
9SYSTEMD_AUTO_ENABLE = "disable" 10SYSTEMD_AUTO_ENABLE = "disable"
10 11
11SRC_URI_append = " file://portmap.service" 12SRC_URI_append = " file://portmap.service"
13do_install_append() {
14 install -d ${D}${systemd_unitdir}/system
15 install -m 0644 ${WORKDIR}/portmap.service ${D}${systemd_unitdir}/system
16}
17
diff --git a/meta-systemd/oe-core/recipes-connectivity/wpa-supplicant/wpa-supplicant_2.0.bbappend b/meta-systemd/oe-core/recipes-connectivity/wpa-supplicant/wpa-supplicant_2.0.bbappend
index a94b00725..d0ce87eb0 100644
--- a/meta-systemd/oe-core/recipes-connectivity/wpa-supplicant/wpa-supplicant_2.0.bbappend
+++ b/meta-systemd/oe-core/recipes-connectivity/wpa-supplicant/wpa-supplicant_2.0.bbappend
@@ -1,15 +1,3 @@
1PRINC := "${@int(PRINC) + 2}" 1PRINC := "${@int(PRINC) + 3}"
2 2
3inherit systemd 3RPROVIDES_${PN} += "${PN}-systemd"
4
5SYSTEMD_PACKAGES = "${PN}-systemd"
6SYSTEMD_SERVICE = "wpa_supplicant.service"
7SYSTEMD_AUTO_ENABLE = "disable"
8
9do_install_append () {
10 install -d ${D}${systemd_unitdir}/system
11 install -m 644 ${S}/wpa_supplicant/systemd/*.service ${D}${systemd_unitdir}/system
12}
13
14# systemd.bbclass does not catch all multiple-instance-service-files
15FILES_${PN}-systemd += "${systemd_unitdir}/system/"
diff --git a/meta-systemd/oe-core/recipes-core/util-linux/util-linux_2.22.2.bbappend b/meta-systemd/oe-core/recipes-core/util-linux/util-linux_2.22.2.bbappend
index 809a55439..e0b1abaf7 100644
--- a/meta-systemd/oe-core/recipes-core/util-linux/util-linux_2.22.2.bbappend
+++ b/meta-systemd/oe-core/recipes-core/util-linux/util-linux_2.22.2.bbappend
@@ -4,5 +4,6 @@ PRINC := "${@int(PRINC) + 1}"
4 4
5SYSTEMD_UNITDIR = "${systemd_unitdir}/system" 5SYSTEMD_UNITDIR = "${systemd_unitdir}/system"
6EXTRA_OECONF += "--enable-socket-activation --with-systemdsystemunitdir=${SYSTEMD_UNITDIR}" 6EXTRA_OECONF += "--enable-socket-activation --with-systemdsystemunitdir=${SYSTEMD_UNITDIR}"
7SYSTEMD_PACKAGES = "${PN}-systemd" 7SYSTEMD_PACKAGES = "${PN}"
8SYSTEMD_SERVICE = "uuidd.socket" 8RPROVIDES_${PN} += "${PN}-systemd"
9SYSTEMD_SERVICE_${PN} = "uuidd.socket"
diff --git a/meta-systemd/oe-core/recipes-extended/lighttpd/lighttpd_1.4.32.bbappend b/meta-systemd/oe-core/recipes-extended/lighttpd/lighttpd_1.4.32.bbappend
index 0e08358b2..89079dcae 100644
--- a/meta-systemd/oe-core/recipes-extended/lighttpd/lighttpd_1.4.32.bbappend
+++ b/meta-systemd/oe-core/recipes-extended/lighttpd/lighttpd_1.4.32.bbappend
@@ -7,4 +7,11 @@ inherit systemd
7SRC_URI += "file://lighttpd.service" 7SRC_URI += "file://lighttpd.service"
8 8
9SYSTEMD_PACKAGES = "${PN}" 9SYSTEMD_PACKAGES = "${PN}"
10RPROVIDES_${PN} += "${PN}-systemd"
10SYSTEMD_SERVICE_${PN} = "lighttpd.service" 11SYSTEMD_SERVICE_${PN} = "lighttpd.service"
12
13do_install_append() {
14 install -d ${D}${systemd_unitdir}/system
15 install -m 0644 ${WORKDIR}/lighttpd.service ${D}${systemd_unitdir}/system
16}
17