summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorLi xin <lixin.fnst@cn.fujitsu.com>2015-12-30 12:01:50 +0300
committerMartin Jansa <Martin.Jansa@gmail.com>2016-01-04 14:56:41 +0100
commitfb1696372ff9de3bc08c25b2b766ecb7e45a5284 (patch)
tree916521ac4402481e0f704f5241511ff93a4ec398 /meta-python
parenta26902970c8361d06f0a368a5c487a568cdea77e (diff)
downloadmeta-openembedded-fb1696372ff9de3bc08c25b2b766ecb7e45a5284.tar.gz
python-vcversioner: Error Fix for recipes depend on python-vcversioner.
If you bitbake recipes which depends on python-vcversioner such as python-jsonschema. And also your network is not very well. Error will occur as following: Download error on https://pypi.python.org/simple/vcversioner/: [Errno -5] No address associated with hostname -- Some packages may not be found! Couldn't find index page for 'vcversioner' (maybe misspelled?) No local packages or download links found for vcversioner So add do_compile_append() to fix it. Signed-off-by: Li Xin <lixin.fnst@cn.fujitsu.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-vcversioner_2.14.0.0.bb9
1 files changed, 9 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-vcversioner_2.14.0.0.bb b/meta-python/recipes-devtools/python/python-vcversioner_2.14.0.0.bb
index f7cd9bb78..152034b4c 100644
--- a/meta-python/recipes-devtools/python/python-vcversioner_2.14.0.0.bb
+++ b/meta-python/recipes-devtools/python/python-vcversioner_2.14.0.0.bb
@@ -12,3 +12,12 @@ S = "${WORKDIR}/vcversioner-${PV}"
12 12
13inherit setuptools 13inherit setuptools
14 14
15
16do_compile_append() {
17 export BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS}
18 ${PYTHON} setup.py -q bdist_egg --dist-dir ./
19}
20
21do_install_append() {
22 install -m 0644 ${S}/vcversioner*.egg ${D}/${PYTHON_SITEPACKAGES_DIR}/
23}