summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-03-23 18:33:16 +0200
committerKhem Raj <raj.khem@gmail.com>2021-03-24 08:50:45 -0700
commitf6f05d19fdab287af016c73c0746d98f56141522 (patch)
tree67c3550c776a0b6f6e9a44c06b4e4f5984b3909b /meta-python
parentae6d145e3b9a621f8a8cacd12815b0b436c8cc29 (diff)
downloadmeta-openembedded-f6f05d19fdab287af016c73c0746d98f56141522.tar.gz
python3-isort: Upgrade 5.7.0 -> 5.8.0
Upgrade to release 5.8.0: - Fix: as import comments can in some cases be duplicated. - Fix: extra newline added with float-to-top, after skip, in some cases. - Fix: incorrect placement of noqa comments with multiple from imports. - Fix: in some cases different length limits for dos based line endings. - Export MyPY type hints. - Identified import statements now return runnable code. - Added "wemake" profile. - Parallel (-j) now defaults to number of CPU cores if no value is provided. - Added a safeguard against accidental usage against /. - Provide a flag --overwrite-in-place to ensure same file handle is used after sorting. - Added support for extending skips with --extend-skip and --extend-skip-glob. - Auto identification and skipping of some invalid import statements. - Ability to reverse the import sorting order. - Added ability to push star imports to the top to avoid overriding explicitly defined imports. - Doc: Skip doesn't support plain directory names, but skip_glob does. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-isort_5.8.0.bb (renamed from meta-python/recipes-devtools/python/python3-isort_5.7.0.bb)2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-isort_5.7.0.bb b/meta-python/recipes-devtools/python/python3-isort_5.8.0.bb
index 9f234ee46..36de825d2 100644
--- a/meta-python/recipes-devtools/python/python3-isort_5.7.0.bb
+++ b/meta-python/recipes-devtools/python/python3-isort_5.8.0.bb
@@ -4,7 +4,7 @@ LICENSE = "MIT"
4SECTION = "devel/python" 4SECTION = "devel/python"
5LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=6;endline=6;md5=8227180126797a0148f94f483f3e1489" 5LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=6;endline=6;md5=8227180126797a0148f94f483f3e1489"
6 6
7SRC_URI[sha256sum] = "c729845434366216d320e936b8ad6f9d681aab72dc7cbc2d51bedc3582f3ad1e" 7SRC_URI[sha256sum] = "0a943902919f65c5684ac4e0154b1ad4fac6dcaa5d9f3426b732f1c8b5419be6"
8 8
9inherit pypi setuptools3 9inherit pypi setuptools3
10 10