summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-03-14 08:36:51 -0700
committertgamblin <trevor.gamblin@windriver.com>2022-03-16 09:25:28 -0400
commitf26ca7749b3d96c8abc5336117248eca91bd3380 (patch)
tree2ffac82c7e35575c269db0702972e2b45e1e9da7 /meta-python
parentd30cd125d56cfd62b948e24cfbdfa0652484aa32 (diff)
downloadmeta-openembedded-f26ca7749b3d96c8abc5336117248eca91bd3380.tar.gz
python3-bcrypt: Remove
Moved to oe-core Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: tgamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-bcrypt/run-ptest3
-rw-r--r--meta-python/recipes-devtools/python/python3-bcrypt_3.2.0.bb30
2 files changed, 0 insertions, 33 deletions
diff --git a/meta-python/recipes-devtools/python/python3-bcrypt/run-ptest b/meta-python/recipes-devtools/python/python3-bcrypt/run-ptest
deleted file mode 100644
index b63c4de0d..000000000
--- a/meta-python/recipes-devtools/python/python3-bcrypt/run-ptest
+++ /dev/null
@@ -1,3 +0,0 @@
1#!/bin/sh
2
3pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}'
diff --git a/meta-python/recipes-devtools/python/python3-bcrypt_3.2.0.bb b/meta-python/recipes-devtools/python/python3-bcrypt_3.2.0.bb
deleted file mode 100644
index 92a6a0d8c..000000000
--- a/meta-python/recipes-devtools/python/python3-bcrypt_3.2.0.bb
+++ /dev/null
@@ -1,30 +0,0 @@
1DESCRIPTION = "Modern password hashing for your software and your servers."
2LICENSE = "Apache-2.0"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=8f7bb094c7232b058c7e9f2e431f389c"
4
5DEPENDS += "${PYTHON_PN}-cffi-native"
6
7SRC_URI[md5sum] = "fe31390dab603728f756cd3d6830c80a"
8SRC_URI[sha256sum] = "5b93c1726e50a93a033c36e5ca7fdcd29a5c7395af50a6892f5d9e7c6cfbfb29"
9
10inherit pypi setuptools_build_meta ptest
11
12SRC_URI += " \
13 file://run-ptest \
14"
15
16RDEPENDS:${PN}-ptest += " \
17 ${PYTHON_PN}-pytest \
18"
19
20do_install_ptest() {
21 install -d ${D}${PTEST_PATH}/tests
22 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
23}
24
25RDEPENDS:${PN}:class-target += "\
26 ${PYTHON_PN}-cffi \
27 ${PYTHON_PN}-ctypes \
28 ${PYTHON_PN}-shell \
29 ${PYTHON_PN}-six \
30"