summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2024-05-09 17:37:09 -0700
committerKhem Raj <raj.khem@gmail.com>2024-05-12 08:43:19 -0700
commite47585ffc87b954cf80f925bd79012ed13d15b94 (patch)
tree4e6d3097eed753ac978d3eeaf19343c6d25d3e3b /meta-python
parent587edc5e8dc22d283a4d725deef210ce7911a966 (diff)
downloadmeta-openembedded-e47585ffc87b954cf80f925bd79012ed13d15b94.tar.gz
python3-wxgtk4: Fix build with gcc-14
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python3-wxgtk4/python3-wxgtk4/0001-sip-Fix-build-with-gcc-14.patch31
-rw-r--r--meta-python/recipes-devtools/python3-wxgtk4/python3-wxgtk4_4.2.1.bb1
2 files changed, 32 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python3-wxgtk4/python3-wxgtk4/0001-sip-Fix-build-with-gcc-14.patch b/meta-python/recipes-devtools/python3-wxgtk4/python3-wxgtk4/0001-sip-Fix-build-with-gcc-14.patch
new file mode 100644
index 000000000..4782e74ef
--- /dev/null
+++ b/meta-python/recipes-devtools/python3-wxgtk4/python3-wxgtk4/0001-sip-Fix-build-with-gcc-14.patch
@@ -0,0 +1,31 @@
1From 5234a454a1b9f11f83e59909fb2972176497e02c Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Thu, 9 May 2024 17:35:11 -0700
4Subject: [PATCH] sip: Fix build with gcc-14
5
6Fixes -Wincompatible-pointer-types
7sip/siplib/siplib.c:3900:20: error: assignment to 'sipSimpleWrapper *' {aka 'struct _sipSimpleWrapper *'} from incompatible pointer type 'PyObject *' {aka 'struct _object *'} [-Wincompatible-pointer-types]
8| 3900 | *selfp = va_arg(va, PyObject *);
9
10Upstream-Status: Pending
11Signed-off-by: Khem Raj <raj.khem@gmail.com>
12---
13 sip/siplib/siplib.c | 2 +-
14 1 file changed, 1 insertion(+), 1 deletion(-)
15
16diff --git a/sip/siplib/siplib.c b/sip/siplib/siplib.c
17index 95563e5c..ae3fac60 100644
18--- a/sip/siplib/siplib.c
19+++ b/sip/siplib/siplib.c
20@@ -3897,7 +3897,7 @@ static int parsePass1(PyObject **parseErrp, sipSimpleWrapper **selfp,
21 {
22 case '#':
23 /* A ctor has an argument with the /Transfer/ annotation. */
24- *selfp = va_arg(va, PyObject *);
25+ *selfp = (sipSimpleWrapper *)va_arg(va, PyObject *);
26 break;
27
28 case 'B':
29--
302.45.0
31
diff --git a/meta-python/recipes-devtools/python3-wxgtk4/python3-wxgtk4_4.2.1.bb b/meta-python/recipes-devtools/python3-wxgtk4/python3-wxgtk4_4.2.1.bb
index fb011cb71..cc6b6cef6 100644
--- a/meta-python/recipes-devtools/python3-wxgtk4/python3-wxgtk4_4.2.1.bb
+++ b/meta-python/recipes-devtools/python3-wxgtk4/python3-wxgtk4_4.2.1.bb
@@ -14,6 +14,7 @@ SRC_URI += "file://add-back-option-build-base.patch \
14 file://wxgtk-fixup-build-scripts.patch \ 14 file://wxgtk-fixup-build-scripts.patch \
15 file://not-overwrite-cflags-cxxflags.patch \ 15 file://not-overwrite-cflags-cxxflags.patch \
16 file://0001-sip-Conditionally-use-GetAssertStackTrace-under-USE_.patch \ 16 file://0001-sip-Conditionally-use-GetAssertStackTrace-under-USE_.patch \
17 file://0001-sip-Fix-build-with-gcc-14.patch \
17 " 18 "
18SRC_URI[sha256sum] = "e48de211a6606bf072ec3fa778771d6b746c00b7f4b970eb58728ddf56d13d5c" 19SRC_URI[sha256sum] = "e48de211a6606bf072ec3fa778771d6b746c00b7f4b970eb58728ddf56d13d5c"
19 20