summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-04-27 12:15:57 +0300
committerKhem Raj <raj.khem@gmail.com>2021-04-29 08:43:54 -0700
commitdfbea6291077e50c0126c8d093794e50febf420d (patch)
tree069d07989ad2b9ecebce1a424e690e5fd4f33771 /meta-python
parent63edb5b42876f3cc50b52e481e9054a36068e400 (diff)
downloadmeta-openembedded-dfbea6291077e50c0126c8d093794e50febf420d.tar.gz
python3-et-xmlfile: Upgrade 1.0.1 -> 1.1.0
Upgrade to release 1.1.0: - Remove bitbucket pipelines config and streamline setup.py - Update project URL - Update APIDOC config - Update tox config - Update python_requires and add sys.path('.') License-Update: Use the exact line from PKG-INFO. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-et-xmlfile_1.0.1.bb20
-rw-r--r--meta-python/recipes-devtools/python/python3-et-xmlfile_1.1.0.bb17
2 files changed, 17 insertions, 20 deletions
diff --git a/meta-python/recipes-devtools/python/python3-et-xmlfile_1.0.1.bb b/meta-python/recipes-devtools/python/python3-et-xmlfile_1.0.1.bb
deleted file mode 100644
index cfff150cc..000000000
--- a/meta-python/recipes-devtools/python/python3-et-xmlfile_1.0.1.bb
+++ /dev/null
@@ -1,20 +0,0 @@
1SUMMARY = "et_xmlfile is a low memory library for creating large XML files"
2DESCRIPTION = "It is based upon the xmlfile module from lxml with the aim of allowing code \
3to be developed that will work with both libraries. It was developed initially for \
4the openpyxl project but is now a standalone module."
5
6HOMEPAGE = "https://bitbucket.org/openpyxl/et_xmlfile/src/default/"
7LICENSE = "MIT"
8LIC_FILES_CHKSUM = "file://PKG-INFO;md5=b3d89cae66f26c3a0799be8a96f3178b"
9
10SRC_URI[md5sum] = "f47940fd9d556375420b2e276476cfaf"
11SRC_URI[sha256sum] = "614d9722d572f6246302c4491846d2c393c199cfa4edc9af593437691683335b"
12
13RDEPENDS_${PN} += "${PYTHON_PN}-compression ${PYTHON_PN}-io ${PYTHON_PN}-pprint ${PYTHON_PN}-shell"
14
15inherit setuptools3
16PYPI_PACKAGE ?= "et_xmlfile"
17PYPI_SRC_URI ?= "https://files.pythonhosted.org/packages/source/e/et_xmlfile/et_xmlfile-1.0.1.tar.gz"
18SECTION = "devel/python"
19SRC_URI += "${PYPI_SRC_URI}"
20S = "${WORKDIR}/${PYPI_PACKAGE}-${PV}"
diff --git a/meta-python/recipes-devtools/python/python3-et-xmlfile_1.1.0.bb b/meta-python/recipes-devtools/python/python3-et-xmlfile_1.1.0.bb
new file mode 100644
index 000000000..182a81d69
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-et-xmlfile_1.1.0.bb
@@ -0,0 +1,17 @@
1SUMMARY = "et_xmlfile is a low memory library for creating large XML files"
2DESCRIPTION = "It is based upon the xmlfile module from lxml with the aim of allowing code \
3to be developed that will work with both libraries. It was developed initially for \
4the openpyxl project but is now a standalone module."
5
6HOMEPAGE = "https://foss.heptapod.net/openpyxl/et_xmlfile"
7SECTION = "devel/python"
8LICENSE = "MIT"
9LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=8227180126797a0148f94f483f3e1489"
10
11SRC_URI[sha256sum] = "8eb9e2bc2f8c97e37a2dc85a09ecdcdec9d8a396530a6d5a33b30b9a92da0c5c"
12
13RDEPENDS_${PN} += "${PYTHON_PN}-compression ${PYTHON_PN}-io ${PYTHON_PN}-pprint ${PYTHON_PN}-shell"
14
15inherit setuptools3 pypi
16
17PYPI_PACKAGE = "et_xmlfile"