summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authoralperak <alperyasinak1@gmail.com>2024-03-08 08:51:36 +0300
committerKhem Raj <raj.khem@gmail.com>2024-03-08 10:07:29 -0800
commitdd0a156fa8f40ead036662d5a422d643ccfda1ed (patch)
tree6ea9ad4713951dd5c32c6e72a2cb810647cd9852 /meta-python
parent8a69bf4e36f0d013c88fe5a7a97356d2cdc2e191 (diff)
downloadmeta-openembedded-dd0a156fa8f40ead036662d5a422d643ccfda1ed.tar.gz
python3-google-auth: add ptest and update runtime dependencies
* Generally we want to keep images as small as possible. RDEPENDS should not contains nothing except what is absolutely needed for a recipe. * Tested on qemux86-64 and qemuarm64 * Add ptest into PTESTS_SLOW_META_PYTHON Ptest results: ============== qemux86-64: Testsuite summary TOTAL: 1074 PASS: 1074 SKIP: 0 XFAIL: 0 FAIL: 0 XPASS: 0 ERROR: 0 DURATION: 227 END: /usr/lib/python3-google-auth/ptest 2024-03-07T21:30 STOP: ptest-runner TOTAL: 1 FAIL: 0 qemuarm64: Testsuite summary TOTAL: 1074 PASS: 1074 SKIP: 0 XFAIL: 0 FAIL: 0 XPASS: 0 ERROR: 0 DURATION: 184 END: /usr/lib/python3-google-auth/ptest 2024-03-07T21:15 STOP: ptest-runner TOTAL: 1 FAIL: 0 Signed-off-by: alperak <alperyasinak1@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/conf/include/ptest-packagelists-meta-python.inc1
-rw-r--r--meta-python/recipes-devtools/python/python3-google-auth/run-ptest4
-rw-r--r--meta-python/recipes-devtools/python/python3-google-auth_2.28.1.bb43
3 files changed, 34 insertions, 14 deletions
diff --git a/meta-python/conf/include/ptest-packagelists-meta-python.inc b/meta-python/conf/include/ptest-packagelists-meta-python.inc
index ce5ccf22d..63457189e 100644
--- a/meta-python/conf/include/ptest-packagelists-meta-python.inc
+++ b/meta-python/conf/include/ptest-packagelists-meta-python.inc
@@ -78,6 +78,7 @@ PTESTS_FAST_META_PYTHON = "\
78 78
79PTESTS_SLOW_META_PYTHON = "\ 79PTESTS_SLOW_META_PYTHON = "\
80 python3-arrow \ 80 python3-arrow \
81 python3-google-auth \
81 python3-lz4 \ 82 python3-lz4 \
82 python3-marshmallow \ 83 python3-marshmallow \
83 python3-pytest-localserver \ 84 python3-pytest-localserver \
diff --git a/meta-python/recipes-devtools/python/python3-google-auth/run-ptest b/meta-python/recipes-devtools/python/python3-google-auth/run-ptest
new file mode 100644
index 000000000..f1c8729f0
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-google-auth/run-ptest
@@ -0,0 +1,4 @@
1#!/bin/sh
2
3pytest --automake
4
diff --git a/meta-python/recipes-devtools/python/python3-google-auth_2.28.1.bb b/meta-python/recipes-devtools/python/python3-google-auth_2.28.1.bb
index 4524cca48..1f37544d2 100644
--- a/meta-python/recipes-devtools/python/python3-google-auth_2.28.1.bb
+++ b/meta-python/recipes-devtools/python/python3-google-auth_2.28.1.bb
@@ -3,24 +3,39 @@ HOMEPAGE = "https://github.com/googleapis/google-auth-library-python"
3LICENSE = "Apache-2.0" 3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" 4LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
5 5
6inherit pypi setuptools3 6inherit pypi setuptools3 ptest
7 7
8SRC_URI[sha256sum] = "34fc3046c257cedcf1622fc4b31fc2be7923d9b4d44973d481125ecc50d83885" 8SRC_URI[sha256sum] = "34fc3046c257cedcf1622fc4b31fc2be7923d9b4d44973d481125ecc50d83885"
9 9
10RDEPENDS:${PN} += "\ 10SRC_URI += " \
11 python3-asyncio \ 11 file://run-ptest \
12 python3-datetime \ 12"
13 python3-io \ 13
14 python3-json \ 14RDEPENDS:${PN}-ptest += " \
15 python3-logging \ 15 python3-cryptography \
16 python3-netclient \ 16 python3-flask \
17 python3-numbers \ 17 python3-freezegun \
18 python3-grpcio \
19 python3-mock \
20 python3-oauth2client \
21 python3-pyopenssl \
22 python3-pytest \
23 python3-pytest-localserver \
24 python3-pyu2f \
25 python3-requests \
26 python3-responses \
27 python3-unittest-automake-output \
28 python3-unixadmin \
18" 29"
19 30
31do_install_ptest() {
32 install -d ${D}${PTEST_PATH}/tests
33 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
34}
35
20RDEPENDS:${PN} += "\ 36RDEPENDS:${PN} += "\
21 python3-aiohttp \ 37 python3-cachetools \
22 python3-cachetools \ 38 python3-json \
23 python3-pyasn1-modules \ 39 python3-pyasn1-modules \
24 python3-rsa \ 40 python3-rsa \
25 python3-six \
26" 41"