summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2023-12-20 22:07:33 +0000
committerKhem Raj <raj.khem@gmail.com>2023-12-21 08:00:42 -0800
commitd8637f07a28128f42c69e397b1ddd4ca0e053060 (patch)
treebfb9c32a8f67ee5ab05fa59429070b3c6dcd7b72 /meta-python
parent6ce73e925d47fef98d345f7b5b12e9e70ccbbd54 (diff)
downloadmeta-openembedded-d8637f07a28128f42c69e397b1ddd4ca0e053060.tar.gz
python3-ninja: update to version 1.11.1.1
Changelog fix(wheels): link libstdc++ statically on manylinux1 by @mayeut in #159 chore(wheels): link libstdc++/libgcc statically on musllinux by @mayeut in #160 chore: add Windows ARM support by @henryiii in #169 chore: continue testing with python 2.7 by @mayeut in #199 chore: move to setuptools_scm by @henryiii in #170 chore: switch to ruff by @henryiii in #174 chore: use trusted publisher deployment by @jcfr in #191 chore: use wheel tags cli by @mayeut in #84 ci: allow setting a version by @henryiii in #171 ci: cancel on repeated pushes by @henryiii in #177 Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-ninja/no-scikit-build.patch8
-rw-r--r--meta-python/recipes-devtools/python/python3-ninja_1.11.1.1.bb (renamed from meta-python/recipes-devtools/python/python3-ninja_1.11.1.bb)4
2 files changed, 7 insertions, 5 deletions
diff --git a/meta-python/recipes-devtools/python/python3-ninja/no-scikit-build.patch b/meta-python/recipes-devtools/python/python3-ninja/no-scikit-build.patch
index 276fb5017..b7d191e24 100644
--- a/meta-python/recipes-devtools/python/python3-ninja/no-scikit-build.patch
+++ b/meta-python/recipes-devtools/python/python3-ninja/no-scikit-build.patch
@@ -8,11 +8,11 @@ diff --git a/pyproject.toml b/pyproject.toml
8index b895c20..577b642 100644 8index b895c20..577b642 100644
9--- a/pyproject.toml 9--- a/pyproject.toml
10+++ b/pyproject.toml 10+++ b/pyproject.toml
11@@ -1,7 +1,6 @@ 11@@ -2,7 +2,6 @@
12 [build-system]
13 requires = [ 12 requires = [
14 "setuptools>=42", 13 "setuptools >=42",
15- "scikit-build>=0.12", 14 "setuptools-scm[toml]",
15- "scikit-build",
16 ] 16 ]
17 build-backend = "setuptools.build_meta" 17 build-backend = "setuptools.build_meta"
18 18
diff --git a/meta-python/recipes-devtools/python/python3-ninja_1.11.1.bb b/meta-python/recipes-devtools/python/python3-ninja_1.11.1.1.bb
index 3b9077f32..a9e0ed208 100644
--- a/meta-python/recipes-devtools/python/python3-ninja_1.11.1.bb
+++ b/meta-python/recipes-devtools/python/python3-ninja_1.11.1.1.bb
@@ -6,11 +6,13 @@ PYPI_PACKAGE = "ninja"
6PYPI_ARCHIVE_NAME_PREFIX = "pypi-" 6PYPI_ARCHIVE_NAME_PREFIX = "pypi-"
7 7
8inherit pypi python_setuptools_build_meta 8inherit pypi python_setuptools_build_meta
9SRC_URI[sha256sum] = "c833a47d39b2d1eee3f9ca886fa1581efd5be6068b82734ac229961ee8748f90" 9SRC_URI[sha256sum] = "9d793b08dd857e38d0b6ffe9e6b7145d7c485a42dcfea04905ca0cdb6017cc3c"
10 10
11SRC_URI += "file://no-scikit-build.patch \ 11SRC_URI += "file://no-scikit-build.patch \
12 file://run-ninja-from-path.patch" 12 file://run-ninja-from-path.patch"
13 13
14DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
15
14do_install:append () { 16do_install:append () {
15 rm -rf ${D}${bindir} 17 rm -rf ${D}${bindir}
16} 18}