summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authornick83ola <nick83ola@gmail.com>2020-03-25 06:22:07 +0000
committerKhem Raj <raj.khem@gmail.com>2020-03-25 06:52:29 -0700
commitc6fb8e3efbb14d138a3aee6cf31e6ae96d57b54f (patch)
tree446155138b58f889d0e4ba1a72fa64313b5b4ad7 /meta-python
parentd85d9c7a13aad23c43a0bccc23f03e98f312f11f (diff)
downloadmeta-openembedded-c6fb8e3efbb14d138a3aee6cf31e6ae96d57b54f.tar.gz
python3-matplotlib: multiple changes
* The license indicated in the setup.py is PSF not the BSD. Update LICENSE * added kiwisolver and cycler to the dependencies * add missing pkgconfig class * added native for the python dependencies to DEPENDS: the setuptools need to launch the required libraries to check if they are there * remove redundant PYPI_PACKAGE * add SECTION = "devel/python" * apply oe-stylize Signed-off-by: Nicola Lunghi <nick83ola@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-matplotlib_3.1.1.bb32
1 files changed, 25 insertions, 7 deletions
diff --git a/meta-python/recipes-devtools/python/python3-matplotlib_3.1.1.bb b/meta-python/recipes-devtools/python/python3-matplotlib_3.1.1.bb
index 824680c24..c638e27b1 100644
--- a/meta-python/recipes-devtools/python/python3-matplotlib_3.1.1.bb
+++ b/meta-python/recipes-devtools/python/python3-matplotlib_3.1.1.bb
@@ -4,16 +4,34 @@ Matplotlib is a Python 2D plotting library which produces \
4publication-quality figures in a variety of hardcopy formats \ 4publication-quality figures in a variety of hardcopy formats \
5and interactive environments across platforms." 5and interactive environments across platforms."
6HOMEPAGE = "https://github.com/matplotlib/matplotlib" 6HOMEPAGE = "https://github.com/matplotlib/matplotlib"
7LICENSE = "BSD-2-Clause" 7SECTION = "devel/python"
8LIC_FILES_CHKSUM = "file://LICENSE/LICENSE;md5=afec61498aa5f0c45936687da9a53d74" 8LICENSE = "PSF"
9 9LIC_FILES_CHKSUM = "\
10DEPENDS = "python3-numpy-native python3-numpy freetype libpng python3-dateutil python3-pytz" 10 file://setup.py;beginline=275;endline=275;md5=2a114620e4e6843aa7568d5902501753 \
11RDEPENDS_${PN} = "python3-numpy freetype libpng python3-dateutil python3-pytz" 11 file://LICENSE/LICENSE;md5=afec61498aa5f0c45936687da9a53d74 \
12"
13DEPENDS = "\
14 freetype \
15 libpng \
16 python3-numpy-native \
17 python3-dateutil-native \
18 python3-pytz-native \
19"
12 20
13SRC_URI[md5sum] = "f894af5564a588e880644123237251b7" 21SRC_URI[md5sum] = "f894af5564a588e880644123237251b7"
14SRC_URI[sha256sum] = "1febd22afe1489b13c6749ea059d392c03261b2950d1d45c17e3aed812080c93" 22SRC_URI[sha256sum] = "1febd22afe1489b13c6749ea059d392c03261b2950d1d45c17e3aed812080c93"
15 23
16PYPI_PACKAGE = "matplotlib" 24inherit pypi setuptools3 pkgconfig
17inherit pypi setuptools3 25
26RDEPENDS_${PN} = "\
27 freetype \
28 libpng \
29 python3-numpy \
30 python3-pyparsing \
31 python3-cycler \
32 python3-dateutil \
33 python3-kiwisolver \
34 python3-pytz \
35"
18 36
19BBCLASSEXTEND = "native" 37BBCLASSEXTEND = "native"