summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2017-05-19 13:27:16 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2017-06-05 11:01:43 +0200
commitc4e099cd6948d9a5b873bf8e14277b96beb73e0e (patch)
treef8fe28c12259b2b96718047fc3f2d5875afc45e2 /meta-python
parentb7095305518d95930d7f7916d6736ea265c4cbfd (diff)
downloadmeta-openembedded-c4e099cd6948d9a5b873bf8e14277b96beb73e0e.tar.gz
python-backports-functools-lru-cache: update to version 1.4
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-backports-functools-lru-cache_1.3.bb14
-rw-r--r--meta-python/recipes-devtools/python/python-backports-functools-lru-cache_1.4.bb19
2 files changed, 19 insertions, 14 deletions
diff --git a/meta-python/recipes-devtools/python/python-backports-functools-lru-cache_1.3.bb b/meta-python/recipes-devtools/python/python-backports-functools-lru-cache_1.3.bb
deleted file mode 100644
index 211cfdef4..000000000
--- a/meta-python/recipes-devtools/python/python-backports-functools-lru-cache_1.3.bb
+++ /dev/null
@@ -1,14 +0,0 @@
1SUMMARY = "Backport of functools.lru_cache from Python 3.3"
2HOMEPAGE = "https://github.com/jaraco/backports.functools_lru_cache"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://setup.py;beginline=42;endline=42;md5=98fc3658e5970d26f6b2109808c766be"
6
7PYPI_PACKAGE = "backports.functools_lru_cache"
8
9SRC_URI[md5sum] = "b26a223250bd24ea2e0ad6ce47b19084"
10SRC_URI[sha256sum] = "444a21bcec4ae177da554321f81a78dc879eaa8f6ea9920cb904830585d31e95"
11
12DEPENDS = "python-setuptools-scm-native"
13
14inherit setuptools pypi
diff --git a/meta-python/recipes-devtools/python/python-backports-functools-lru-cache_1.4.bb b/meta-python/recipes-devtools/python/python-backports-functools-lru-cache_1.4.bb
new file mode 100644
index 000000000..961436f53
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-backports-functools-lru-cache_1.4.bb
@@ -0,0 +1,19 @@
1SUMMARY = "Backport of functools.lru_cache from Python 3.3"
2HOMEPAGE = "https://github.com/jaraco/backports.functools_lru_cache"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://setup.py;beginline=47;endline=47;md5=98fc3658e5970d26f6b2109808c766be"
6
7PYPI_PACKAGE = "backports.functools_lru_cache"
8
9SRC_URI[md5sum] = "b954e7d5e2ca0f0f66ad2ed12ba800e5"
10SRC_URI[sha256sum] = "31f235852f88edc1558d428d890663c49eb4514ffec9f3650e7f3c9e4a12e36f"
11
12DEPENDS += "python-setuptools-scm-native"
13
14inherit setuptools pypi
15
16RDEPENDS_${PN} += "\
17 ${PYTHON_PN}-pickle \
18 ${PYTHON_PN}-threading \
19 "