summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2022-03-01 12:33:53 -0800
committerKhem Raj <raj.khem@gmail.com>2022-03-03 08:48:07 -0800
commitc2b210d20941011f3f79590d9df115c18c4c8eb7 (patch)
treec8e24c1ed2a5779bfa9b7ed266e50c8f6a731dc6 /meta-python
parentbe04fddedc428f657f33e24b7267c343e4c4b8f8 (diff)
downloadmeta-openembedded-c2b210d20941011f3f79590d9df115c18c4c8eb7.tar.gz
python3-pymisp: inherit poetry_core
* Use PEP-517 build-backend instead of setuptools3. * Also set PIP_INSTALL_PACKAGE = "pymisp" Signed-off-by: Tim Orling <tim.orling@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-pymisp_2.4.152.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pymisp_2.4.152.bb b/meta-python/recipes-devtools/python/python3-pymisp_2.4.152.bb
index 254330bf5..18f5f9cd9 100644
--- a/meta-python/recipes-devtools/python/python3-pymisp_2.4.152.bb
+++ b/meta-python/recipes-devtools/python/python3-pymisp_2.4.152.bb
@@ -7,7 +7,9 @@ SRC_URI = "git://github.com/MISP/PyMISP.git;protocol=https;branch=main"
7SRCREV = "d991e53f9a9641f454e116e83d2913edf405a53f" 7SRCREV = "d991e53f9a9641f454e116e83d2913edf405a53f"
8S = "${WORKDIR}/git" 8S = "${WORKDIR}/git"
9 9
10inherit setuptools3 10inherit poetry_core
11
12PIP_INSTALL_PACKAGE = "pymisp"
11 13
12RDEPENDS:${PN} += " \ 14RDEPENDS:${PN} += " \
13 ${PYTHON_PN}-dateutil \ 15 ${PYTHON_PN}-dateutil \