diff options
author | Leon Anavi <leon.anavi@konsulko.com> | 2020-08-24 12:14:57 +0300 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2020-08-25 10:34:00 -0700 |
commit | bfe063558830950a6b120bc247be416ae5fac197 (patch) | |
tree | fd6c23f27787ab95df86fbf48abf65f5dc7a17e6 /meta-python | |
parent | 270531486c651ea965ca3435cd98ab12a7b446bc (diff) | |
download | meta-openembedded-bfe063558830950a6b120bc247be416ae5fac197.tar.gz |
python3-attrs: Upgrade 19.3.0 -> 20.1.0
Upgrade to release 20.1.0:
- Python 3.4 is not supported anymore.
- Added attr.resolve_types(). It ensures that all
forward-references and types in string form are resolved
into concrete types.
- Added @attr.s(collect_by_mro=False) argument that if set to
True fixes the collection of attributes from base classes.
- On Python 3, all generated methods now have a docstring
explaining that they have been created by attrs.
- Fixed a ValueError: Cell is empty bug that could happen in some
rare edge cases.
- Added attr.converters.pipe(). The feature allows combining
multiple conversion callbacks into one by piping the value
through all of them, and retuning the last result.
- Provisionally added attr.field() that supplants attr.ib().
Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-attrs_20.1.0.bb (renamed from meta-python/recipes-devtools/python/python3-attrs_19.3.0.bb) | 4 |
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-attrs_19.3.0.bb b/meta-python/recipes-devtools/python/python3-attrs_20.1.0.bb index 7ff8049e5..371f1f042 100644 --- a/meta-python/recipes-devtools/python/python3-attrs_19.3.0.bb +++ b/meta-python/recipes-devtools/python/python3-attrs_20.1.0.bb | |||
@@ -3,8 +3,8 @@ HOMEPAGE = "http://www.attrs.org/" | |||
3 | LICENSE = "MIT" | 3 | LICENSE = "MIT" |
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=d4ab25949a73fe7d4fdee93bcbdbf8ff" | 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=d4ab25949a73fe7d4fdee93bcbdbf8ff" |
5 | 5 | ||
6 | SRC_URI[sha256sum] = "f7b7ce16570fe9965acd6d30101a28f62fb4a7f9e926b3bbc9b61f8b04247e72" | 6 | SRC_URI[sha256sum] = "0ef97238856430dcf9228e07f316aefc17e8939fc8507e18c6501b761ef1a42a" |
7 | SRC_URI[md5sum] = "5b2db50fcc31be34d32798183c9bd062" | 7 | SRC_URI[md5sum] = "ab7533fc91c5db3d5b65e66be907444e" |
8 | 8 | ||
9 | inherit pypi setuptools3 | 9 | inherit pypi setuptools3 |
10 | 10 | ||