summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorMartin Kelly <mkelly@xevo.com>2020-03-24 15:48:42 -0700
committerKhem Raj <raj.khem@gmail.com>2020-03-24 19:58:50 -0700
commitbe0e033b076c517b3d6e05db74ad751cb747db28 (patch)
treedf86bac76b5634164416f01163c566a9ae52db15 /meta-python
parent21fe4d2290be9200222867c1fe63738edf150c7c (diff)
downloadmeta-openembedded-be0e033b076c517b3d6e05db74ad751cb747db28.tar.gz
python3-lockfile: add recipe for 0.12.2
Signed-off-by: Martin Kelly <mkelly@xevo.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-lockfile_0.12.2.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-lockfile_0.12.2.bb b/meta-python/recipes-devtools/python/python3-lockfile_0.12.2.bb
new file mode 100644
index 000000000..30b1297e7
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-lockfile_0.12.2.bb
@@ -0,0 +1,17 @@
1# This recipe is originally from meta-openstack:
2# https://git.yoctoproject.org/cgit/cgit.cgi/meta-cloud-services/tree/meta-openstack/recipes-devtools/python/python-lockfile_0.12.2.bb
3
4SUMMARY = "Platform-independent file locking module"
5HOMEPAGE = "https://pypi.org/project/lockfile/"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=2340dffbbfea534b58f1349984eeef72"
8
9SRC_URI[md5sum] = "a6a1a82957a23afdf44cfdd039b65ff9"
10SRC_URI[sha256sum] = "6aed02de03cba24efabcd600b30540140634fc06cfa603822d508d5361e9f799"
11
12inherit pypi setuptools3
13
14DEPENDS += "python3-distutils-extra-native python3-pbr-native"
15RDEPENDS_${PN} += "python3-sqlite3"
16
17BBCLASSEXTEND = "native nativesdk"