diff options
author | Andrew Jeffery <andrew@aj.id.au> | 2018-05-10 16:07:18 +0930 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2018-08-24 09:14:05 -0700 |
commit | bdf5540dc510bb7cfaca1b9045533cd558954681 (patch) | |
tree | e452b06459d0bbad17cc3386ca02bd1ada925150 /meta-python | |
parent | 82fc7b9e2670f083c1046252e6eed488b63afde9 (diff) | |
download | meta-openembedded-bdf5540dc510bb7cfaca1b9045533cd558954681.tar.gz |
meta-python: Make python-pyflame cope with prelinked ELFs
Signed-off-by: Andrew Jeffery <andrew@aj.id.au>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python-pyflame-1.6.6/0001-symbol-Account-for-prelinked-shared-objects.patch | 134 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python-pyflame_1.6.6.bb | 1 |
2 files changed, 135 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-pyflame-1.6.6/0001-symbol-Account-for-prelinked-shared-objects.patch b/meta-python/recipes-devtools/python/python-pyflame-1.6.6/0001-symbol-Account-for-prelinked-shared-objects.patch new file mode 100644 index 0000000000..3eefc9cb98 --- /dev/null +++ b/meta-python/recipes-devtools/python/python-pyflame-1.6.6/0001-symbol-Account-for-prelinked-shared-objects.patch | |||
@@ -0,0 +1,134 @@ | |||
1 | From 007965d341349679607699d005c4af811b2c419a Mon Sep 17 00:00:00 2001 | ||
2 | From: Andrew Jeffery <andrew@aj.id.au> | ||
3 | Date: Fri, 4 May 2018 11:23:53 +0930 | ||
4 | Subject: [PATCH] symbol: Account for prelinked shared objects | ||
5 | |||
6 | Some projects, such as those derived from Yocto, tend to prelink their | ||
7 | binaries and libraries to reduce runtime overhead. Currently this trips | ||
8 | up pyflame in its symbol address calculations, and leads to ptrace | ||
9 | failures due to spurious addresses: | ||
10 | |||
11 | $ pyflame -t python -c "print 'foo'" | ||
12 | Unexpected ptrace(2) exception: Failed to PTRACE_PEEKDATA (pid 1482, addr 0x9f9b1d70): Input/output error | ||
13 | Unexpected ptrace(2) exception: Failed to PTRACE_PEEKDATA (pid 1482, addr 0x9f9b1d70): Input/output error | ||
14 | Unexpected ptrace(2) exception: Failed to PTRACE_PEEKDATA (pid 1482, addr 0x9f9b1d70): Input/output error | ||
15 | Unexpected ptrace(2) exception: Failed to PTRACE_PEEKDATA (pid 1482, addr 0x9f9b1d70): Input/output error | ||
16 | Unexpected ptrace(2) exception: Failed to PTRACE_PEEKDATA (pid 1482, addr 0x9f9b1d70): Input/output error | ||
17 | ... | ||
18 | |||
19 | Add support for reading a prelinked base p_vaddr out of the ELF and | ||
20 | adjust the PyAddresses values accordingly. | ||
21 | |||
22 | Signed-off-by: Andrew Jeffery <andrew@aj.id.au> | ||
23 | --- | ||
24 | src/symbol.cc | 15 +++++++++++++++ | ||
25 | src/symbol.h | 29 ++++++++++++++++++++++++++++- | ||
26 | 2 files changed, 43 insertions(+), 1 deletion(-) | ||
27 | |||
28 | diff --git a/src/symbol.cc b/src/symbol.cc | ||
29 | index 125174efeeb5..39c3e8132dd1 100644 | ||
30 | --- a/src/symbol.cc | ||
31 | +++ b/src/symbol.cc | ||
32 | @@ -166,6 +166,17 @@ PyABI ELF::WalkTable(int sym, int str, PyAddresses *addrs) { | ||
33 | return abi; | ||
34 | } | ||
35 | |||
36 | +addr_t ELF::GetBaseAddress() { | ||
37 | + int32_t phnum = hdr()->e_phnum; | ||
38 | + int32_t i; | ||
39 | + for (i = 0; i < phnum && phdr(i)->p_type != PT_LOAD; i++) { | ||
40 | + } | ||
41 | + if (i == phnum) { | ||
42 | + throw FatalException("Failed to find PT_LOAD entry in program headers"); | ||
43 | + } | ||
44 | + return phdr(i)->p_vaddr; | ||
45 | +} | ||
46 | + | ||
47 | PyAddresses ELF::GetAddresses(PyABI *abi) { | ||
48 | PyAddresses addrs; | ||
49 | PyABI detected_abi = WalkTable(dynsym_, dynstr_, &addrs); | ||
50 | @@ -176,6 +187,10 @@ PyAddresses ELF::GetAddresses(PyABI *abi) { | ||
51 | if (abi != nullptr) { | ||
52 | *abi = detected_abi; | ||
53 | } | ||
54 | + // Handle prelinked shared objects | ||
55 | + if (hdr()->e_type == ET_DYN) { | ||
56 | + return addrs - GetBaseAddress(); | ||
57 | + } | ||
58 | return addrs; | ||
59 | } | ||
60 | } // namespace pyflame | ||
61 | diff --git a/src/symbol.h b/src/symbol.h | ||
62 | index 124853bcc1c1..bb92b9a2604b 100644 | ||
63 | --- a/src/symbol.h | ||
64 | +++ b/src/symbol.h | ||
65 | @@ -28,15 +28,19 @@ | ||
66 | |||
67 | #if USE_ELF64 | ||
68 | #define ehdr_t Elf64_Ehdr | ||
69 | +#define phdr_t Elf64_Phdr | ||
70 | #define shdr_t Elf64_Shdr | ||
71 | #define dyn_t Elf64_Dyn | ||
72 | #define sym_t Elf64_Sym | ||
73 | +#define addr_t Elf64_Addr | ||
74 | #define ARCH_ELFCLASS ELFCLASS64 | ||
75 | #else | ||
76 | #define ehdr_t Elf32_Ehdr | ||
77 | +#define phdr_t Elf32_Phdr | ||
78 | #define shdr_t Elf32_Shdr | ||
79 | #define dyn_t Elf32_Dyn | ||
80 | #define sym_t Elf32_Sym | ||
81 | +#define addr_t Elf32_Addr | ||
82 | #define ARCH_ELFCLASS ELFCLASS32 | ||
83 | #endif | ||
84 | |||
85 | @@ -67,8 +71,18 @@ struct PyAddresses { | ||
86 | interp_head_hint(0), | ||
87 | pie(false) {} | ||
88 | |||
89 | + PyAddresses operator-(const unsigned long base) const { | ||
90 | + PyAddresses res(*this); | ||
91 | + res.tstate_addr = this->tstate_addr == 0 ? 0 : this->tstate_addr - base; | ||
92 | + res.interp_head_addr = | ||
93 | + this->interp_head_addr == 0 ? 0 : this->interp_head_addr - base; | ||
94 | + res.interp_head_fn_addr = | ||
95 | + this->interp_head_fn_addr == 0 ? 0 : this->interp_head_fn_addr - base; | ||
96 | + return res; | ||
97 | + } | ||
98 | + | ||
99 | PyAddresses operator+(const unsigned long base) const { | ||
100 | - PyAddresses res; | ||
101 | + PyAddresses res(*this); | ||
102 | res.tstate_addr = this->tstate_addr == 0 ? 0 : this->tstate_addr + base; | ||
103 | res.interp_head_addr = | ||
104 | this->interp_head_addr == 0 ? 0 : this->interp_head_addr + base; | ||
105 | @@ -113,6 +127,9 @@ class ELF { | ||
106 | // ABI. | ||
107 | PyAddresses GetAddresses(PyABI *abi); | ||
108 | |||
109 | + // Extract the base load address from the Program Header table | ||
110 | + addr_t GetBaseAddress(); | ||
111 | + | ||
112 | private: | ||
113 | void *addr_; | ||
114 | size_t length_; | ||
115 | @@ -122,6 +139,16 @@ class ELF { | ||
116 | return reinterpret_cast<const ehdr_t *>(addr_); | ||
117 | } | ||
118 | |||
119 | + inline const phdr_t *phdr(int idx) const { | ||
120 | + if (idx < 0) { | ||
121 | + std::ostringstream ss; | ||
122 | + ss << "Illegal phdr index: " << idx; | ||
123 | + throw FatalException(ss.str()); | ||
124 | + } | ||
125 | + return reinterpret_cast<const phdr_t *>(p() + hdr()->e_phoff + | ||
126 | + idx * hdr()->e_phentsize); | ||
127 | + } | ||
128 | + | ||
129 | inline const shdr_t *shdr(int idx) const { | ||
130 | if (idx < 0) { | ||
131 | std::ostringstream ss; | ||
132 | -- | ||
133 | 2.14.1 | ||
134 | |||
diff --git a/meta-python/recipes-devtools/python/python-pyflame_1.6.6.bb b/meta-python/recipes-devtools/python/python-pyflame_1.6.6.bb index 7a6d3b0996..abf3ed7fee 100644 --- a/meta-python/recipes-devtools/python/python-pyflame_1.6.6.bb +++ b/meta-python/recipes-devtools/python/python-pyflame_1.6.6.bb | |||
@@ -1,3 +1,4 @@ | |||
1 | require python-pyflame.inc | 1 | require python-pyflame.inc |
2 | 2 | ||
3 | SRC_URI += "file://0001-ptrace-Abstract-over-user_regs_struct-name-which-dif.patch" | 3 | SRC_URI += "file://0001-ptrace-Abstract-over-user_regs_struct-name-which-dif.patch" |
4 | SRC_URI += "file://0001-symbol-Account-for-prelinked-shared-objects.patch" | ||