summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2024-02-19 17:02:26 +0800
committerKhem Raj <raj.khem@gmail.com>2024-02-19 23:22:22 -0800
commitbd8c858652a3b60605cb12343569e5193333fbd7 (patch)
tree0f06448c7ca0664572c226434fec43a7463e6fab /meta-python
parent5e8ac4795a515763244c4c3a5cd702fcb4e06ada (diff)
downloadmeta-openembedded-bd8c858652a3b60605cb12343569e5193333fbd7.tar.gz
python3-gevent: upgrade 23.9.1 -> 24.2.1
0001-_setuputils.py-Do-not-add-sys_inc_dir.patch refreshed for 24.2.1 Changelog: =========== -Add support for Python patch releases 3.11.8 and 3.12.2, which changed internal details of threading. -Errors raised from subprocess.Popen may not have a filename set. -SSLSocket.recv_into and SSLSocket.read no longer require the buffer to implement len and now work with buffers whose size is not 1. -gh-108310: Fix CVE-2023-40217: Check for & avoid the ssl pre-close flaw. -Drop setuptools to a soft test dependency. -Drop support for very old versions of CFFI. -Update bundled c-ares from 1.19.1 to 1.26.0. -Locks created by gevent, but acquired from multiple different threads (not recommended), no longer spin to implement timeouts and interruptible blocking. Instead, they use the native functionality of the Python 3 lock. Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-gevent/0001-_setuputils.py-Do-not-add-sys_inc_dir.patch12
-rw-r--r--meta-python/recipes-devtools/python/python3-gevent_24.2.1.bb (renamed from meta-python/recipes-devtools/python/python3-gevent_23.9.1.bb)2
2 files changed, 6 insertions, 8 deletions
diff --git a/meta-python/recipes-devtools/python/python3-gevent/0001-_setuputils.py-Do-not-add-sys_inc_dir.patch b/meta-python/recipes-devtools/python/python3-gevent/0001-_setuputils.py-Do-not-add-sys_inc_dir.patch
index ac8b031cf..49903d6ce 100644
--- a/meta-python/recipes-devtools/python/python3-gevent/0001-_setuputils.py-Do-not-add-sys_inc_dir.patch
+++ b/meta-python/recipes-devtools/python/python3-gevent/0001-_setuputils.py-Do-not-add-sys_inc_dir.patch
@@ -1,4 +1,4 @@
1From f3267ad7994a4b66e6bcf72cb0e418105f77bd52 Mon Sep 17 00:00:00 2001 1From 9eb453283a7ac8a9b1dd3eac86d936c7a430476b Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Tue, 11 Oct 2022 17:37:01 -0700 3Date: Tue, 11 Oct 2022 17:37:01 -0700
4Subject: [PATCH] _setuputils.py: Do not add sys_inc_dir 4Subject: [PATCH] _setuputils.py: Do not add sys_inc_dir
@@ -10,15 +10,16 @@ we really do not need setuptools to deduce it for us.
10 10
11Upstream-Status: Inappropriate [ Cross-compile specific ] 11Upstream-Status: Inappropriate [ Cross-compile specific ]
12Signed-off-by: Khem Raj <raj.khem@gmail.com> 12Signed-off-by: Khem Raj <raj.khem@gmail.com>
13
13--- 14---
14 _setuputils.py | 3 +-- 15 _setuputils.py | 3 +--
15 1 file changed, 1 insertion(+), 2 deletions(-) 16 1 file changed, 1 insertion(+), 2 deletions(-)
16 17
17diff --git a/_setuputils.py b/_setuputils.py 18diff --git a/_setuputils.py b/_setuputils.py
18index d98f716..31134a4 100644 19index 4c25e00..23fdfe1 100644
19--- a/_setuputils.py 20--- a/_setuputils.py
20+++ b/_setuputils.py 21+++ b/_setuputils.py
21@@ -161,7 +161,6 @@ def get_include_dirs(*extra_paths): 22@@ -164,7 +164,6 @@ def get_include_dirs(*extra_paths):
22 # Neither sysconfig dir is not enough if we're in a virtualenv; the greenlet.h 23 # Neither sysconfig dir is not enough if we're in a virtualenv; the greenlet.h
23 # header goes into a site/ subdir. See https://github.com/pypa/pip/issues/4610 24 # header goes into a site/ subdir. See https://github.com/pypa/pip/issues/4610
24 dist_inc_dir = os.path.abspath(dist_sysconfig.get_python_inc()) # 1 25 dist_inc_dir = os.path.abspath(dist_sysconfig.get_python_inc()) # 1
@@ -26,7 +27,7 @@ index d98f716..31134a4 100644
26 venv_include_dir = os.path.join( 27 venv_include_dir = os.path.join(
27 sys.prefix, 'include', 'site', 28 sys.prefix, 'include', 'site',
28 'python' + sysconfig.get_python_version() 29 'python' + sysconfig.get_python_version()
29@@ -175,7 +174,7 @@ def get_include_dirs(*extra_paths): 30@@ -178,7 +177,7 @@ def get_include_dirs(*extra_paths):
30 31
31 return [ 32 return [
32 p 33 p
@@ -35,6 +36,3 @@ index d98f716..31134a4 100644
35 if os.path.exists(p) 36 if os.path.exists(p)
36 ] 37 ]
37 38
38--
392.38.0
40
diff --git a/meta-python/recipes-devtools/python/python3-gevent_23.9.1.bb b/meta-python/recipes-devtools/python/python3-gevent_24.2.1.bb
index 0caebce28..ebde34d56 100644
--- a/meta-python/recipes-devtools/python/python3-gevent_23.9.1.bb
+++ b/meta-python/recipes-devtools/python/python3-gevent_24.2.1.bb
@@ -13,7 +13,7 @@ RDEPENDS:${PN} = "${PYTHON_PN}-greenlet \
13 13
14SRC_URI += "file://0001-_setuputils.py-Do-not-add-sys_inc_dir.patch" 14SRC_URI += "file://0001-_setuputils.py-Do-not-add-sys_inc_dir.patch"
15 15
16SRC_URI[sha256sum] = "72c002235390d46f94938a96920d8856d4ffd9ddf62a303a0d7c118894097e34" 16SRC_URI[sha256sum] = "432fc76f680acf7cf188c2ee0f5d3ab73b63c1f03114c7cd8a34cebbe5aa2056"
17 17
18inherit pypi setuptools3 18inherit pypi setuptools3
19 19