summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2020-02-14 18:08:19 -0500
committerKhem Raj <raj.khem@gmail.com>2020-02-15 08:05:07 -0800
commitbbe7eb6c339611dc6d2686461476637e203fddc4 (patch)
tree3fddef324c1b2707d7374b5fa5ad7c5da7149131 /meta-python
parent90ca842c7a4f08e66cc3d1eb11fc0b3a1129526a (diff)
downloadmeta-openembedded-bbe7eb6c339611dc6d2686461476637e203fddc4.tar.gz
python3-cffi: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-cffi.inc17
-rw-r--r--meta-python/recipes-devtools/python/python3-cffi_1.14.0.bb19
2 files changed, 18 insertions, 18 deletions
diff --git a/meta-python/recipes-devtools/python/python-cffi.inc b/meta-python/recipes-devtools/python/python-cffi.inc
deleted file mode 100644
index af10c5f36..000000000
--- a/meta-python/recipes-devtools/python/python-cffi.inc
+++ /dev/null
@@ -1,17 +0,0 @@
1SUMMARY = "Foreign Function Interface for Python calling C code"
2HOMEPAGE = "http://cffi.readthedocs.org/"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=5677e2fdbf7cdda61d6dd2b57df547bf"
5DEPENDS += "libffi ${PYTHON_PN}-pycparser"
6
7SRC_URI[md5sum] = "74845f8d2b7b583dd9a3574f402edf39"
8SRC_URI[sha256sum] = "2d384f4a127a15ba701207f7639d94106693b6cd64173d6c8988e2c25f3ac2b6"
9
10RDEPENDS_${PN}_class-target = " \
11 ${PYTHON_PN}-ctypes \
12 ${PYTHON_PN}-io \
13 ${PYTHON_PN}-pycparser \
14 ${PYTHON_PN}-shell \
15"
16
17BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python3-cffi_1.14.0.bb b/meta-python/recipes-devtools/python/python3-cffi_1.14.0.bb
index e88808434..53c8ee265 100644
--- a/meta-python/recipes-devtools/python/python3-cffi_1.14.0.bb
+++ b/meta-python/recipes-devtools/python/python3-cffi_1.14.0.bb
@@ -1,2 +1,19 @@
1SUMMARY = "Foreign Function Interface for Python calling C code"
2HOMEPAGE = "http://cffi.readthedocs.org/"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=5677e2fdbf7cdda61d6dd2b57df547bf"
5DEPENDS += "libffi ${PYTHON_PN}-pycparser"
6
7SRC_URI[md5sum] = "74845f8d2b7b583dd9a3574f402edf39"
8SRC_URI[sha256sum] = "2d384f4a127a15ba701207f7639d94106693b6cd64173d6c8988e2c25f3ac2b6"
9
1inherit pypi setuptools3 10inherit pypi setuptools3
2require python-cffi.inc 11
12RDEPENDS_${PN}_class-target = " \
13 ${PYTHON_PN}-ctypes \
14 ${PYTHON_PN}-io \
15 ${PYTHON_PN}-pycparser \
16 ${PYTHON_PN}-shell \
17"
18
19BBCLASSEXTEND = "native nativesdk"