summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-05-27 00:32:48 +0300
committerKhem Raj <raj.khem@gmail.com>2021-05-28 06:50:20 -0700
commitbaa8a5e3c8a93e84e416981121124c2971ac9d90 (patch)
tree4db25295f7ce1f12a70eacccb5b1464b9505c515 /meta-python
parent74eae432d127963f8e910b65a74afd6b787c376d (diff)
downloadmeta-openembedded-baa8a5e3c8a93e84e416981121124c2971ac9d90.tar.gz
python3-socketio: Upgrade 5.1.0 -> 5.3.0
Upgrade to release 5.3.0: - Document WebSocket support for threading mode - Allow functions to be used for URL, headers and auth data in client connection - Emit events to multiple rooms - More descriptive error when joining a room on a bad namespace - Document the use of arguments in the connect_error handler - Document that callbacks cannot be used in external processes - Improve start_background_task() example in the documentation - Added Open Collective funding option - Remove Python 2 from PyPI classifiers Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-socketio_5.3.0.bb (renamed from meta-python/recipes-devtools/python/python3-socketio_5.1.0.bb)3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-socketio_5.1.0.bb b/meta-python/recipes-devtools/python/python3-socketio_5.3.0.bb
index 8cf6a96ba..4a9d3ebef 100644
--- a/meta-python/recipes-devtools/python/python3-socketio_5.1.0.bb
+++ b/meta-python/recipes-devtools/python/python3-socketio_5.3.0.bb
@@ -9,7 +9,7 @@ inherit pypi setuptools3
9 9
10PYPI_PACKAGE = "python-socketio" 10PYPI_PACKAGE = "python-socketio"
11 11
12SRC_URI[sha256sum] = "338cc29abb6f3ca14c88f1f8d05ed27c690df4648f62062b299f92625bbf7093" 12SRC_URI[sha256sum] = "3dcc9785aaeef3a9eeb36c3818095662342744bdcdabd050fe697cdb826a1c2b"
13 13
14PACKAGECONFIG ?= "asyncio_client client" 14PACKAGECONFIG ?= "asyncio_client client"
15PACKAGECONFIG[asyncio_client] = ",,,${PYTHON_PN}-aiohttp ${PYTHON_PN}-websockets" 15PACKAGECONFIG[asyncio_client] = ",,,${PYTHON_PN}-aiohttp ${PYTHON_PN}-websockets"
@@ -24,4 +24,5 @@ RDEPENDS_${PN} += "\
24 ${PYTHON_PN}-threading \ 24 ${PYTHON_PN}-threading \
25 ${PYTHON_PN}-six \ 25 ${PYTHON_PN}-six \
26 ${PYTHON_PN}-attrs \ 26 ${PYTHON_PN}-attrs \
27 ${PYTHON_PN}-bidict \
27 " 28 "