summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorChristian Eggers <ceggers@arri.de>2021-11-22 11:12:04 +0100
committerKhem Raj <raj.khem@gmail.com>2021-11-24 09:31:08 -0800
commitb695c663562688d7540039e1074e3ba0967ed77b (patch)
treeb850973a87ede70cb81453805204029a06732714 /meta-python
parent05ecf0d4ff955f3debe1a8e2988d78f4aeaa3b57 (diff)
downloadmeta-openembedded-b695c663562688d7540039e1074e3ba0967ed77b.tar.gz
python3-gcovr: add recipe
Self description from the website: Gcovr provides a utility for managing the use of the GNU gcov utility and generating summarized code coverage results. This command is inspired by the Python coverage.py package, which provides a similar utility for Python. Signed-off-by: Christian Eggers <ceggers@arri.de> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-gcovr_5.0.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-gcovr_5.0.bb b/meta-python/recipes-devtools/python/python3-gcovr_5.0.bb
new file mode 100644
index 000000000..330831a0b
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-gcovr_5.0.bb
@@ -0,0 +1,16 @@
1DESCRIPTION = "generate GCC code coverage reports"
2HOMEPAGE = "https://gcovr.com"
3SECTION = "devel/python"
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=08208c66520e8d69d5367483186d94ed"
6
7SRC_URI = "git://github.com/gcovr/gcovr.git;branch=master;protocol=https"
8SRCREV = "2b50284e8a6792b4ddcba14e2050c5c05f15deb6"
9
10S = "${WORKDIR}/git"
11
12inherit setuptools3
13
14RDEPENDS:${PN} += "${PYTHON_PN}-jinja2 ${PYTHON_PN}-lxml ${PYTHON_PN}-setuptools ${PYTHON_PN}-pygments"
15
16BBCLASSEXTEND = "native nativesdk"