summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorJens Rehsack <sno@netbsd.org>2018-08-27 13:07:31 +0200
committerKhem Raj <raj.khem@gmail.com>2018-08-28 09:36:28 -0700
commitb3b34496758768d06a18621754492dde730c9423 (patch)
treee3581d6353f5e60d670360b3b6dc529452fceb6d /meta-python
parentd9309e44aa1d530c77ced19af1b4d2c5c0dbec6e (diff)
downloadmeta-openembedded-b3b34496758768d06a18621754492dde730c9423.tar.gz
python{,3}-grpcio: update to 1.14.1
Update python-grpcio and add related python3-grpcio recipe for recent features and bug-fixes. Signed-off-by: Jens Rehsack <sno@netbsd.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-grpcio.inc25
-rw-r--r--meta-python/recipes-devtools/python/python-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch21
-rw-r--r--meta-python/recipes-devtools/python/python-grpcio_1.14.1.bb6
-rw-r--r--meta-python/recipes-devtools/python/python-grpcio_1.8.4.bb25
-rw-r--r--meta-python/recipes-devtools/python/python3-grpcio_1.14.1.bb2
5 files changed, 48 insertions, 31 deletions
diff --git a/meta-python/recipes-devtools/python/python-grpcio.inc b/meta-python/recipes-devtools/python/python-grpcio.inc
new file mode 100644
index 000000000..23d25f7aa
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-grpcio.inc
@@ -0,0 +1,25 @@
1DESCRIPTION = "Google gRPC"
2HOMEPAGE = "http://www.grpc.io/"
3SECTION = "devel/python"
4
5DEPENDS_append = "${PYTHON_PN}-protobuf"
6
7FILESEXTRAPATHS_prepend := "${THISDIR}/python-grpcio:"
8SRC_URI_append_class-target = " file://0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch "
9
10RDEPENDS_${PN} = "${PYTHON_PN}-protobuf \
11 ${PYTHON_PN}-setuptools \
12 ${PYTHON_PN}-six \
13"
14
15LICENSE = "BSD-3-Clause"
16LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/BSD-3-Clause;md5=550794465ba0ec5312d6919e203a55f9"
17
18inherit pypi
19
20SRC_URI[md5sum] = "0987ae2e47b5103de3cacc437874a3c5"
21SRC_URI[sha256sum] = "4bf23666e763ca7ff6010465864e9f088f4ac7ecc1e11abd6f85b250e66b2c05"
22
23CLEANBROKEN = "1"
24
25BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch b/meta-python/recipes-devtools/python/python-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch
index 0c1d964a6..996597b14 100644
--- a/meta-python/recipes-devtools/python/python-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch
+++ b/meta-python/recipes-devtools/python/python-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch
@@ -18,16 +18,25 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
18 setup.py | 2 +- 18 setup.py | 2 +-
19 1 file changed, 1 insertion(+), 1 deletion(-) 19 1 file changed, 1 insertion(+), 1 deletion(-)
20 20
21Index: grpcio-1.8.4/setup.py 21Index: grpcio-1.14.1/setup.py
22=================================================================== 22===================================================================
23--- grpcio-1.8.4.orig/setup.py 23--- grpcio-1.14.1.orig/setup.py
24+++ grpcio-1.8.4/setup.py 24+++ grpcio-1.14.1/setup.py
25@@ -115,7 +115,7 @@ if EXTRA_ENV_COMPILE_ARGS is None: 25@@ -123,7 +123,7 @@ ENABLE_DOCUMENTATION_BUILD = os.environ.
26 EXTRA_ENV_COMPILE_ARGS = os.environ.get('GRPC_PYTHON_CFLAGS', None)
27 EXTRA_ENV_LINK_ARGS = os.environ.get('GRPC_PYTHON_LDFLAGS', None)
28 if EXTRA_ENV_COMPILE_ARGS is None:
29- EXTRA_ENV_COMPILE_ARGS = ' -std=c++11'
30+ EXTRA_ENV_COMPILE_ARGS = ""
31 if 'win32' in sys.platform and sys.version_info < (3, 5):
32 EXTRA_ENV_COMPILE_ARGS += ' -D_hypot=hypot'
33 # We use define flags here and don't directly add to DEFINE_MACROS below to
34@@ -135,7 +135,7 @@ if EXTRA_ENV_COMPILE_ARGS is None:
26 else: 35 else:
27 EXTRA_ENV_COMPILE_ARGS += ' -D_ftime=_ftime64 -D_timeb=__timeb64' 36 EXTRA_ENV_COMPILE_ARGS += ' -D_ftime=_ftime64 -D_timeb=__timeb64'
28 elif "linux" in sys.platform: 37 elif "linux" in sys.platform:
29- EXTRA_ENV_COMPILE_ARGS += ' -std=c++11 -std=gnu99 -fvisibility=hidden -fno-wrapv -fno-exceptions' 38- EXTRA_ENV_COMPILE_ARGS += ' -std=gnu99 -fvisibility=hidden -fno-wrapv -fno-exceptions'
30+ EXTRA_ENV_COMPILE_ARGS += ' -fvisibility=hidden -fno-wrapv -fno-exceptions' 39+ EXTRA_ENV_COMPILE_ARGS += ' -fvisibility=hidden -fno-wrapv -fno-exceptions'
31 elif "darwin" in sys.platform: 40 elif "darwin" in sys.platform:
32 EXTRA_ENV_COMPILE_ARGS += ' -fvisibility=hidden -fno-wrapv -fno-exceptions' 41 EXTRA_ENV_COMPILE_ARGS += ' -fvisibility=hidden -fno-wrapv -fno-exceptions'
33 42 EXTRA_ENV_COMPILE_ARGS += ' -DPB_FIELD_16BIT'
diff --git a/meta-python/recipes-devtools/python/python-grpcio_1.14.1.bb b/meta-python/recipes-devtools/python/python-grpcio_1.14.1.bb
new file mode 100644
index 000000000..820bea44b
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-grpcio_1.14.1.bb
@@ -0,0 +1,6 @@
1inherit setuptools
2require python-grpcio.inc
3
4RDEPENDS_${PN} += " python-enum34 \
5 python-futures \
6"
diff --git a/meta-python/recipes-devtools/python/python-grpcio_1.8.4.bb b/meta-python/recipes-devtools/python/python-grpcio_1.8.4.bb
deleted file mode 100644
index bec9d846b..000000000
--- a/meta-python/recipes-devtools/python/python-grpcio_1.8.4.bb
+++ /dev/null
@@ -1,25 +0,0 @@
1DESCRIPTION = "Google gRPC"
2HOMEPAGE = "http://www.grpc.io/"
3SECTION = "devel/python"
4
5DEPENDS = "python-protobuf"
6
7SRC_URI_append_class-target = " file://0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch "
8
9RDEPENDS_${PN} = "python-enum34 \
10 python-futures \
11 python-protobuf \
12 python-setuptools \
13 python-six \
14"
15
16LICENSE = "BSD-3-Clause"
17LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/BSD-3-Clause;md5=550794465ba0ec5312d6919e203a55f9"
18
19inherit pypi setuptools
20
21SRC_URI[md5sum] = "7860f7c61de3890323670b7b1ff63e56"
22SRC_URI[sha256sum] = "88d87aab9c7889b3ab29dd74aac1a5493ed78b9bf5afba1c069c9dd5531f951d"
23
24# For usage in other recipes when compiling protobuf files (e.g. by grpcio-tools)
25BBCLASSEXTEND = "native"
diff --git a/meta-python/recipes-devtools/python/python3-grpcio_1.14.1.bb b/meta-python/recipes-devtools/python/python3-grpcio_1.14.1.bb
new file mode 100644
index 000000000..d4720b4b8
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-grpcio_1.14.1.bb
@@ -0,0 +1,2 @@
1inherit setuptools3
2require python-grpcio.inc