summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2025-01-07 16:00:38 +0200
committerKhem Raj <raj.khem@gmail.com>2025-01-07 09:33:17 -0800
commitafc078bab378bc721a260f5b56165fd4ef129c66 (patch)
tree5c7669a2941ede5fe6b82eef431d0cdbe91a1ec2 /meta-python
parent33700ad5f8ca26d5d8a75e9adfc7c0351ae7c385 (diff)
downloadmeta-openembedded-afc078bab378bc721a260f5b56165fd4ef129c66.tar.gz
python3-anyio: Upgrade 4.7.0 -> 4.8.0
Upgrade to release 4.8.0: - Added experimental support for running functions in subinterpreters on Python 3.13 and later - Added support for the copy(), copy_into(), move() and move_into() methods in anyio.Path, available in Python 3.14 - Changed TaskGroup on asyncio to always spawn tasks non-eagerly, even if using a task factory created via asyncio.create_eager_task_factory(), to preserve expected Trio-like task scheduling semantics - Configure SO_RCVBUF, SO_SNDBUF and TCP_NODELAY on the selector thread waker socket pair (this should improve the performance of wait_readable() and wait_writable() when using the ProactorEventLoop) - Fixed AssertionError when using nest-asyncio - Fixed return type annotation of various context managers' __exit__ method Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-anyio_4.8.0.bb (renamed from meta-python/recipes-devtools/python/python3-anyio_4.7.0.bb)2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-anyio_4.7.0.bb b/meta-python/recipes-devtools/python/python3-anyio_4.8.0.bb
index 5f90ffbd5..c103eba46 100644
--- a/meta-python/recipes-devtools/python/python3-anyio_4.7.0.bb
+++ b/meta-python/recipes-devtools/python/python3-anyio_4.8.0.bb
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=c0a769411d2af7894099e8ff75058c9f"
5 5
6inherit pypi python_setuptools_build_meta 6inherit pypi python_setuptools_build_meta
7 7
8SRC_URI[sha256sum] = "2f834749c602966b7d456a7567cafcb309f96482b5081d14ac93ccd457f9dd48" 8SRC_URI[sha256sum] = "1d9fe889df5212298c0c0723fa20479d1b94883a2df44bd3897aa91083316f7a"
9 9
10DEPENDS += " \ 10DEPENDS += " \
11 python3-setuptools-scm-native \ 11 python3-setuptools-scm-native \