summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2024-03-19 13:45:10 +0800
committerKhem Raj <raj.khem@gmail.com>2024-03-20 09:28:07 -0700
commita6439a2179f8b6d514bc00f14f76ae71ea3bb5f0 (patch)
treea1262d9be6d5e6fff26c16422a0570a79e0adee2 /meta-python
parent99b4f570ff7da277c407a86ad809086d433e813b (diff)
downloadmeta-openembedded-a6439a2179f8b6d514bc00f14f76ae71ea3bb5f0.tar.gz
python3-blivet: upgrade 3.8.2 -> 3.9.1
0002-run_program-support-timeout.patch 0003-support-infinit-timeout.patch 0005-fix-incorrect-timeout-while-system-time-changed.patch 0006-tweak-btrfs-packages.patch 0007-invoking-mount-with-infinite-timeout.patch 0008-use-oe-variable-to-replace-hardcoded-dir.patch 0010-invoking-mkfs-with-infinite-timeout.patch 0011-invoking-dd-with-infinite-timeout.patch refreshed for 3.9.1 Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-extended/python-blivet/python3-blivet/0002-run_program-support-timeout.patch13
-rw-r--r--meta-python/recipes-extended/python-blivet/python3-blivet/0003-support-infinit-timeout.patch17
-rw-r--r--meta-python/recipes-extended/python-blivet/python3-blivet/0005-fix-incorrect-timeout-while-system-time-changed.patch9
-rw-r--r--meta-python/recipes-extended/python-blivet/python3-blivet/0006-tweak-btrfs-packages.patch13
-rw-r--r--meta-python/recipes-extended/python-blivet/python3-blivet/0007-invoking-mount-with-infinite-timeout.patch9
-rw-r--r--meta-python/recipes-extended/python-blivet/python3-blivet/0008-use-oe-variable-to-replace-hardcoded-dir.patch9
-rw-r--r--meta-python/recipes-extended/python-blivet/python3-blivet/0010-invoking-mkfs-with-infinite-timeout.patch9
-rw-r--r--meta-python/recipes-extended/python-blivet/python3-blivet/0011-invoking-dd-with-infinite-timeout.patch9
-rw-r--r--meta-python/recipes-extended/python-blivet/python3-blivet_3.9.1.bb (renamed from meta-python/recipes-extended/python-blivet/python3-blivet_3.8.2.bb)2
9 files changed, 33 insertions, 57 deletions
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivet/0002-run_program-support-timeout.patch b/meta-python/recipes-extended/python-blivet/python3-blivet/0002-run_program-support-timeout.patch
index 5b388599b..d277e8b0f 100644
--- a/meta-python/recipes-extended/python-blivet/python3-blivet/0002-run_program-support-timeout.patch
+++ b/meta-python/recipes-extended/python-blivet/python3-blivet/0002-run_program-support-timeout.patch
@@ -1,4 +1,4 @@
1From 713cf821ebe17f9e1771502a85e0905ea04dafae Mon Sep 17 00:00:00 2001 1From 8a18a6c1dea7cce6669d0eeb4230e85aa88d8e44 Mon Sep 17 00:00:00 2001
2From: Hongxu Jia <hongxu.jia@windriver.com> 2From: Hongxu Jia <hongxu.jia@windriver.com>
3Date: Fri, 23 Nov 2018 17:03:58 +0800 3Date: Fri, 23 Nov 2018 17:03:58 +0800
4Subject: [PATCH 02/11] run_program support timeout 4Subject: [PATCH 02/11] run_program support timeout
@@ -7,14 +7,14 @@ Upstream-Status: Pending
7 7
8Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> 8Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
9--- 9---
10 blivet/util.py | 70 ++++++++++++++++++++++++++++++++++------------------------ 10 blivet/util.py | 70 +++++++++++++++++++++++++++++---------------------
11 1 file changed, 41 insertions(+), 29 deletions(-) 11 1 file changed, 41 insertions(+), 29 deletions(-)
12 12
13diff --git a/blivet/util.py b/blivet/util.py 13diff --git a/blivet/util.py b/blivet/util.py
14index 4eac8b9..4f05076 100644 14index f8a8f88..a5da7b6 100644
15--- a/blivet/util.py 15--- a/blivet/util.py
16+++ b/blivet/util.py 16+++ b/blivet/util.py
17@@ -158,6 +158,30 @@ class Path(str): 17@@ -171,6 +171,30 @@ class Path(str):
18 def __hash__(self): 18 def __hash__(self):
19 return self._path.__hash__() 19 return self._path.__hash__()
20 20
@@ -45,7 +45,7 @@ index 4eac8b9..4f05076 100644
45 45
46 def _run_program(argv, root='/', stdin=None, env_prune=None, stderr_to_stdout=False, binary_output=False): 46 def _run_program(argv, root='/', stdin=None, env_prune=None, stderr_to_stdout=False, binary_output=False):
47 if env_prune is None: 47 if env_prune is None:
48@@ -180,35 +204,23 @@ def _run_program(argv, root='/', stdin=None, env_prune=None, stderr_to_stdout=Fa 48@@ -193,35 +217,23 @@ def _run_program(argv, root='/', stdin=None, env_prune=None, stderr_to_stdout=Fa
49 stderr_dir = subprocess.STDOUT 49 stderr_dir = subprocess.STDOUT
50 else: 50 else:
51 stderr_dir = subprocess.PIPE 51 stderr_dir = subprocess.PIPE
@@ -98,6 +98,3 @@ index 4eac8b9..4f05076 100644
98 98
99 99
100 def run_program(*args, **kwargs): 100 def run_program(*args, **kwargs):
101--
1022.7.4
103
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivet/0003-support-infinit-timeout.patch b/meta-python/recipes-extended/python-blivet/python3-blivet/0003-support-infinit-timeout.patch
index 861b2cdd4..8ab65a3e2 100644
--- a/meta-python/recipes-extended/python-blivet/python3-blivet/0003-support-infinit-timeout.patch
+++ b/meta-python/recipes-extended/python-blivet/python3-blivet/0003-support-infinit-timeout.patch
@@ -1,4 +1,4 @@
1From 5d5436dfa3bdde7b4e87ce5a40cbc724199847d6 Mon Sep 17 00:00:00 2001 1From 112b825541f498762f373cfc9918e444dda74095 Mon Sep 17 00:00:00 2001
2From: Hongxu Jia <hongxu.jia@windriver.com> 2From: Hongxu Jia <hongxu.jia@windriver.com>
3Date: Mon, 8 May 2017 16:18:02 +0800 3Date: Mon, 8 May 2017 16:18:02 +0800
4Subject: [PATCH 03/11] support infinit timeout 4Subject: [PATCH 03/11] support infinit timeout
@@ -11,10 +11,10 @@ Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
11 1 file changed, 8 insertions(+), 4 deletions(-) 11 1 file changed, 8 insertions(+), 4 deletions(-)
12 12
13diff --git a/blivet/util.py b/blivet/util.py 13diff --git a/blivet/util.py b/blivet/util.py
14index 4f05076..7e89949 100644 14index a5da7b6..58117ae 100644
15--- a/blivet/util.py 15--- a/blivet/util.py
16+++ b/blivet/util.py 16+++ b/blivet/util.py
17@@ -158,6 +158,7 @@ class Path(str): 17@@ -171,6 +171,7 @@ class Path(str):
18 def __hash__(self): 18 def __hash__(self):
19 return self._path.__hash__() 19 return self._path.__hash__()
20 20
@@ -22,7 +22,7 @@ index 4f05076..7e89949 100644
22 def timeout_command(argv, timeout, *args, **kwargs): 22 def timeout_command(argv, timeout, *args, **kwargs):
23 """call shell-command and either return its output or kill it 23 """call shell-command and either return its output or kill it
24 if it doesn't normally exit within timeout seconds and return None""" 24 if it doesn't normally exit within timeout seconds and return None"""
25@@ -169,7 +170,7 @@ def timeout_command(argv, timeout, *args, **kwargs): 25@@ -182,7 +183,7 @@ def timeout_command(argv, timeout, *args, **kwargs):
26 while proc.poll() is None: 26 while proc.poll() is None:
27 time.sleep(0.1) 27 time.sleep(0.1)
28 now = datetime.datetime.now() 28 now = datetime.datetime.now()
@@ -31,7 +31,7 @@ index 4f05076..7e89949 100644
31 os.kill(proc.pid, signal.SIGKILL) 31 os.kill(proc.pid, signal.SIGKILL)
32 os.waitpid(-1, os.WNOHANG) 32 os.waitpid(-1, os.WNOHANG)
33 program_log.debug("%d seconds timeout" % timeout) 33 program_log.debug("%d seconds timeout" % timeout)
34@@ -183,7 +184,7 @@ def timeout_command(argv, timeout, *args, **kwargs): 34@@ -196,7 +197,7 @@ def timeout_command(argv, timeout, *args, **kwargs):
35 program_log.debug("Return code: %d", proc.returncode) 35 program_log.debug("Return code: %d", proc.returncode)
36 return (proc.returncode, proc.stdout.read()) 36 return (proc.returncode, proc.stdout.read())
37 37
@@ -40,7 +40,7 @@ index 4f05076..7e89949 100644
40 if env_prune is None: 40 if env_prune is None:
41 env_prune = [] 41 env_prune = []
42 42
43@@ -192,7 +193,10 @@ def _run_program(argv, root='/', stdin=None, env_prune=None, stderr_to_stdout=Fa 43@@ -205,7 +206,10 @@ def _run_program(argv, root='/', stdin=None, env_prune=None, stderr_to_stdout=Fa
44 os.chroot(root) 44 os.chroot(root)
45 45
46 with program_log_lock: # pylint: disable=not-context-manager 46 with program_log_lock: # pylint: disable=not-context-manager
@@ -52,7 +52,7 @@ index 4f05076..7e89949 100644
52 52
53 env = os.environ.copy() 53 env = os.environ.copy()
54 env.update({"LC_ALL": "C", 54 env.update({"LC_ALL": "C",
55@@ -205,7 +209,7 @@ def _run_program(argv, root='/', stdin=None, env_prune=None, stderr_to_stdout=Fa 55@@ -218,7 +222,7 @@ def _run_program(argv, root='/', stdin=None, env_prune=None, stderr_to_stdout=Fa
56 else: 56 else:
57 stderr_dir = subprocess.PIPE 57 stderr_dir = subprocess.PIPE
58 58
@@ -61,6 +61,3 @@ index 4f05076..7e89949 100644
61 stdin=stdin, 61 stdin=stdin,
62 stdout=subprocess.PIPE, 62 stdout=subprocess.PIPE,
63 stderr=stderr_dir, 63 stderr=stderr_dir,
64--
652.7.4
66
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivet/0005-fix-incorrect-timeout-while-system-time-changed.patch b/meta-python/recipes-extended/python-blivet/python3-blivet/0005-fix-incorrect-timeout-while-system-time-changed.patch
index 9c5d53b43..795e4f120 100644
--- a/meta-python/recipes-extended/python-blivet/python3-blivet/0005-fix-incorrect-timeout-while-system-time-changed.patch
+++ b/meta-python/recipes-extended/python-blivet/python3-blivet/0005-fix-incorrect-timeout-while-system-time-changed.patch
@@ -1,4 +1,4 @@
1From f783b9b00da5df176fcd7927b752f574ca6db319 Mon Sep 17 00:00:00 2001 1From c645c83628b2290855cbd225e13c038ab75a7f74 Mon Sep 17 00:00:00 2001
2From: Hongxu Jia <hongxu.jia@windriver.com> 2From: Hongxu Jia <hongxu.jia@windriver.com>
3Date: Fri, 26 Aug 2016 02:02:49 -0400 3Date: Fri, 26 Aug 2016 02:02:49 -0400
4Subject: [PATCH 05/11] fix incorrect timeout while system time changed 4Subject: [PATCH 05/11] fix incorrect timeout while system time changed
@@ -22,10 +22,10 @@ Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
22 1 file changed, 3 insertions(+), 3 deletions(-) 22 1 file changed, 3 insertions(+), 3 deletions(-)
23 23
24diff --git a/blivet/util.py b/blivet/util.py 24diff --git a/blivet/util.py b/blivet/util.py
25index 7e89949..5571e73 100644 25index 58117ae..5bc5804 100644
26--- a/blivet/util.py 26--- a/blivet/util.py
27+++ b/blivet/util.py 27+++ b/blivet/util.py
28@@ -163,14 +163,14 @@ def timeout_command(argv, timeout, *args, **kwargs): 28@@ -176,14 +176,14 @@ def timeout_command(argv, timeout, *args, **kwargs):
29 """call shell-command and either return its output or kill it 29 """call shell-command and either return its output or kill it
30 if it doesn't normally exit within timeout seconds and return None""" 30 if it doesn't normally exit within timeout seconds and return None"""
31 import subprocess, datetime, os, time, signal 31 import subprocess, datetime, os, time, signal
@@ -43,6 +43,3 @@ index 7e89949..5571e73 100644
43 os.kill(proc.pid, signal.SIGKILL) 43 os.kill(proc.pid, signal.SIGKILL)
44 os.waitpid(-1, os.WNOHANG) 44 os.waitpid(-1, os.WNOHANG)
45 program_log.debug("%d seconds timeout" % timeout) 45 program_log.debug("%d seconds timeout" % timeout)
46--
472.7.4
48
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivet/0006-tweak-btrfs-packages.patch b/meta-python/recipes-extended/python-blivet/python3-blivet/0006-tweak-btrfs-packages.patch
index 2e53a6477..b98dafeab 100644
--- a/meta-python/recipes-extended/python-blivet/python3-blivet/0006-tweak-btrfs-packages.patch
+++ b/meta-python/recipes-extended/python-blivet/python3-blivet/0006-tweak-btrfs-packages.patch
@@ -1,4 +1,4 @@
1From 8932ae933f2b6acf5e98c9956beff69ae430eed2 Mon Sep 17 00:00:00 2001 1From 359bc9f60a4bcf6be64a72c3825af65269f6c6c9 Mon Sep 17 00:00:00 2001
2From: Hongxu Jia <hongxu.jia@windriver.com> 2From: Hongxu Jia <hongxu.jia@windriver.com>
3Date: Mon, 8 May 2017 16:33:15 +0800 3Date: Mon, 8 May 2017 16:33:15 +0800
4Subject: [PATCH 06/11] tweak btrfs packages 4Subject: [PATCH 06/11] tweak btrfs packages
@@ -15,10 +15,10 @@ Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
15 2 files changed, 2 insertions(+), 2 deletions(-) 15 2 files changed, 2 insertions(+), 2 deletions(-)
16 16
17diff --git a/blivet/devices/btrfs.py b/blivet/devices/btrfs.py 17diff --git a/blivet/devices/btrfs.py b/blivet/devices/btrfs.py
18index cada940..7e4d4b8 100644 18index 259bcf8..8e4eb2b 100644
19--- a/blivet/devices/btrfs.py 19--- a/blivet/devices/btrfs.py
20+++ b/blivet/devices/btrfs.py 20+++ b/blivet/devices/btrfs.py
21@@ -55,7 +55,7 @@ class BTRFSDevice(StorageDevice): 21@@ -57,7 +57,7 @@ class BTRFSDevice(StorageDevice):
22 22
23 """ Base class for BTRFS volume and sub-volume devices. """ 23 """ Base class for BTRFS volume and sub-volume devices. """
24 _type = "btrfs" 24 _type = "btrfs"
@@ -28,10 +28,10 @@ index cada940..7e4d4b8 100644
28 28
29 def __init__(self, *args, **kwargs): 29 def __init__(self, *args, **kwargs):
30diff --git a/blivet/formats/fs.py b/blivet/formats/fs.py 30diff --git a/blivet/formats/fs.py b/blivet/formats/fs.py
31index 81e367f..55e5d57 100644 31index 932307a..865b863 100644
32--- a/blivet/formats/fs.py 32--- a/blivet/formats/fs.py
33+++ b/blivet/formats/fs.py 33+++ b/blivet/formats/fs.py
34@@ -926,7 +926,7 @@ class BTRFS(FS): 34@@ -1049,7 +1049,7 @@ class BTRFS(FS):
35 _formattable = True 35 _formattable = True
36 _linux_native = True 36 _linux_native = True
37 _supported = True 37 _supported = True
@@ -40,6 +40,3 @@ index 81e367f..55e5d57 100644
40 _min_size = Size("256 MiB") 40 _min_size = Size("256 MiB")
41 _max_size = Size("16 EiB") 41 _max_size = Size("16 EiB")
42 _mkfs_class = fsmkfs.BTRFSMkfs 42 _mkfs_class = fsmkfs.BTRFSMkfs
43--
442.7.4
45
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivet/0007-invoking-mount-with-infinite-timeout.patch b/meta-python/recipes-extended/python-blivet/python3-blivet/0007-invoking-mount-with-infinite-timeout.patch
index b2606d769..809f4e158 100644
--- a/meta-python/recipes-extended/python-blivet/python3-blivet/0007-invoking-mount-with-infinite-timeout.patch
+++ b/meta-python/recipes-extended/python-blivet/python3-blivet/0007-invoking-mount-with-infinite-timeout.patch
@@ -1,4 +1,4 @@
1From f53481dc4a56b8a996628733553e080bb0aafdd7 Mon Sep 17 00:00:00 2001 1From f159d71d742ace5640c7810bcc27365f8fde95a3 Mon Sep 17 00:00:00 2001
2From: Hongxu Jia <hongxu.jia@windriver.com> 2From: Hongxu Jia <hongxu.jia@windriver.com>
3Date: Fri, 23 Nov 2018 17:07:22 +0800 3Date: Fri, 23 Nov 2018 17:07:22 +0800
4Subject: [PATCH 07/11] invoking mount with infinite timeout 4Subject: [PATCH 07/11] invoking mount with infinite timeout
@@ -14,10 +14,10 @@ Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
14 1 file changed, 1 insertion(+), 1 deletion(-) 14 1 file changed, 1 insertion(+), 1 deletion(-)
15 15
16diff --git a/blivet/util.py b/blivet/util.py 16diff --git a/blivet/util.py b/blivet/util.py
17index 5571e73..02c8033 100644 17index 5bc5804..9de77e1 100644
18--- a/blivet/util.py 18--- a/blivet/util.py
19+++ b/blivet/util.py 19+++ b/blivet/util.py
20@@ -258,7 +258,7 @@ def mount(device, mountpoint, fstype, options=None): 20@@ -271,7 +271,7 @@ def mount(device, mountpoint, fstype, options=None):
21 makedirs(mountpoint) 21 makedirs(mountpoint)
22 22
23 argv = ["mount", "-t", fstype, "-o", options, device, mountpoint] 23 argv = ["mount", "-t", fstype, "-o", options, device, mountpoint]
@@ -26,6 +26,3 @@ index 5571e73..02c8033 100644
26 26
27 27
28 def umount(mountpoint): 28 def umount(mountpoint):
29--
302.7.4
31
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivet/0008-use-oe-variable-to-replace-hardcoded-dir.patch b/meta-python/recipes-extended/python-blivet/python3-blivet/0008-use-oe-variable-to-replace-hardcoded-dir.patch
index 1e8bcac47..d3ab8f852 100644
--- a/meta-python/recipes-extended/python-blivet/python3-blivet/0008-use-oe-variable-to-replace-hardcoded-dir.patch
+++ b/meta-python/recipes-extended/python-blivet/python3-blivet/0008-use-oe-variable-to-replace-hardcoded-dir.patch
@@ -1,4 +1,4 @@
1From 12e2579333258d1a690f8718e91b0f217078e886 Mon Sep 17 00:00:00 2001 1From 6a85945c060154581f5a129a6a946258bf9333c4 Mon Sep 17 00:00:00 2001
2From: Hongxu Jia <hongxu.jia@windriver.com> 2From: Hongxu Jia <hongxu.jia@windriver.com>
3Date: Mon, 8 May 2017 03:54:12 -0400 3Date: Mon, 8 May 2017 03:54:12 -0400
4Subject: [PATCH 08/11] use oe variable to replace hardcoded dir 4Subject: [PATCH 08/11] use oe variable to replace hardcoded dir
@@ -15,10 +15,10 @@ Signed-off-by: Kai Kang <kai.kang@windriver.com>
15 1 file changed, 4 insertions(+), 4 deletions(-) 15 1 file changed, 4 insertions(+), 4 deletions(-)
16 16
17diff --git a/setup.py b/setup.py 17diff --git a/setup.py b/setup.py
18index b745a79..b5b4258 100644 18index e6bb3f3..700085b 100644
19--- a/setup.py 19--- a/setup.py
20+++ b/setup.py 20+++ b/setup.py
21@@ -61,10 +61,10 @@ class blivet_sdist(sdist): 21@@ -73,10 +73,10 @@ class blivet_sdist(sdist):
22 22
23 23
24 data_files = [ 24 data_files = [
@@ -33,6 +33,3 @@ index b745a79..b5b4258 100644
33 ] 33 ]
34 34
35 35
36--
372.7.4
38
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivet/0010-invoking-mkfs-with-infinite-timeout.patch b/meta-python/recipes-extended/python-blivet/python3-blivet/0010-invoking-mkfs-with-infinite-timeout.patch
index c441acd17..394a818aa 100644
--- a/meta-python/recipes-extended/python-blivet/python3-blivet/0010-invoking-mkfs-with-infinite-timeout.patch
+++ b/meta-python/recipes-extended/python-blivet/python3-blivet/0010-invoking-mkfs-with-infinite-timeout.patch
@@ -1,4 +1,4 @@
1From 33844f6773a676bd57240954e402ae9a843663a4 Mon Sep 17 00:00:00 2001 1From abadd821acffd5dbc870f86dad3c3a6bf3f2f74f Mon Sep 17 00:00:00 2001
2From: Hongxu Jia <hongxu.jia@windriver.com> 2From: Hongxu Jia <hongxu.jia@windriver.com>
3Date: Fri, 16 Jun 2017 15:43:00 +0800 3Date: Fri, 16 Jun 2017 15:43:00 +0800
4Subject: [PATCH 10/11] invoking mkfs with infinite timeout 4Subject: [PATCH 10/11] invoking mkfs with infinite timeout
@@ -18,10 +18,10 @@ Signed-off-by: Kai Kang <kai.kang@windriver.com>
18 1 file changed, 1 insertion(+), 1 deletion(-) 18 1 file changed, 1 insertion(+), 1 deletion(-)
19 19
20diff --git a/blivet/tasks/fsmkfs.py b/blivet/tasks/fsmkfs.py 20diff --git a/blivet/tasks/fsmkfs.py b/blivet/tasks/fsmkfs.py
21index e4a6aaa8..9730f7e5 100644 21index e9daa9e..2174cc3 100644
22--- a/blivet/tasks/fsmkfs.py 22--- a/blivet/tasks/fsmkfs.py
23+++ b/blivet/tasks/fsmkfs.py 23+++ b/blivet/tasks/fsmkfs.py
24@@ -203,7 +203,7 @@ class FSMkfs(task.BasicApplication, FSMkfsTask): 24@@ -207,7 +207,7 @@ class FSMkfs(task.BasicApplication, FSMkfsTask):
25 options = options or [] 25 options = options or []
26 cmd = self._mkfs_command(options, label, set_uuid, nodiscard) 26 cmd = self._mkfs_command(options, label, set_uuid, nodiscard)
27 try: 27 try:
@@ -30,6 +30,3 @@ index e4a6aaa8..9730f7e5 100644
30 except OSError as e: 30 except OSError as e:
31 raise FSError(e) 31 raise FSError(e)
32 32
33--
342.7.4
35
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivet/0011-invoking-dd-with-infinite-timeout.patch b/meta-python/recipes-extended/python-blivet/python3-blivet/0011-invoking-dd-with-infinite-timeout.patch
index 13c2933f0..48ffaf2cb 100644
--- a/meta-python/recipes-extended/python-blivet/python3-blivet/0011-invoking-dd-with-infinite-timeout.patch
+++ b/meta-python/recipes-extended/python-blivet/python3-blivet/0011-invoking-dd-with-infinite-timeout.patch
@@ -1,4 +1,4 @@
1From 21ca2b859a49e96a230d55a7866dfc7ed5d1366c Mon Sep 17 00:00:00 2001 1From 3d398173f02bb641473299abb1166fdcc3643666 Mon Sep 17 00:00:00 2001
2From: Hongxu Jia <hongxu.jia@windriver.com> 2From: Hongxu Jia <hongxu.jia@windriver.com>
3Date: Tue, 6 Mar 2018 17:28:56 +0800 3Date: Tue, 6 Mar 2018 17:28:56 +0800
4Subject: [PATCH 11/11] invoking dd with infinite timeout 4Subject: [PATCH 11/11] invoking dd with infinite timeout
@@ -14,10 +14,10 @@ Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
14 1 file changed, 1 insertion(+), 1 deletion(-) 14 1 file changed, 1 insertion(+), 1 deletion(-)
15 15
16diff --git a/blivet/devices/partition.py b/blivet/devices/partition.py 16diff --git a/blivet/devices/partition.py b/blivet/devices/partition.py
17index 623e1c9..141d8ad 100644 17index b60b9b4..fa8858b 100644
18--- a/blivet/devices/partition.py 18--- a/blivet/devices/partition.py
19+++ b/blivet/devices/partition.py 19+++ b/blivet/devices/partition.py
20@@ -618,7 +618,7 @@ class PartitionDevice(StorageDevice): 20@@ -667,7 +667,7 @@ class PartitionDevice(StorageDevice):
21 cmd = ["dd", "if=/dev/zero", "of=%s" % device, "bs=%d" % bs, 21 cmd = ["dd", "if=/dev/zero", "of=%s" % device, "bs=%d" % bs,
22 "seek=%d" % start, "count=%d" % count] 22 "seek=%d" % start, "count=%d" % count]
23 try: 23 try:
@@ -26,6 +26,3 @@ index 623e1c9..141d8ad 100644
26 except OSError as e: 26 except OSError as e:
27 log.error(str(e)) 27 log.error(str(e))
28 finally: 28 finally:
29--
302.7.4
31
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivet_3.8.2.bb b/meta-python/recipes-extended/python-blivet/python3-blivet_3.9.1.bb
index 52b3aa7dc..e9c27548e 100644
--- a/meta-python/recipes-extended/python-blivet/python3-blivet_3.8.2.bb
+++ b/meta-python/recipes-extended/python-blivet/python3-blivet_3.9.1.bb
@@ -16,7 +16,7 @@ SRC_URI += "\
16 file://0010-invoking-mkfs-with-infinite-timeout.patch \ 16 file://0010-invoking-mkfs-with-infinite-timeout.patch \
17 file://0011-invoking-dd-with-infinite-timeout.patch \ 17 file://0011-invoking-dd-with-infinite-timeout.patch \
18" 18"
19SRC_URI[sha256sum] = "88d1500c76c4660aec7da9e9aa54f7f574546571b52c07a67e1417883c2cb25b" 19SRC_URI[sha256sum] = "fda09ac9ddbbacbb0c00e867006cf36b213b8f5707accdfaaebfd27378f362d8"
20 20
21inherit pypi features_check systemd setuptools3_legacy 21inherit pypi features_check systemd setuptools3_legacy
22 22