summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-05-27 00:32:43 +0300
committerKhem Raj <raj.khem@gmail.com>2021-05-28 06:50:20 -0700
commita436443bea27bcaa5f6dfa616644bd0bc1f7bbf3 (patch)
tree3fd74efec22e83b5742a3a52da748ad17c54f5e8 /meta-python
parent44b5c60c4b50656fe7a11cf2d320311f6b480d69 (diff)
downloadmeta-openembedded-a436443bea27bcaa5f6dfa616644bd0bc1f7bbf3.tar.gz
python3-flask: Upgrade 1.1.2 -> 2.0.1
Upgrade to release 2.0.1: - Re-add the filename parameter in send_from_directory. The filename parameter has been renamed to path, the old name is deprecated. - Mark top-level names as exported so type checking understands imports in user projects. - Fix type annotation for g and inform mypy that it is a namespace object that has arbitrary attributes. - Fix some types that weren’t available in Python 3.6.0. - Improve typing for send_file, send_from_directory, and get_send_file_max_age. - Show an error when a blueprint name contains a dot. The . has special meaning, it is used to separate (nested) blueprint names and the endpoint name. - Combine URL prefixes when nesting blueprints that were created with a url_prefix value. - Roll back a change to the order that URL matching was done. The URL is again matched after the session is loaded, so the session is available in custom URL converters. - Re-add deprecated Config.from_json, which was accidentally removed early. - Improve typing for some functions using Callable in their type signatures, focusing on decorator factories. - Nested blueprints are registered with their dotted name. This allows different blueprints with the same name to be nested at different locations. - register_blueprint takes a name option to change the (pre-dotted) name the blueprint is registered with. This allows the same blueprint to be registered multiple times with unique names for url_for. Registering the same blueprint with the same name multiple times is deprecated. #1091 - Improve typing for stream_with_context. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-flask_2.0.1.bb (renamed from meta-python/recipes-devtools/python/python3-flask_1.1.2.bb)3
1 files changed, 1 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-flask_1.1.2.bb b/meta-python/recipes-devtools/python/python3-flask_2.0.1.bb
index 23799617f..2c94f82da 100644
--- a/meta-python/recipes-devtools/python/python3-flask_1.1.2.bb
+++ b/meta-python/recipes-devtools/python/python3-flask_2.0.1.bb
@@ -6,8 +6,7 @@ HOMEPAGE = "https://github.com/mitsuhiko/flask/"
6LICENSE = "BSD-3-Clause" 6LICENSE = "BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=ffeffa59c90c9c4a033c7574f8f3fb75" 7LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=ffeffa59c90c9c4a033c7574f8f3fb75"
8 8
9SRC_URI[md5sum] = "0da4145d172993cd28a6c619630cc19c" 9SRC_URI[sha256sum] = "1c4c257b1892aec1398784c63791cbaa43062f1f7aeb555c4da961b20ee68f55"
10SRC_URI[sha256sum] = "4efa1ae2d7c9865af48986de8aeb8504bf32c7f3d6fdc9353d34b21f4b127060"
11 10
12PYPI_PACKAGE = "Flask" 11PYPI_PACKAGE = "Flask"
13 12