summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2023-11-01 16:32:38 +0200
committerKhem Raj <raj.khem@gmail.com>2023-11-01 20:09:08 -0700
commit9d5171a8a164fc1c47fdb5a43b7bb1b2d3e7455d (patch)
tree4093e8d2c78ccfec539a7ac7c83b56c311cfb8db /meta-python
parentf7a5d856a7d37645dc7e71e31e22d37bc8506377 (diff)
downloadmeta-openembedded-9d5171a8a164fc1c47fdb5a43b7bb1b2d3e7455d.tar.gz
python3-inflate64: add recipe
Add python3-inflate64, a python package to provide compression and decompression feature with Enhanced Deflate algorithm. This work was sponsored by GOVCERT.LU. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-inflate64_0.3.1.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-inflate64_0.3.1.bb b/meta-python/recipes-devtools/python/python3-inflate64_0.3.1.bb
new file mode 100644
index 000000000..835856025
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-inflate64_0.3.1.bb
@@ -0,0 +1,16 @@
1SUMMARY = "deflate64 compression/decompression library"
2HOMEPAGE = "https://codeberg.org/miurahr/inflate64"
3LICENSE = "LGPL-2.1-or-later"
4SECTION = "devel/python"
5LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
6
7inherit setuptools3 pypi
8
9SRC_URI[sha256sum] = "b52dd8fefd2ba179e5dfa18d6eca7e2fc822584616271c039d5ef1f9ca90c71c"
10
11PYPI_PACKAGE = "inflate64"
12
13RDEPENDS:${PN} += "\
14 ${PYTHON_PN}-core \
15 ${PYTHON_PN}-importlib-metadata \
16"