summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorDwane Pottratz <dwane.pottratz@intel.com>2018-10-05 10:33:43 -0700
committerKhem Raj <raj.khem@gmail.com>2018-10-05 14:51:14 -0700
commit99ecc889a0909d54b6bb5c795087585adde1bfbd (patch)
treec510580876fa8afe99ec0a1a0137a564c4f1c62b /meta-python
parentba24cbde104afa582b0d33edfef331567df60e11 (diff)
downloadmeta-openembedded-99ecc889a0909d54b6bb5c795087585adde1bfbd.tar.gz
python-sh: add python sh library
sh is a python subprocess replacement. Signed-off-by: Dwane Pottratz <dwane.pottratz@intel.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-sh.inc32
-rw-r--r--meta-python/recipes-devtools/python/python-sh_1.12.14.bb8
-rw-r--r--meta-python/recipes-devtools/python/python3-sh_1.12.14.bb5
3 files changed, 45 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-sh.inc b/meta-python/recipes-devtools/python/python-sh.inc
new file mode 100644
index 000000000..f2fd562bb
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-sh.inc
@@ -0,0 +1,32 @@
1SUMMARY = "Python subprocess replacement"
2HOMEPAGE = "https://github.com/amoffat/sh"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=5317094292296f03405f59ae5f6544b6"
5
6SRC_URI[md5sum] = "a8351aef25d25f707c17e0a7a6280251"
7SRC_URI[sha256sum] = "b52bf5833ed01c7b5c5fb73a7f71b3d98d48e9b9b8764236237bdc7ecae850fc"
8
9PYPI_PACKAGE = "sh"
10
11inherit pypi
12
13RDEPENDS_${PN} += " \
14 ${PYTHON_PN}-codecs \
15 ${PYTHON_PN}-core \
16 ${PYTHON_PN}-io \
17 ${PYTHON_PN}-logging \
18 ${PYTHON_PN}-resource \
19 ${PYTHON_PN}-shell \
20 ${PYTHON_PN}-terminal \
21 ${PYTHON_PN}-tests \
22 ${PYTHON_PN}-threading \
23 ${PYTHON_PN}-unixadmin \
24"
25
26# WARNING: We were unable to map the following python package/module
27# dependencies to the bitbake packages which include them:
28# coverage - only used in test and there is a check to see if it is
29# available before importing.
30# queue - part of threading
31# signal - part of core in python3. not sure how it is imported in python2.
32# No complants in compiling.
diff --git a/meta-python/recipes-devtools/python/python-sh_1.12.14.bb b/meta-python/recipes-devtools/python/python-sh_1.12.14.bb
new file mode 100644
index 000000000..7cb5140d2
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-sh_1.12.14.bb
@@ -0,0 +1,8 @@
1require python-sh.inc
2inherit setuptools
3
4RDEPENDS_${PN} += " \
5 ${PYTHON_PN}-contextlib \
6 ${PYTHON_PN}-lang \
7 ${PYTHON_PN}-textutils \
8"
diff --git a/meta-python/recipes-devtools/python/python3-sh_1.12.14.bb b/meta-python/recipes-devtools/python/python3-sh_1.12.14.bb
new file mode 100644
index 000000000..812bd4b1a
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-sh_1.12.14.bb
@@ -0,0 +1,5 @@
1require python-sh.inc
2inherit setuptools3
3
4RDEPENDS_${PN} += " \
5"