summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorBinghua Guan <freebendy@gmail.com>2018-08-08 13:43:22 +0000
committerKhem Raj <raj.khem@gmail.com>2018-08-10 12:51:21 -0700
commit98382d5c77900b504360e48ebdf4a4ef0082b9e1 (patch)
treec0c0c774aea70f259d17d3c510204dd3ee7ef9f5 /meta-python
parentde0149136450188c3c866478f843d484301d3c62 (diff)
downloadmeta-openembedded-98382d5c77900b504360e48ebdf4a4ef0082b9e1.tar.gz
meta-python: add python-pycodestyle recipe
Signed-off-by: Binghua Guan <freebendy@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-pycodestyle.inc12
-rw-r--r--meta-python/recipes-devtools/python/python-pycodestyle_2.4.0.bb4
-rw-r--r--meta-python/recipes-devtools/python/python3-pycodestyle_2.4.0.bb2
3 files changed, 18 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-pycodestyle.inc b/meta-python/recipes-devtools/python/python-pycodestyle.inc
new file mode 100644
index 000000000..c0e46b7ea
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pycodestyle.inc
@@ -0,0 +1,12 @@
1SUMMARY = "Python style guide checker (formly called pep8)"
2HOMEPAGE = "https://pypi.org/project/pycodestyle"
3LICENSE = "MIT"
4SECTION = "devel/python"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=01831ddbaf398471da3cc87f5037e822"
6
7SRC_URI[md5sum] = "85bbebd2c90d2f833c1db467d4d0e9a3"
8SRC_URI[sha256sum] = "cbfca99bd594a10f674d0cd97a3d802a1fdef635d4361e1a2658de47ed261e3a"
9
10inherit pypi
11
12BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python-pycodestyle_2.4.0.bb b/meta-python/recipes-devtools/python/python-pycodestyle_2.4.0.bb
new file mode 100644
index 000000000..7c736e76f
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pycodestyle_2.4.0.bb
@@ -0,0 +1,4 @@
1inherit setuptools
2require python-pycodestyle.inc
3
4RDEPENDS_${PN} += "${PYTHON_PN}-lang"
diff --git a/meta-python/recipes-devtools/python/python3-pycodestyle_2.4.0.bb b/meta-python/recipes-devtools/python/python3-pycodestyle_2.4.0.bb
new file mode 100644
index 000000000..cedcdb3bf
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pycodestyle_2.4.0.bb
@@ -0,0 +1,2 @@
1inherit setuptools3
2require python-pycodestyle.inc