summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorrichardhb <richardhb@weg.net>2023-05-23 07:41:35 -0300
committerKhem Raj <raj.khem@gmail.com>2023-05-23 15:04:38 -0700
commit761e5ffffd5fdf65341d528d07c200b97d3cc7c3 (patch)
treecb9e4d81e9ec59eaf7835e1617284c57f098bb9f /meta-python
parentb9366915d96c569e00da7f24fb2e037c808c5bf7 (diff)
downloadmeta-openembedded-761e5ffffd5fdf65341d528d07c200b97d3cc7c3.tar.gz
python3-bleak: add recipe
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-bleak/0001-fix-poetry-version-compatibility.patch21
-rw-r--r--meta-python/recipes-devtools/python/python3-bleak_0.20.2.bb20
2 files changed, 41 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-bleak/0001-fix-poetry-version-compatibility.patch b/meta-python/recipes-devtools/python/python3-bleak/0001-fix-poetry-version-compatibility.patch
new file mode 100644
index 000000000..cc568146d
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-bleak/0001-fix-poetry-version-compatibility.patch
@@ -0,0 +1,21 @@
1--- a/pyproject.toml 2023-04-19 19:04:47.159474100 -0300
2+++ b/pyproject.toml 2023-05-04 08:08:12.289941765 -0300
3@@ -31,15 +31,15 @@
4 bleak-winrt = { version = "^1.2.0", markers = "platform_system=='Windows'" }
5 dbus-fast = { version = "^1.83.0", markers = "platform_system == 'Linux'" }
6
7-[tool.poetry.group.docs.dependencies]
8+#[tool.poetry.group.docs.dependencies]
9 Sphinx = { version = "^5.1.1", python = ">=3.8" }
10 sphinx-rtd-theme = "^1.0.0"
11
12-[tool.poetry.group.lint.dependencies]
13+#[tool.poetry.group.lint.dependencies]
14 black = "^22.1.0"
15 flake8 = { version = "^5.0.0", python = ">=3.8" }
16
17-[tool.poetry.group.test.dependencies]
18+#[tool.poetry.group.test.dependencies]
19 asynctest = { version = "^0.13.0", python = "<3.8" }
20 pytest = "^7.0.0"
21 pytest-asyncio = "^0.19.0"
diff --git a/meta-python/recipes-devtools/python/python3-bleak_0.20.2.bb b/meta-python/recipes-devtools/python/python3-bleak_0.20.2.bb
new file mode 100644
index 000000000..9b81efe40
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-bleak_0.20.2.bb
@@ -0,0 +1,20 @@
1SUMMARY = "Bleak is a GATT client software, capable of connecting to BLE devices acting as GATT servers."
2HOMEPAGE = "https://github.com/hbldh/bleak"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=bcbc2069a86cba1b5e47253679f66ed7"
5
6SRC_URI:append = " \
7 file://0001-fix-poetry-version-compatibility.patch \
8"
9
10SRC_URI[sha256sum] = "6c92a47abe34e6dea8ffc5cea9457cbff6e1be966854839dbc25cddb36b79ee4"
11
12PYPI_PACKAGE = "bleak"
13
14inherit pypi python_poetry_core
15
16RDEPENDS:${PN} += " \
17 python3-core (>=3.7) \
18 python3-async-timeout \
19 python3-dbus-fast \
20"