summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorJustin Bronder <jsbronder@cold-front.org>2022-03-02 12:43:25 -0500
committerKhem Raj <raj.khem@gmail.com>2022-03-03 08:48:07 -0800
commit7513effd0df75d2d577d1931f2b6a3f5aae56442 (patch)
treee69c812ca0624a3cb29ee3af37482cf721f13db2 /meta-python
parentf7f407aa8101cb1ba55d7aa3fb9a887538b6d741 (diff)
downloadmeta-openembedded-7513effd0df75d2d577d1931f2b6a3f5aae56442.tar.gz
python3-pyscaffold: fix wheel build and license
Without python3-setuptools-scm-native, the version on the generated wheel is 0.0.0, not ${PV} as expected which causes pip_install_wheel_do_install to fail to find the wheel. Consulting the LICENSE.txt distributed with the source, the template files under pyscaffold.templates, which are installed as part of this recipe, are licensed as BSD-0-Clause Signed-off-by: Justin Bronder <jsbronder@cold-front.org> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-pyscaffold_4.1.4.bb14
1 files changed, 7 insertions, 7 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pyscaffold_4.1.4.bb b/meta-python/recipes-devtools/python/python3-pyscaffold_4.1.4.bb
index 7e5599e4a..fbba75c43 100644
--- a/meta-python/recipes-devtools/python/python3-pyscaffold_4.1.4.bb
+++ b/meta-python/recipes-devtools/python/python3-pyscaffold_4.1.4.bb
@@ -5,18 +5,18 @@ used to create template Projects."
5 5
6HOMEPAGE = "https://github.com/pyscaffold/pyscaffold" 6HOMEPAGE = "https://github.com/pyscaffold/pyscaffold"
7SECTION = "devel/python" 7SECTION = "devel/python"
8LICENSE = "MIT" 8LICENSE = "0BSD & MIT"
9LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=8227180126797a0148f94f483f3e1489" 9LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=14a49c74a1d91829908ac756c07e6b91"
10 10DEPENDS += "python3-setuptools-scm-native"
11inherit pypi setuptools3
12
13PYPI_PACKAGE = "PyScaffold"
14 11
15SRC_URI[sha256sum] = "46a2bbdf255ba2efc6c56ae1428249b61d56c4a3e54ef3db0d05fa97792011a5" 12SRC_URI[sha256sum] = "46a2bbdf255ba2efc6c56ae1428249b61d56c4a3e54ef3db0d05fa97792011a5"
16 13
17BBCLASSEXTEND = "native nativesdk" 14inherit pypi setuptools3
15PYPI_PACKAGE = "PyScaffold"
18 16
19RDEPENDS:${PN} += " \ 17RDEPENDS:${PN} += " \
20 python3-email \ 18 python3-email \
21 python3-compression \ 19 python3-compression \
22" 20"
21
22BBCLASSEXTEND = "native nativesdk"