summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorBartosz Golaszewski <brgl@bgdev.pl>2022-05-12 10:41:42 +0200
committerKhem Raj <raj.khem@gmail.com>2022-05-14 08:17:25 -0700
commit6e4ec4b18098928f3e9799f92d7eb8bd2afffe6c (patch)
treeefd62458ef4652877d2f8482b4c2133d2c3d0fa3 /meta-python
parentbecd9ec57a7b38279ea79708f583a5b2eba3f30d (diff)
downloadmeta-openembedded-6e4ec4b18098928f3e9799f92d7eb8bd2afffe6c.tar.gz
python3-eth-utils: new package
Add a recipe for eth-utils: utility functions for codebases which interact with ethereum. Signed-off-by: Bartosz Golaszewski <brgl@bgdev.pl> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb1
-rw-r--r--meta-python/recipes-devtools/python/python3-eth-utils/0001-setup-don-t-use-setuptools-markdown.patch37
-rw-r--r--meta-python/recipes-devtools/python/python3-eth-utils_2.0.0.bb16
3 files changed, 54 insertions, 0 deletions
diff --git a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
index d8cc9c0a5..11de569a9 100644
--- a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
+++ b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
@@ -112,6 +112,7 @@ RDEPENDS:packagegroup-meta-python3 = "\
112 python3-et-xmlfile \ 112 python3-et-xmlfile \
113 python3-eth-hash \ 113 python3-eth-hash \
114 python3-eth-typing \ 114 python3-eth-typing \
115 python3-eth-utils \
115 python3-evdev \ 116 python3-evdev \
116 python3-execnet \ 117 python3-execnet \
117 python3-fann2 \ 118 python3-fann2 \
diff --git a/meta-python/recipes-devtools/python/python3-eth-utils/0001-setup-don-t-use-setuptools-markdown.patch b/meta-python/recipes-devtools/python/python3-eth-utils/0001-setup-don-t-use-setuptools-markdown.patch
new file mode 100644
index 000000000..3c3c5270a
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-eth-utils/0001-setup-don-t-use-setuptools-markdown.patch
@@ -0,0 +1,37 @@
1From bc86d603e632ce61de4ae7a5d4bcef080cbdb160 Mon Sep 17 00:00:00 2001
2From: Bartosz Golaszewski <brgl@bgdev.pl>
3Date: Wed, 11 May 2022 13:45:06 +0200
4Subject: [PATCH] setup: don't use setuptools-markdown
5
6This project is deprecated and irrelevant for the functionality of
7eth-utils. We don't support it in meta-python so just drop it from
8the dependencies.
9
10Signed-off-by: Bartosz Golaszewski <brgl@bgdev.pl>
11---
12 setup.py | 2 --
13 1 file changed, 2 deletions(-)
14
15diff --git a/setup.py b/setup.py
16index 5717d5b..cb62132 100644
17--- a/setup.py
18+++ b/setup.py
19@@ -37,7 +37,6 @@ setup(
20 # *IMPORTANT*: Don't manually change the version here. Use the 'bumpversion' utility.
21 version='1.1.2',
22 description="""Common utility functions for ethereum codebases.""",
23- long_description_markdown_filename='README.md',
24 author='Piper Merriam',
25 author_email='pipermerriam@gmail.com',
26 url='https://github.com/ethereum/eth_utils',
27@@ -48,7 +47,6 @@ setup(
28 "toolz>0.8.2,<1;implementation_name=='pypy'",
29 "cytoolz>=0.8.2,<1.0.0;implementation_name=='cpython'",
30 ],
31- setup_requires=['setuptools-markdown'],
32 extras_require=extras_require,
33 py_modules=['eth_utils'],
34 license="MIT",
35--
362.34.1
37
diff --git a/meta-python/recipes-devtools/python/python3-eth-utils_2.0.0.bb b/meta-python/recipes-devtools/python/python3-eth-utils_2.0.0.bb
new file mode 100644
index 000000000..ff7caf5bf
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-eth-utils_2.0.0.bb
@@ -0,0 +1,16 @@
1SUMMARY = "Common utility functions for codebases which interact with ethereum."
2HOMEPAGE = "https://github.com/ethereum/eth-utils"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=287820ad3553117aa2f92bf84c219324"
6
7SRC_URI[sha256sum] = "32f50edb14c5be0c4f0e8c2e6117286ccc5dfda21d170f358add554a048398e3"
8
9inherit pypi setuptools3
10
11RDEPENDS:${PN} += " \
12 python3-eth-hash \
13 python3-eth-typing \
14 python3-setuptools \
15 python3-toolz \
16"