diff options
author | Leon Anavi <leon.anavi@konsulko.com> | 2022-09-14 14:58:31 +0300 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2022-09-14 11:25:11 -0700 |
commit | 6b27fa1d5c3fcd92ec6da5e4ce43164b55131baa (patch) | |
tree | bd4f273bcfae9ab46d7558743e45d885be5ea8b0 /meta-python | |
parent | 782fbe54d4e2ad7baa821382449c9f3c6ebc4214 (diff) | |
download | meta-openembedded-6b27fa1d5c3fcd92ec6da5e4ce43164b55131baa.tar.gz |
python3-pydantic: Upgrade 1.9.1 -> 1.10.2
Upgrade to release 1.10.2:
- Revert Change: Revert percent encoding of URL parts
- Prevent long (length > 4_300) strings/bytes as input to int
fields, see python/cpython#95778 and CVE-2020-10735
- fix: dataclass wrapper was not always called
- Use tomllib on Python 3.11 when parsing mypy configuration
- Basic fix of GenericModel cache to detect order of arguments in
Union models
- Fix mypy plugin when using bare types like list and dict as
default_factory
Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-pydantic_1.10.2.bb | 20 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-pydantic_1.9.1.bb | 11 |
2 files changed, 20 insertions, 11 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pydantic_1.10.2.bb b/meta-python/recipes-devtools/python/python3-pydantic_1.10.2.bb new file mode 100644 index 0000000000..16bb1f6ae6 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-pydantic_1.10.2.bb | |||
@@ -0,0 +1,20 @@ | |||
1 | SUMMARY = "Data validation and settings management using Python type hinting" | ||
2 | HOMEPAGE = "https://github.com/samuelcolvin/pydantic" | ||
3 | LICENSE = "MIT" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=2c02ea30650b91528657db64baea1757" | ||
5 | |||
6 | inherit pypi setuptools3 | ||
7 | |||
8 | SRC_URI[sha256sum] = "91b8e218852ef6007c2b98cd861601c6a09f1aa32bbbb74fab5b1c33d4a1e410" | ||
9 | |||
10 | RDEPENDS:${PN} += "\ | ||
11 | ${PYTHON_PN}-typing-extensions \ | ||
12 | ${PYTHON_PN}-core \ | ||
13 | ${PYTHON_PN}-numbers \ | ||
14 | ${PYTHON_PN}-json \ | ||
15 | ${PYTHON_PN}-datetime \ | ||
16 | ${PYTHON_PN}-io \ | ||
17 | ${PYTHON_PN}-netclient \ | ||
18 | ${PYTHON_PN}-image \ | ||
19 | ${PYTHON_PN}-logging \ | ||
20 | " | ||
diff --git a/meta-python/recipes-devtools/python/python3-pydantic_1.9.1.bb b/meta-python/recipes-devtools/python/python3-pydantic_1.9.1.bb deleted file mode 100644 index 1d113c9c50..0000000000 --- a/meta-python/recipes-devtools/python/python3-pydantic_1.9.1.bb +++ /dev/null | |||
@@ -1,11 +0,0 @@ | |||
1 | SUMMARY = "Data validation and settings management using Python type hinting" | ||
2 | HOMEPAGE = "https://github.com/samuelcolvin/pydantic" | ||
3 | LICENSE = "MIT" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=2c02ea30650b91528657db64baea1757" | ||
5 | RDEPENDS:${PN} += "\ | ||
6 | python3-typing-extensions \ | ||
7 | " | ||
8 | |||
9 | inherit pypi setuptools3 | ||
10 | |||
11 | SRC_URI[sha256sum] = "1ed987c3ff29fff7fd8c3ea3a3ea877ad310aae2ef9889a119e22d3f2db0691a" | ||