summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2020-04-05 14:39:22 -0400
committerKhem Raj <raj.khem@gmail.com>2020-04-05 14:27:45 -0700
commit657c3cd872cda82b3ab35d9037abd2befe645206 (patch)
tree4315df0eefd1472911dcaa580c4b25644acde619 /meta-python
parent4c359aa7c20da32f18c5934f58ab4dadb07f2596 (diff)
downloadmeta-openembedded-657c3cd872cda82b3ab35d9037abd2befe645206.tar.gz
python-pyinotify: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-pyinotify.inc16
-rw-r--r--meta-python/recipes-devtools/python/python3-pyinotify_0.9.6.bb18
2 files changed, 16 insertions, 18 deletions
diff --git a/meta-python/recipes-devtools/python/python-pyinotify.inc b/meta-python/recipes-devtools/python/python-pyinotify.inc
deleted file mode 100644
index 21abdb84f..000000000
--- a/meta-python/recipes-devtools/python/python-pyinotify.inc
+++ /dev/null
@@ -1,16 +0,0 @@
1DESCRIPTION = "Python pyinotify: Linux filesystem events monitoring"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://COPYING;md5=ab173cade7965b411528464589a08382"
4
5RDEPENDS_${PN} += "\
6 ${PYTHON_PN}-threading \
7 ${PYTHON_PN}-io \
8 ${PYTHON_PN}-misc \
9 ${PYTHON_PN}-shell \
10 ${PYTHON_PN}-smtpd \
11"
12
13SRC_URI[md5sum] = "8e580fa1ff3971f94a6f81672b76c406"
14SRC_URI[sha256sum] = "9c998a5d7606ca835065cdabc013ae6c66eb9ea76a00a1e3bc6e0cfe2b4f71f4"
15
16inherit pypi
diff --git a/meta-python/recipes-devtools/python/python3-pyinotify_0.9.6.bb b/meta-python/recipes-devtools/python/python3-pyinotify_0.9.6.bb
index b3bab989a..ab3395317 100644
--- a/meta-python/recipes-devtools/python/python3-pyinotify_0.9.6.bb
+++ b/meta-python/recipes-devtools/python/python3-pyinotify_0.9.6.bb
@@ -1,2 +1,16 @@
1inherit setuptools3 1DESCRIPTION = "Python pyinotify: Linux filesystem events monitoring"
2require python-pyinotify.inc 2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://COPYING;md5=ab173cade7965b411528464589a08382"
4
5RDEPENDS_${PN} += "\
6 ${PYTHON_PN}-threading \
7 ${PYTHON_PN}-io \
8 ${PYTHON_PN}-misc \
9 ${PYTHON_PN}-shell \
10 ${PYTHON_PN}-smtpd \
11"
12
13SRC_URI[md5sum] = "8e580fa1ff3971f94a6f81672b76c406"
14SRC_URI[sha256sum] = "9c998a5d7606ca835065cdabc013ae6c66eb9ea76a00a1e3bc6e0cfe2b4f71f4"
15
16inherit pypi setuptools3