summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorZang Ruochen <zangrc.fnst@cn.fujitsu.com>2020-03-20 10:21:33 +0800
committerKhem Raj <raj.khem@gmail.com>2020-03-20 07:44:29 -0700
commit5c474d09a8497ee0c8dd2561311d614e7cc05c44 (patch)
tree32b49157477ee659828bd514cdd6287a6a273f68 /meta-python
parent54201bae76ddfeaebb077c79fdf28740de76d88e (diff)
downloadmeta-openembedded-5c474d09a8497ee0c8dd2561311d614e7cc05c44.tar.gz
python3-xmltodict: Enable ptest
Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-xmltodict/run-ptest3
-rw-r--r--meta-python/recipes-devtools/python/python3-xmltodict_0.12.0.bb15
2 files changed, 17 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-xmltodict/run-ptest b/meta-python/recipes-devtools/python/python3-xmltodict/run-ptest
new file mode 100644
index 000000000..5cec71169
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-xmltodict/run-ptest
@@ -0,0 +1,3 @@
1#!/bin/sh
2
3pytest
diff --git a/meta-python/recipes-devtools/python/python3-xmltodict_0.12.0.bb b/meta-python/recipes-devtools/python/python3-xmltodict_0.12.0.bb
index 00aa81809..d07888324 100644
--- a/meta-python/recipes-devtools/python/python3-xmltodict_0.12.0.bb
+++ b/meta-python/recipes-devtools/python/python3-xmltodict_0.12.0.bb
@@ -9,4 +9,17 @@ SRC_URI[sha256sum] = "50d8c638ed7ecb88d90561beedbf720c9b4e851a9fa6c47ebd64e99d16
9 9
10PYPI_PACKAGE = "xmltodict" 10PYPI_PACKAGE = "xmltodict"
11 11
12inherit pypi setuptools3 12inherit pypi setuptools3 ptest
13
14SRC_URI += " \
15 file://run-ptest \
16"
17
18RDEPENDS_${PN}-ptest += " \
19 ${PYTHON_PN}-pytest \
20"
21
22do_install_ptest() {
23 install -d ${D}${PTEST_PATH}/tests
24 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
25}