diff options
author | Khem Raj <raj.khem@gmail.com> | 2023-03-01 20:20:42 -0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-03-01 20:22:25 -0800 |
commit | 4e84bef8912e40bbbede22e5e4f662b44dfdfc16 (patch) | |
tree | f7720c44a342c73f20c3a47ad6665eaa9748bc17 /meta-python | |
parent | ebcce220ccb99e6adc01fc0c6c4bcf1979f567e0 (diff) | |
download | meta-openembedded-4e84bef8912e40bbbede22e5e4f662b44dfdfc16.tar.gz |
python3-h5py: Upgrade to 3.8.0
Drop unused patches
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-h5py/0001-fix-wrong-file-driver-version.patch | 53 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-h5py/0001-setup.py-Fix-numpy-version.patch | 28 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-h5py_3.8.0.bb (renamed from meta-python/recipes-devtools/python/python3-h5py_3.7.0.bb) | 9 |
3 files changed, 3 insertions, 87 deletions
diff --git a/meta-python/recipes-devtools/python/python3-h5py/0001-fix-wrong-file-driver-version.patch b/meta-python/recipes-devtools/python/python3-h5py/0001-fix-wrong-file-driver-version.patch deleted file mode 100644 index 2692acde7..000000000 --- a/meta-python/recipes-devtools/python/python3-h5py/0001-fix-wrong-file-driver-version.patch +++ /dev/null | |||
@@ -1,53 +0,0 @@ | |||
1 | From 5b0b1d0b941ba338d449f9261bdf4cb2b679d048 Mon Sep 17 00:00:00 2001 | ||
2 | From: Hongxu Jia <hongxu.jia@windriver.com> | ||
3 | Date: Tue, 20 Sep 2022 02:53:11 -0700 | ||
4 | Subject: [PATCH] fix wrong file driver version | ||
5 | |||
6 | Due to commit [1] applied in hdf5 (1.13.2), import hdf5 failed | ||
7 | |||
8 | |>>> import h5py | ||
9 | |Traceback (most recent call last): | ||
10 | | File "<stdin>", line 1, in <module> | ||
11 | | File "/usr/lib/python3.10/site-packages/h5py/__init__.py", line 56, in <module> | ||
12 | | from . import h5a, h5d, h5ds, h5f, h5fd, h5g, h5r, h5s, h5t, h5p, h5z, h5pl | ||
13 | | File "h5py/h5fd.pyx", line 220, in init h5py.h5fd | ||
14 | |RuntimeError: Wrong file driver version # (wrong file driver version #) | ||
15 | |||
16 | Initial driver version to fix the error | ||
17 | |||
18 | [1] https://github.com/HDFGroup/hdf5/commit/42b767fc67ad1e13735e3cee2077f2e108f9463e | ||
19 | |||
20 | Upstream-Status: Submitted [https://github.com/h5py/h5py/pull/2153] | ||
21 | Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> | ||
22 | --- | ||
23 | h5py/api_types_hdf5.pxd | 1 + | ||
24 | h5py/h5fd.pyx | 1 + | ||
25 | 2 files changed, 2 insertions(+) | ||
26 | |||
27 | diff --git a/h5py/api_types_hdf5.pxd b/h5py/api_types_hdf5.pxd | ||
28 | index 6977f1a7..312fdaa0 100644 | ||
29 | --- a/h5py/api_types_hdf5.pxd | ||
30 | +++ b/h5py/api_types_hdf5.pxd | ||
31 | @@ -237,6 +237,7 @@ cdef extern from "hdf5.h": | ||
32 | |||
33 | # Class information for each file driver | ||
34 | ctypedef struct H5FD_class_t: | ||
35 | + unsigned version; | ||
36 | const char *name | ||
37 | haddr_t maxaddr | ||
38 | H5F_close_degree_t fc_degree | ||
39 | diff --git a/h5py/h5fd.pyx b/h5py/h5fd.pyx | ||
40 | index 04aff077..d41953d0 100644 | ||
41 | --- a/h5py/h5fd.pyx | ||
42 | +++ b/h5py/h5fd.pyx | ||
43 | @@ -191,6 +191,7 @@ cdef herr_t H5FD_fileobj_flush(H5FD_fileobj_t *f, hid_t dxpl, hbool_t closing) e | ||
44 | cdef H5FD_class_t info | ||
45 | memset(&info, 0, sizeof(info)) | ||
46 | |||
47 | +info.version = 0x01 | ||
48 | info.name = 'fileobj' | ||
49 | info.maxaddr = libc.stdint.SIZE_MAX - 1 | ||
50 | info.fc_degree = H5F_CLOSE_WEAK | ||
51 | -- | ||
52 | 2.37.1 | ||
53 | |||
diff --git a/meta-python/recipes-devtools/python/python3-h5py/0001-setup.py-Fix-numpy-version.patch b/meta-python/recipes-devtools/python/python3-h5py/0001-setup.py-Fix-numpy-version.patch deleted file mode 100644 index 9b79cc539..000000000 --- a/meta-python/recipes-devtools/python/python3-h5py/0001-setup.py-Fix-numpy-version.patch +++ /dev/null | |||
@@ -1,28 +0,0 @@ | |||
1 | From b1d4d171fd13624f3d8bb917f716b62494066501 Mon Sep 17 00:00:00 2001 | ||
2 | From: Leon Anavi <leon.anavi@konsulko.com> | ||
3 | Date: Mon, 22 Feb 2021 18:42:43 +0200 | ||
4 | Subject: [PATCH] setup.py: Fix numpy version | ||
5 | |||
6 | Fix numpy version to ensure bitbake will find the pip package. | ||
7 | |||
8 | Upstream-Status: Inappropriate [oe specific] | ||
9 | |||
10 | Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> | ||
11 | |||
12 | --- | ||
13 | setup.py | 2 +- | ||
14 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
15 | |||
16 | diff --git a/setup.py b/setup.py | ||
17 | index 4b2890c..42ba21b 100755 | ||
18 | --- a/setup.py | ||
19 | +++ b/setup.py | ||
20 | @@ -49,7 +49,7 @@ SETUP_REQUIRES = [ | ||
21 | "Cython >=0.29.14; python_version=='3.8'", | ||
22 | "Cython >=0.29.15; python_version>='3.9'", | ||
23 | ] + [ | ||
24 | - f"numpy =={np_min}; python_version{py_condition}" | ||
25 | + f"numpy >={np_min}; python_version{py_condition}" | ||
26 | for np_min, py_condition in NUMPY_MIN_VERSIONS | ||
27 | ] | ||
28 | |||
diff --git a/meta-python/recipes-devtools/python/python3-h5py_3.7.0.bb b/meta-python/recipes-devtools/python/python3-h5py_3.8.0.bb index ce4f05dbe..75a41e29d 100644 --- a/meta-python/recipes-devtools/python/python3-h5py_3.7.0.bb +++ b/meta-python/recipes-devtools/python/python3-h5py_3.8.0.bb | |||
@@ -4,12 +4,9 @@ SECTION = "devel/python" | |||
4 | LICENSE = "BSD-3-Clause" | 4 | LICENSE = "BSD-3-Clause" |
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=113251d71fb0384712c719b567261c5c" | 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=113251d71fb0384712c719b567261c5c" |
6 | 6 | ||
7 | SRC_URI[sha256sum] = "3fcf37884383c5da64846ab510190720027dca0768def34dd8dcb659dbe5cbf3" | 7 | SRC_URI[sha256sum] = "6fead82f0c4000cf38d53f9c030780d81bfa0220218aee13b90b7701c937d95f" |
8 | 8 | ||
9 | SRC_URI:append = " \ | 9 | SRC_URI += "file://0001-setup_build.py-avoid-absolute-path.patch" |
10 | file://0001-setup_build.py-avoid-absolute-path.patch \ | ||
11 | file://0001-fix-wrong-file-driver-version.patch \ | ||
12 | " | ||
13 | 10 | ||
14 | inherit pkgconfig pypi setuptools3 | 11 | inherit pkgconfig pypi setuptools3 |
15 | 12 | ||
@@ -29,4 +26,4 @@ RDEPENDS:${PN} = "python3-numpy \ | |||
29 | python3-json \ | 26 | python3-json \ |
30 | " | 27 | " |
31 | 28 | ||
32 | export HDF5_VERSION="1.13.2" | 29 | export HDF5_VERSION="1.14.0" |