summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2018-01-21 11:20:36 -0500
committerArmin Kuster <akuster808@gmail.com>2018-01-26 17:28:12 -0800
commit49b6db7e66bbff7ec0c1ddbd746c656004527db5 (patch)
tree86076e9004a9d167a85d066e9a6b5fe58304d3d2 /meta-python
parentaf8aff7b878ec08e3cba9e5fafe58b73f10bda44 (diff)
downloadmeta-openembedded-49b6db7e66bbff7ec0c1ddbd746c656004527db5.tar.gz
Remove deprecated python3-textutils from the RDEPENDS
The python3-textutils package was merged into core as part of the json manifest migration Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-asn1crypto.inc1
-rw-r--r--meta-python/recipes-devtools/python/python-asn1crypto_0.24.0.bb4
-rw-r--r--meta-python/recipes-devtools/python/python-jinja2.inc2
-rw-r--r--meta-python/recipes-devtools/python/python-jinja2_2.10.bb6
-rw-r--r--meta-python/recipes-devtools/python/python-jsonschema.inc1
-rw-r--r--meta-python/recipes-devtools/python/python-jsonschema_2.6.0.bb1
-rw-r--r--meta-python/recipes-devtools/python/python-netaddr.inc1
-rw-r--r--meta-python/recipes-devtools/python/python-netaddr_0.7.19.bb4
-rw-r--r--meta-python/recipes-devtools/python/python3-prompt-toolkit_1.0.15.bb1
9 files changed, 15 insertions, 6 deletions
diff --git a/meta-python/recipes-devtools/python/python-asn1crypto.inc b/meta-python/recipes-devtools/python/python-asn1crypto.inc
index 0d3ee4152..2777c215b 100644
--- a/meta-python/recipes-devtools/python/python-asn1crypto.inc
+++ b/meta-python/recipes-devtools/python/python-asn1crypto.inc
@@ -18,7 +18,6 @@ RDEPENDS_${PN}_class-target += " \
18 ${PYTHON_PN}-datetime \ 18 ${PYTHON_PN}-datetime \
19 ${PYTHON_PN}-io \ 19 ${PYTHON_PN}-io \
20 ${PYTHON_PN}-netclient \ 20 ${PYTHON_PN}-netclient \
21 ${PYTHON_PN}-textutils \
22 ${PYTHON_PN}-subprocess \ 21 ${PYTHON_PN}-subprocess \
23" 22"
24 23
diff --git a/meta-python/recipes-devtools/python/python-asn1crypto_0.24.0.bb b/meta-python/recipes-devtools/python/python-asn1crypto_0.24.0.bb
index 6af60c2d4..1218519ec 100644
--- a/meta-python/recipes-devtools/python/python-asn1crypto_0.24.0.bb
+++ b/meta-python/recipes-devtools/python/python-asn1crypto_0.24.0.bb
@@ -1,2 +1,6 @@
1inherit setuptools 1inherit setuptools
2require python-asn1crypto.inc 2require python-asn1crypto.inc
3
4RDEPENDS_${PN} += " \
5 ${PYTHON_PN}-textutils \
6"
diff --git a/meta-python/recipes-devtools/python/python-jinja2.inc b/meta-python/recipes-devtools/python/python-jinja2.inc
index 510765b28..0c0bf0def 100644
--- a/meta-python/recipes-devtools/python/python-jinja2.inc
+++ b/meta-python/recipes-devtools/python/python-jinja2.inc
@@ -8,7 +8,7 @@ SRC_URI[md5sum] = "61ef1117f945486472850819b8d1eb3d"
8SRC_URI[sha256sum] = "f84be1bb0040caca4cea721fcbbbbd61f9be9464ca236387158b0feea01914a4" 8SRC_URI[sha256sum] = "f84be1bb0040caca4cea721fcbbbbd61f9be9464ca236387158b0feea01914a4"
9 9
10RDEPENDS_${PN} += "${PYTHON_PN}-io ${PYTHON_PN}-pickle ${PYTHON_PN}-crypt \ 10RDEPENDS_${PN} += "${PYTHON_PN}-io ${PYTHON_PN}-pickle ${PYTHON_PN}-crypt \
11 ${PYTHON_PN}-math ${PYTHON_PN}-netclient ${PYTHON_PN}-textutils \ 11 ${PYTHON_PN}-math ${PYTHON_PN}-netclient \
12 ${PYTHON_PN}-pprint ${PYTHON_PN}-shell ${PYTHON_PN}-markupsafe \ 12 ${PYTHON_PN}-pprint ${PYTHON_PN}-shell ${PYTHON_PN}-markupsafe \
13 ${PYTHON_PN}-json ${PYTHON_PN}-threading ${PYTHON_PN}-numbers" 13 ${PYTHON_PN}-json ${PYTHON_PN}-threading ${PYTHON_PN}-numbers"
14 14
diff --git a/meta-python/recipes-devtools/python/python-jinja2_2.10.bb b/meta-python/recipes-devtools/python/python-jinja2_2.10.bb
index 06075213f..5233cf40c 100644
--- a/meta-python/recipes-devtools/python/python-jinja2_2.10.bb
+++ b/meta-python/recipes-devtools/python/python-jinja2_2.10.bb
@@ -1,4 +1,8 @@
1inherit pypi setuptools 1inherit pypi setuptools
2require python-jinja2.inc 2require python-jinja2.inc
3 3
4RDEPENDS_${PN} += "${PYTHON_PN}-lang ${PYTHON_PN}-re" 4RDEPENDS_${PN} += " \
5 ${PYTHON_PN}-lang \
6 ${PYTHON_PN}-re \
7 ${PYTHON_PN}-textutils \
8"
diff --git a/meta-python/recipes-devtools/python/python-jsonschema.inc b/meta-python/recipes-devtools/python/python-jsonschema.inc
index 748ef6e2e..841369292 100644
--- a/meta-python/recipes-devtools/python/python-jsonschema.inc
+++ b/meta-python/recipes-devtools/python/python-jsonschema.inc
@@ -19,7 +19,6 @@ RDEPENDS_${PN} += " \
19 ${PYTHON_PN}-shell \ 19 ${PYTHON_PN}-shell \
20 ${PYTHON_PN}-strict-rfc3339 \ 20 ${PYTHON_PN}-strict-rfc3339 \
21 ${PYTHON_PN}-subprocess \ 21 ${PYTHON_PN}-subprocess \
22 ${PYTHON_PN}-textutils \
23 ${PYTHON_PN}-unittest \ 22 ${PYTHON_PN}-unittest \
24" 23"
25 24
diff --git a/meta-python/recipes-devtools/python/python-jsonschema_2.6.0.bb b/meta-python/recipes-devtools/python/python-jsonschema_2.6.0.bb
index c118f2d8a..740761633 100644
--- a/meta-python/recipes-devtools/python/python-jsonschema_2.6.0.bb
+++ b/meta-python/recipes-devtools/python/python-jsonschema_2.6.0.bb
@@ -7,4 +7,5 @@ RDEPENDS_${PN} += " \
7 ${PYTHON_PN}-functools32 \ 7 ${PYTHON_PN}-functools32 \
8 ${PYTHON_PN}-lang \ 8 ${PYTHON_PN}-lang \
9 ${PYTHON_PN}-re \ 9 ${PYTHON_PN}-re \
10 ${PYTHON_PN}-textutils \
10" 11"
diff --git a/meta-python/recipes-devtools/python/python-netaddr.inc b/meta-python/recipes-devtools/python/python-netaddr.inc
index 486bfc600..5b6d4dffa 100644
--- a/meta-python/recipes-devtools/python/python-netaddr.inc
+++ b/meta-python/recipes-devtools/python/python-netaddr.inc
@@ -9,6 +9,5 @@ inherit pypi
9 9
10RDEPENDS_${PN} += " \ 10RDEPENDS_${PN} += " \
11 ${PYTHON_PN}-pprint \ 11 ${PYTHON_PN}-pprint \
12 ${PYTHON_PN}-textutils \
13 ${PYTHON_PN}-xml \ 12 ${PYTHON_PN}-xml \
14" 13"
diff --git a/meta-python/recipes-devtools/python/python-netaddr_0.7.19.bb b/meta-python/recipes-devtools/python/python-netaddr_0.7.19.bb
index 5e089a90f..ca5a79a78 100644
--- a/meta-python/recipes-devtools/python/python-netaddr_0.7.19.bb
+++ b/meta-python/recipes-devtools/python/python-netaddr_0.7.19.bb
@@ -1,2 +1,6 @@
1require python-netaddr.inc 1require python-netaddr.inc
2inherit setuptools 2inherit setuptools
3
4RDEPENDS_${PN} += " \
5 ${PYTHON_PN}-textutils \
6"
diff --git a/meta-python/recipes-devtools/python/python3-prompt-toolkit_1.0.15.bb b/meta-python/recipes-devtools/python/python3-prompt-toolkit_1.0.15.bb
index 1067d156a..0e99917c2 100644
--- a/meta-python/recipes-devtools/python/python3-prompt-toolkit_1.0.15.bb
+++ b/meta-python/recipes-devtools/python/python3-prompt-toolkit_1.0.15.bb
@@ -4,5 +4,4 @@ require python-prompt-toolkit.inc
4RDEPENDS_${PN} += " \ 4RDEPENDS_${PN} += " \
5 ${PYTHON_PN}-datetime \ 5 ${PYTHON_PN}-datetime \
6 ${PYTHON_PN}-shell \ 6 ${PYTHON_PN}-shell \
7 ${PYTHON_PN}-textutils \
8" 7"