summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2024-03-22 19:56:07 +0200
committerKhem Raj <raj.khem@gmail.com>2024-03-23 10:01:49 -0700
commit37594d354b993925d8ef02c8abe191e6c8e747cf (patch)
tree0914fc93c781bf8aa1e97321c069047fe4369e13 /meta-python
parentcf49617d4a5b3767a562552fceea926710aaf30a (diff)
downloadmeta-openembedded-37594d354b993925d8ef02c8abe191e6c8e747cf.tar.gz
python3-anyio: Upgrade 4.2.0 -> 4.3.0
Upgrade to version 4.3.0: - Added support for the Python 3.12 walk_up keyword argument in anyio.Path.relative_to() (PR by Colin Taylor) - Fixed passing total_tokens to anyio.CapacityLimiter() as a keyword argument not working on the trio backend (#515) - Fixed Process.aclose() not performing the minimum level of necessary cleanup when cancelled. Previously: - Cancellation of Process.aclose() could leak an orphan process - Cancellation of run_process() could very briefly leak an orphan process. - Cancellation of Process.aclose() or run_process() on Trio could leave standard streams unclosed - Fixed Process.stdin.aclose(), Process.stdout.aclose(), and Process.stderr.aclose() not including a checkpoint on asyncio - Fixed documentation on how to provide your own typed attributes Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-anyio_4.3.0.bb (renamed from meta-python/recipes-devtools/python/python3-anyio_4.2.0.bb)6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-anyio_4.2.0.bb b/meta-python/recipes-devtools/python/python3-anyio_4.3.0.bb
index 0bf907de7..2c7a9f8ca 100644
--- a/meta-python/recipes-devtools/python/python3-anyio_4.2.0.bb
+++ b/meta-python/recipes-devtools/python/python3-anyio_4.3.0.bb
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=c0a769411d2af7894099e8ff75058c9f"
5 5
6inherit pypi python_setuptools_build_meta 6inherit pypi python_setuptools_build_meta
7 7
8SRC_URI[sha256sum] = "e1875bb4b4e2de1669f4bc7869b6d3f54231cdced71605e6e64c9be77e3be50f" 8SRC_URI[sha256sum] = "f75253795a87df48568485fd18cdd2a3fa5c4f7c5be8e5e36637733fce06fed6"
9 9
10DEPENDS += " \ 10DEPENDS += " \
11 python3-setuptools-scm-native \ 11 python3-setuptools-scm-native \
@@ -20,4 +20,8 @@ DEPENDS += " \
20RDEPENDS:${PN} += "\ 20RDEPENDS:${PN} += "\
21 python3-idna \ 21 python3-idna \
22 python3-sniffio \ 22 python3-sniffio \
23 python3-core \
24 python3-numbers \
25 python3-io \
26 python3-asyncio \
23" 27"