diff options
author | Ross Burton <ross@burtonini.com> | 2022-01-14 13:53:52 +0000 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2022-01-18 08:59:58 -0800 |
commit | 33ef3173d235c9dd521f9d52099dd409787a6305 (patch) | |
tree | 30c6e933519d00ff2f533b348186d9f7f6ebeb06 /meta-python | |
parent | 84769a963974cffc5d877e57a46a289a84bc293d (diff) | |
download | meta-openembedded-33ef3173d235c9dd521f9d52099dd409787a6305.tar.gz |
python3-smbus: use setuptools
Port the use of distutils to setuptools, as distutils is deprecated.
Signed-off-by: Ross Burton <ross.burton@arm.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-smbus/0001-Use-setuptools-as-distutils-is-deprecated.patch | 25 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-smbus_4.3.bb | 8 |
2 files changed, 30 insertions, 3 deletions
diff --git a/meta-python/recipes-devtools/python/python3-smbus/0001-Use-setuptools-as-distutils-is-deprecated.patch b/meta-python/recipes-devtools/python/python3-smbus/0001-Use-setuptools-as-distutils-is-deprecated.patch new file mode 100644 index 000000000..6aafd6a95 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-smbus/0001-Use-setuptools-as-distutils-is-deprecated.patch | |||
@@ -0,0 +1,25 @@ | |||
1 | Upstream-Status: Submitted [https://lore.kernel.org/linux-i2c/20220114134910.3994688-1-ross.burton@arm.com/T/#u] | ||
2 | Signed-off-by: Ross Burton <ross.burton@arm.com> | ||
3 | |||
4 | From fa522a9a390b1857a58ec1f55da1465c542fd106 Mon Sep 17 00:00:00 2001 | ||
5 | From: Ross Burton <ross.burton@arm.com> | ||
6 | Date: Fri, 14 Jan 2022 13:38:34 +0000 | ||
7 | Subject: [PATCH] Use setuptools as distutils is deprecated | ||
8 | |||
9 | Signed-off-by: Ross Burton <ross.burton@arm.com> | ||
10 | --- | ||
11 | py-smbus/setup.py | 2 +- | ||
12 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
13 | |||
14 | diff --git a/py-smbus/setup.py b/py-smbus/setup.py | ||
15 | index 28a4500..26db33a 100644 | ||
16 | --- a/py-smbus/setup.py | ||
17 | +++ b/py-smbus/setup.py | ||
18 | @@ -1,6 +1,6 @@ | ||
19 | #!/usr/bin/env python | ||
20 | |||
21 | -from distutils.core import setup, Extension | ||
22 | +from setuptools import setup, Extension | ||
23 | |||
24 | setup( name="smbus", | ||
25 | version="1.1", | ||
diff --git a/meta-python/recipes-devtools/python/python3-smbus_4.3.bb b/meta-python/recipes-devtools/python/python3-smbus_4.3.bb index a09a108b3..ecdff3ada 100644 --- a/meta-python/recipes-devtools/python/python3-smbus_4.3.bb +++ b/meta-python/recipes-devtools/python/python3-smbus_4.3.bb | |||
@@ -2,13 +2,15 @@ SUMMARY = "Set of i2c tools for linux - Python module" | |||
2 | LICENSE = "GPLv2" | 2 | LICENSE = "GPLv2" |
3 | LIC_FILES_CHKSUM = "file://py-smbus/smbusmodule.c;beginline=1;endline=18;md5=46e424fb045901ab25e0f92c28c80055" | 3 | LIC_FILES_CHKSUM = "file://py-smbus/smbusmodule.c;beginline=1;endline=18;md5=46e424fb045901ab25e0f92c28c80055" |
4 | 4 | ||
5 | SRC_URI = "${KERNELORG_MIRROR}/software/utils/i2c-tools/i2c-tools-${PV}.tar.gz " | 5 | SRC_URI = "${KERNELORG_MIRROR}/software/utils/i2c-tools/i2c-tools-${PV}.tar.gz \ |
6 | file://0001-Use-setuptools-as-distutils-is-deprecated.patch \ | ||
7 | " | ||
6 | SRC_URI[sha256sum] = "eec464e42301d93586cbeca3845ed61bff40f560670e5b35baec57301d438148" | 8 | SRC_URI[sha256sum] = "eec464e42301d93586cbeca3845ed61bff40f560670e5b35baec57301d438148" |
7 | 9 | ||
8 | DEPENDS += "i2c-tools" | 10 | DEPENDS += "i2c-tools" |
9 | 11 | ||
10 | S = "${WORKDIR}/i2c-tools-${PV}" | 12 | S = "${WORKDIR}/i2c-tools-${PV}" |
11 | 13 | ||
12 | inherit distutils3 | 14 | inherit setuptools3 |
13 | 15 | ||
14 | DISTUTILS_SETUP_PATH = "${S}/py-smbus" | 16 | SETUPTOOLS_SETUP_PATH = "${S}/py-smbus" |