summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@arm.com>2024-08-06 17:39:17 +0100
committerKhem Raj <raj.khem@gmail.com>2024-08-09 14:25:28 -0700
commit301075cb5c1984cfd3b324a209ebf789c655fabb (patch)
treead6ce4dd7f69ab4812e449cdc76a14ce2065ad75 /meta-python
parent8103148564d2dc26db765b0409264b83698a83e4 (diff)
downloadmeta-openembedded-301075cb5c1984cfd3b324a209ebf789c655fabb.tar.gz
python3-toml: add from openembedded-core
This recipe is being removed from oe-core, so add to meta-python. Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-toml_0.10.2.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-toml_0.10.2.bb b/meta-python/recipes-devtools/python/python3-toml_0.10.2.bb
new file mode 100644
index 000000000..649464b96
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-toml_0.10.2.bb
@@ -0,0 +1,15 @@
1SUMMARY = "Python Library for Tom's Obvious, Minimal Language"
2HOMEPAGE = "https://github.com/uiri/toml"
3LICENSE = "MIT"
4SECTION = "devel/python"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=16c77b2b1050d2f03cb9c2ed0edaf4f0"
6
7SRC_URI[sha256sum] = "b3bda1d108d5dd99f4a20d24d9c348e91c4db7ab1b749200bded2f839ccbe68f"
8
9inherit pypi setuptools3
10
11BBCLASSEXTEND = "native nativesdk"
12
13RDEPENDS:${PN} += " \
14 python3-misc \
15"