summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2018-01-29 08:39:01 -0500
committerArmin Kuster <akuster808@gmail.com>2018-02-11 11:50:56 -0800
commit215dfc15581e90794df8a2c4cb498b3af32b843c (patch)
tree7cea153e94ee6f936d40aa91b4094c0425a3c604 /meta-python
parentedbe41f53ec15eeae4673498c41a1f3a42ac813b (diff)
downloadmeta-openembedded-215dfc15581e90794df8a2c4cb498b3af32b843c.tar.gz
python-yappi: add a python3 version of the recipe
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-yappi.inc16
-rw-r--r--meta-python/recipes-devtools/python/python-yappi_0.98.bb18
-rw-r--r--meta-python/recipes-devtools/python/python3-yappi_0.98.bb2
3 files changed, 20 insertions, 16 deletions
diff --git a/meta-python/recipes-devtools/python/python-yappi.inc b/meta-python/recipes-devtools/python/python-yappi.inc
new file mode 100644
index 000000000..651ce7731
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-yappi.inc
@@ -0,0 +1,16 @@
1SUMMARY = "Yet Another Python Profiler"
2HOMEPAGE = "http://yappi.googlecode.com/"
3
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://PKG-INFO;md5=6b131c3041637f6a5175a43112dde05c"
6
7SRC_URI[md5sum] = "dc56240575c99938a924eaeb7c0d8beb"
8SRC_URI[sha256sum] = "5f657129e1b9b952379ffbc009357d0dcdb58c50f3bfe88ffbb992e4b27b263c"
9
10inherit pypi setuptools
11
12RDEPENDS_${PN} += "\
13 ${PYTHON_PN}-datetime \
14 ${PYTHON_PN}-pickle \
15 ${PYTHON_PN}-threading \
16 "
diff --git a/meta-python/recipes-devtools/python/python-yappi_0.98.bb b/meta-python/recipes-devtools/python/python-yappi_0.98.bb
index 651ce7731..a3bdde5c2 100644
--- a/meta-python/recipes-devtools/python/python-yappi_0.98.bb
+++ b/meta-python/recipes-devtools/python/python-yappi_0.98.bb
@@ -1,16 +1,2 @@
1SUMMARY = "Yet Another Python Profiler" 1require python-yappi.inc
2HOMEPAGE = "http://yappi.googlecode.com/" 2inherit setuptools
3
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://PKG-INFO;md5=6b131c3041637f6a5175a43112dde05c"
6
7SRC_URI[md5sum] = "dc56240575c99938a924eaeb7c0d8beb"
8SRC_URI[sha256sum] = "5f657129e1b9b952379ffbc009357d0dcdb58c50f3bfe88ffbb992e4b27b263c"
9
10inherit pypi setuptools
11
12RDEPENDS_${PN} += "\
13 ${PYTHON_PN}-datetime \
14 ${PYTHON_PN}-pickle \
15 ${PYTHON_PN}-threading \
16 "
diff --git a/meta-python/recipes-devtools/python/python3-yappi_0.98.bb b/meta-python/recipes-devtools/python/python3-yappi_0.98.bb
new file mode 100644
index 000000000..07da5b6eb
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-yappi_0.98.bb
@@ -0,0 +1,2 @@
1require python-yappi.inc
2inherit setuptools3