diff options
author | Leon Anavi <leon.anavi@konsulko.com> | 2020-08-18 18:34:39 +0300 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2020-08-19 14:04:00 -0700 |
commit | 1e1451b8183c82ed6c1b74955b37fa8527268e9c (patch) | |
tree | 92b32a6e44ff66bdcae3958b0dc1c94f1d6eee3d /meta-python | |
parent | b04b6048f276cc4c755d0503ff59835933fb60c4 (diff) | |
download | meta-openembedded-1e1451b8183c82ed6c1b74955b37fa8527268e9c.tar.gz |
python3-sqlalchemy: Upgrade 1.3.18 -> 1.3.19
Upgrade to release 1.3.19:
- orm: Adjusted the workings of the Mapper.all_orm_descriptors()
accessor to represent the attributes in the order that they are
located in a deterministic way, assuming the use of Python 3.6
or higher which maintains the sorting order of class attributes
based on how they were declared. This sorting is not guaranteed
to match the declared order of attributes in all cases however;
see the method documentation for the exact scheme.
- orm: The name of the virtual column used when using the
AbstractConcreteBase and ConcreteBase classes can now be
customized, to allow for models that have a column that is
actually named type.
- sql: Repaired an issue where the "ORDER BY" clause rendering a
label name rather than a complete expression, which is
particularly important for SQL Server, would fail to occur if
the expression were enclosed in a parenthesized grouping in some
cases. This case has been added to test support. The change
additionally adjusts the "automatically add ORDER BY columns
when DISTINCT is present" behavior of ORM query, deprecated in
1.4, to more accurately detect column expressions that are
already present.
- mysql: The MySQL dialect will render FROM DUAL for a SELECT
statement that has no FROM clause but has a WHERE clause. This
allows things like "SELECT 1 WHERE EXISTS (subquery)" kinds of
queries to be used as well as other use cases.
- sqlite: Applied a sweep through all included dialects to ensure
names that contain single or double quotes are properly escaped
when querying system tables, for all Inspector methods that
accept object names as an argument (e.g. table names, view
names, etc). SQLite and MSSQL contained two quoting issues that
were repaired.
- mssql: Fixed bug where the mssql dialect incorrectly escaped
object names that contained ‘]’ character(s).
- Added a **kw argument to the DeclarativeMeta.__init__() method.
This allows a class to support the PEP 487 metaclass hook
__init_subclass__.
For more details have a look at the complete changelog:
https://docs.sqlalchemy.org/en/13/changelog/changelog_13.html
Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-sqlalchemy_1.3.19.bb (renamed from meta-python/recipes-devtools/python/python3-sqlalchemy_1.3.18.bb) | 4 |
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-sqlalchemy_1.3.18.bb b/meta-python/recipes-devtools/python/python3-sqlalchemy_1.3.19.bb index a5e1737b0..52e7bf376 100644 --- a/meta-python/recipes-devtools/python/python3-sqlalchemy_1.3.18.bb +++ b/meta-python/recipes-devtools/python/python3-sqlalchemy_1.3.19.bb | |||
@@ -4,8 +4,8 @@ HOMEPAGE = "http://www.sqlalchemy.org/" | |||
4 | LICENSE = "MIT" | 4 | LICENSE = "MIT" |
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=c19467890539ff718c00a019c9c7a7b2" | 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=c19467890539ff718c00a019c9c7a7b2" |
6 | 6 | ||
7 | SRC_URI[md5sum] = "96e085d318297b1ad36ef2685f54287a" | 7 | SRC_URI[md5sum] = "a5710b0aee19a743e513f3bf002072a8" |
8 | SRC_URI[sha256sum] = "da2fb75f64792c1fc64c82313a00c728a7c301efe6a60b7a9fe35b16b4368ce7" | 8 | SRC_URI[sha256sum] = "3bba2e9fbedb0511769780fe1d63007081008c5c2d7d715e91858c94dbaa260e" |
9 | 9 | ||
10 | PYPI_PACKAGE = "SQLAlchemy" | 10 | PYPI_PACKAGE = "SQLAlchemy" |
11 | inherit pypi setuptools3 | 11 | inherit pypi setuptools3 |