summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorDaniel Gomez <daniel@qtec.com>2022-03-01 14:45:47 +0100
committerKhem Raj <raj.khem@gmail.com>2022-03-03 08:48:06 -0800
commit048e1e40b216d3d00e555090e06d29170b5b14ba (patch)
tree53b745819e8ff897393c967082232b6ce0334965 /meta-python
parent87efb466499e4c211d864230134d3a96c0c45b92 (diff)
downloadmeta-openembedded-048e1e40b216d3d00e555090e06d29170b5b14ba.tar.gz
python3-flask-versioned: Fix PYPA_WHEEL name
Add function to generate expected PYPA_WHEEL name. Generated name: /yp/builds/meta-qtec-distro/tmp/work/dbfp4-poky-linux/python3-flask-versioned/0.9.4-20101221-r0/Flask-Versioned-0.9.4-20101221/dist/ Flask_Versioned-0.9.4.post20101221-py3-none-any.whl Default (wrong) name: Flask_Versioned-0.9.4-20101221-*.whl Error: WARNING: Requirement '/yp/builds/meta-qtec-distro/tmp/work/dbfp4-poky-linux/python3-flask-versioned/0.9.4-20101221-r0/Flask-Versioned-0.9.4-20101221/dist/Flask_Versioned-0.9.4-20101221-*.whl' looks like a filename, but the file does not exist ERROR: Flask_Versioned-0.9.4-20101221-*.whl is not a valid wheel filename. Signed-off-by: Daniel Gomez <daniel@qtec.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-flask-versioned_0.9.4-20101221.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-flask-versioned_0.9.4-20101221.bb b/meta-python/recipes-devtools/python/python3-flask-versioned_0.9.4-20101221.bb
index 7aaf439b8..04493b21d 100644
--- a/meta-python/recipes-devtools/python/python3-flask-versioned_0.9.4-20101221.bb
+++ b/meta-python/recipes-devtools/python/python3-flask-versioned_0.9.4-20101221.bb
@@ -7,3 +7,10 @@ PYPI_PACKAGE = "Flask-Versioned"
7SRC_URI[sha256sum] = "516694dc860a1bc4f22ab60b324a85083c0150522be109282a3bed681057fd34" 7SRC_URI[sha256sum] = "516694dc860a1bc4f22ab60b324a85083c0150522be109282a3bed681057fd34"
8 8
9inherit pypi setuptools3 9inherit pypi setuptools3
10
11def get_pypa_wheel_name(d):
12 return (d.getVar('PIP_INSTALL_DIST_PATH') + '/' + \
13 d.getVar('PIP_INSTALL_PACKAGE') + '-' + \
14 d.getVar('PV').replace('-', '.post') + '-*.whl')
15
16PYPA_WHEEL = "${@get_pypa_wheel_name(d)}"