summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-python/python/python-pyserial_2.4.bb
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2014-07-15 16:32:34 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2014-07-22 00:01:49 +0200
commita6d7ba92645a112af358efd94ff3aa0c74985a51 (patch)
tree6232bed0de0d30933326525b24e21ca8e4965237 /meta-python/recipes-python/python/python-pyserial_2.4.bb
parented634d36d64af846b68424d38eaa86b464584840 (diff)
downloadmeta-openembedded-a6d7ba92645a112af358efd94ff3aa0c74985a51.tar.gz
meta-python: move recipes from meta-oe
* Move recipes from meta-openembedded/meta-oe that are not depended upon by recipes already in meta-oe (e.g. gateone, anki) * Recipes NOT moved: python-futures python-pyopenssl python-simplejson python-tornado python-pyqt python-sip Signed-off-by: Tim Orling <TicoTimo@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-python/python/python-pyserial_2.4.bb')
-rw-r--r--meta-python/recipes-python/python/python-pyserial_2.4.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-python/recipes-python/python/python-pyserial_2.4.bb b/meta-python/recipes-python/python/python-pyserial_2.4.bb
new file mode 100644
index 000000000..2263b2ccc
--- /dev/null
+++ b/meta-python/recipes-python/python/python-pyserial_2.4.bb
@@ -0,0 +1,22 @@
1SUMMARY = "Serial Port Support for Python"
2SECTION = "devel/python"
3LICENSE = "PSF"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=7424386ffe323e815ee62ee9ad591dd8"
5SRCNAME = "pyserial"
6PR = "ml4"
7
8SRC_URI = "${SOURCEFORGE_MIRROR}/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
9S = "${WORKDIR}/${SRCNAME}-${PV}"
10
11inherit setuptools
12
13# FIXME might stop packaging serialwin32 and serialjava files
14
15RDEPENDS_${PN} = "\
16 python-fcntl \
17 python-io \
18 python-stringold \
19"
20
21SRC_URI[md5sum] = "eec19df59fd75ba5a136992897f8e468"
22SRC_URI[sha256sum] = "6b6a9e3d2fd5978c92c843e0109918a4bcac481eecae316254481c0e0f7e73c8"