summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-extended
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2018-03-06 20:17:32 -0500
committerArmin Kuster <akuster808@gmail.com>2018-03-12 10:01:16 -0700
commitaa997c97b30d016817dbf471536989c0e1b589ef (patch)
tree08391ab77c146a940ff8bc1fd9a48afa0f7acdd1 /meta-python/recipes-extended
parentc372e227e2b7bc019ee5d9a25e92ff7f654b98d7 (diff)
downloadmeta-openembedded-aa997c97b30d016817dbf471536989c0e1b589ef.tar.gz
python3-blivet: fix invoking dd timeout caused partition failed
This large timeout is needed when running on machines with lots of disks, or with slow disks. Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python/recipes-extended')
-rw-r--r--meta-python/recipes-extended/python-blivet/python3-blivet/0014-invoking-dd-with-infinite-timeout.patch31
-rw-r--r--meta-python/recipes-extended/python-blivet/python3-blivet_2.2.0.bb1
2 files changed, 32 insertions, 0 deletions
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivet/0014-invoking-dd-with-infinite-timeout.patch b/meta-python/recipes-extended/python-blivet/python3-blivet/0014-invoking-dd-with-infinite-timeout.patch
new file mode 100644
index 000000000..12a9e4f54
--- /dev/null
+++ b/meta-python/recipes-extended/python-blivet/python3-blivet/0014-invoking-dd-with-infinite-timeout.patch
@@ -0,0 +1,31 @@
1From 92fe7dfd01131c93a9b2013cabf77d5f46900fab Mon Sep 17 00:00:00 2001
2From: Hongxu Jia <hongxu.jia@windriver.com>
3Date: Tue, 6 Mar 2018 17:28:56 +0800
4Subject: [PATCH] invoking dd with infinite timeout
5
6This large timeout is needed when running on machines with
7lots of disks, or with slow disks.
8
9Upstream-Status: Pending
10
11Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
12---
13 blivet/devices/partition.py | 2 +-
14 1 file changed, 1 insertion(+), 1 deletion(-)
15
16diff --git a/blivet/devices/partition.py b/blivet/devices/partition.py
17index a7372fb..8947472 100644
18--- a/blivet/devices/partition.py
19+++ b/blivet/devices/partition.py
20@@ -594,7 +594,7 @@ class PartitionDevice(StorageDevice):
21 cmd = ["dd", "if=/dev/zero", "of=%s" % device, "bs=%d" % bs,
22 "seek=%d" % start, "count=%d" % count]
23 try:
24- util.run_program(cmd)
25+ util.run_program(cmd, timeout=-1)
26 except OSError as e:
27 log.error(str(e))
28 finally:
29--
301.8.3.1
31
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivet_2.2.0.bb b/meta-python/recipes-extended/python-blivet/python3-blivet_2.2.0.bb
index cacca67e2..46dc32de7 100644
--- a/meta-python/recipes-extended/python-blivet/python3-blivet_2.2.0.bb
+++ b/meta-python/recipes-extended/python-blivet/python3-blivet_2.2.0.bb
@@ -23,6 +23,7 @@ SRC_URI = "git://github.com/rhinstaller/blivet;branch=2.2-devel \
23 file://0011-invoking-fsck-with-infinite-timeout.patch \ 23 file://0011-invoking-fsck-with-infinite-timeout.patch \
24 file://0012-invoking-mkfs-with-infinite-timeout.patch \ 24 file://0012-invoking-mkfs-with-infinite-timeout.patch \
25 file://0013-Revert-Adapt-to-logging-module-name-change.patch \ 25 file://0013-Revert-Adapt-to-logging-module-name-change.patch \
26 file://0014-invoking-dd-with-infinite-timeout.patch \
26" 27"
27 28
28inherit distro_features_check 29inherit distro_features_check