summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-extended/pywbem
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-05-20 19:42:35 +0300
committerKhem Raj <raj.khem@gmail.com>2021-05-24 07:36:49 -0700
commit6818fcdbaec46021b423d20c946169eadf41d4e3 (patch)
treeab44b4f7a60c564ada1de68e816992d6e8051b48 /meta-python/recipes-extended/pywbem
parent9bd205e4171f3fb72da713dbdeb50f6a763bff26 (diff)
downloadmeta-openembedded-6818fcdbaec46021b423d20c946169eadf41d4e3.tar.gz
python3-pywbem: Upgrade 1.1.3 -> 1.2.0
Upgrade to release 1.2.0 with bug fixes and enhancements: - Finalized the pywbem mock support - Logging: Added a value 'off' for the log destination in the pywbem.configure_logging() function that disables logging - Improved exception handling during the parsing of CIM-XML responses received from a WBEM server - Reduced memory consumption of CIM objects and CIM types by defining their attributes to use Python slots - Reduced memory consumption of CIM objects by using lazy initialization of dictionary-type attributes - Unsupported versions for CIM infrastructure, DTD or protocol version returned in CIM-XML responses from WBEM servers are now raised as new exceptions pywbem - In the makefile, added an ignore list for issues reported by safety along with the reasons why each issue is ignored - Improvements in the log messages of the MOFCompiler class - Added a conn_close() method to the pywbem.MOFCompiler class that closes the underlying connection - Added 'make perftest' to run performance tests Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-extended/pywbem')
-rw-r--r--meta-python/recipes-extended/pywbem/python3-pywbem_1.2.0.bb (renamed from meta-python/recipes-extended/pywbem/python3-pywbem_1.1.3.bb)6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta-python/recipes-extended/pywbem/python3-pywbem_1.1.3.bb b/meta-python/recipes-extended/pywbem/python3-pywbem_1.2.0.bb
index fd7341953..988dae133 100644
--- a/meta-python/recipes-extended/pywbem/python3-pywbem_1.1.3.bb
+++ b/meta-python/recipes-extended/pywbem/python3-pywbem_1.2.0.bb
@@ -16,7 +16,7 @@ HOMEPAGE = "http://pywbem.github.io"
16LICENSE = "LGPLv2.1" 16LICENSE = "LGPLv2.1"
17LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=fbc093901857fcd118f065f900982c24" 17LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=fbc093901857fcd118f065f900982c24"
18 18
19SRC_URI[sha256sum] = "2abb6443f4debae56af7abefadb9fa5b8af9b53fc9bcf67f6c01a78db1064300" 19SRC_URI[sha256sum] = "8ef48185e0adbaeb9bd5181c4c5de951f6d58d54e2e1d7e87a9834e10eabe957"
20 20
21inherit pypi setuptools3 update-alternatives 21inherit pypi setuptools3 update-alternatives
22 22
@@ -24,6 +24,7 @@ DEPENDS += " \
24 ${PYTHON_PN}-ply-native \ 24 ${PYTHON_PN}-ply-native \
25 ${PYTHON_PN}-pyyaml-native \ 25 ${PYTHON_PN}-pyyaml-native \
26 ${PYTHON_PN}-six-native \ 26 ${PYTHON_PN}-six-native \
27 ${PYTHON_PN}-wheel-native \
27" 28"
28 29
29RDEPENDS_${PN}_class-target += "\ 30RDEPENDS_${PN}_class-target += "\
@@ -37,6 +38,9 @@ RDEPENDS_${PN}_class-target += "\
37 ${PYTHON_PN}-threading \ 38 ${PYTHON_PN}-threading \
38 ${PYTHON_PN}-unixadmin \ 39 ${PYTHON_PN}-unixadmin \
39 ${PYTHON_PN}-xml \ 40 ${PYTHON_PN}-xml \
41 ${PYTHON_PN}-nocasedict \
42 ${PYTHON_PN}-nocaselist \
43 ${PYTHON_PN}-yamlloader \
40" 44"
41 45
42ALTERNATIVE_${PN} = "mof_compiler" 46ALTERNATIVE_${PN} = "mof_compiler"